1. bertbear's Avatar
    I noticed today that the Gmail app on my phone is not showing all of my messages. By this I mean that if I log into Gmail from my PC it shows 8 messages received on 1/8/10. If I use my ERIS there is now only 1 message from that date showing. I have been checking for the last few hours, and the messages are slowly disappearing. I tried going to manage apps and cleared the Gmail apps data and cache to try to force a redownload of messages, but that did not help.

    I apologize if this is a question that has been asked before, I did not find anything about it throught the search function.

    Is anyone else having this problem, or have a solution?
    01-12-2010 07:11 PM
  2. doogald's Avatar
    In the "gmail" app, choose "menu", then "settings", then "labels". By default, gmail syncs 4 days in your inbox; from here, you can change it to "all". (You can also sync other labels in your gmail account, if you use labels.)
    R0tten likes this.
    01-12-2010 08:05 PM
  3. bertbear's Avatar
    That fixed it. The starred messages by default were set to not sync at all. The default settings just don't help for the way I use Gmail.

    Thanks
    01-13-2010 09:51 AM
  4. R0tten's Avatar
    It is now 2018 and this still fixed my problem. Ridiculous these options aren't default and not even shown or educated to the user upon first install! Thank you very much.
    doogald likes this.
    08-06-2018 09:18 PM
LINK TO POST COPIED TO CLIPBOARD