1. fuzmeister's Avatar
    So when I first rooted my phone and flashed it with KAOSFroyo V38, I set something somewhere to have wifi turn on automatically when the phone's charger is plugged in.

    Being that my memory is utter crap, I completely forgot where I set this. I tried looking in Cyanogen, ADW, and all the other settings I could think of, but nothing.

    Anyone have a clue where I could find this? Have I gone insane?

    - Steve
    01-23-2011 10:08 PM
  2. doogald's Avatar
    There is a setting that tells it not to turn off when you are plugged in, in settings->wireless & networks->WiFi settings, press menu, Advanced settings.

    But you don't have an app like JuiceDefender, maybe?
    01-24-2011 10:02 AM
  3. fuzmeister's Avatar
    Yeah, I looked at those settings.

    It's actually a setting somewhere that says "enable wifi when charger is plugged in."

    I've been beating my head against the wall for a week trying to remember and have done a bunch of searches on google.

    Here are the apps I have installed that would have to do with system settings:
    - ADWLauncher
    - AutoKiller Memory Optimizer
    - CyanogenMod (2.2.1)
    - Dev Tools
    - Spare Parts

    Either way, any thoughts on the matter are appreciated. I just feel like a fool for not remembering where I set this scheme up.

    - Steve
    01-24-2011 10:27 AM
  4. fuzmeister's Avatar
    I checked out some info on CyanogenMod and I noticed my version numbering might be wrong. I just wanted to say that the CyanogenMod version I pulled was out of Titanium Backup, not my *** (just to clarify)

    Since I'm using KAOSFroyo, it came bundled with the ROM.

    - Steve
    01-24-2011 10:32 AM
  5. gopher1's Avatar
    I, too, am having this exact same problem. I checked all the settings on the phone and a number of apps that I thought might have had the option to set wifi on when the phone is plugged in. I'm running launcherpro and thought that it might be in the ADW settings somewhere so I loaded that and still nothing in the settings for ADW or launcherpro. There must be an app somewhere or a setting that did this.

    I specifically remember what the page looked like, too. It had a list of settings where you could change wifi turning on when plugged in and off when unplugged. There were also options for turning on/off other settings under certain conditions like 3g/2g access, screen brightness, etc. It seems like that would be an app but I really don't remember. Is it possible that it was something that I set up when first booting into cyanogenmod?
    01-29-2011 12:50 PM
  6. doogald's Avatar
    You're not running an app like JuiceDefender, are you?
    01-29-2011 01:32 PM
  7. gopher1's Avatar
    No, I'm not running any app called JuiceDefender. If I did have that app installed would I be able to turn this setting off maybe? Also what does JuiceDefender do because maybe there's a setting that I can find that sounds like what that app does that will lead me to the solution.
    01-30-2011 07:41 PM
  8. tropper's Avatar
    It seems to me that Ive seen that somewhere in build V38 also. Lemme look it up. Also Settings>about phone will show the build number
    01-31-2011 12:00 PM
  9. tropper's Avatar
    Ok found it menu path as follows Settings>Wi-Fi settings>menu button>Advanced>Wi-Fisleep policy
    01-31-2011 12:10 PM
  10. gopher1's Avatar
    Ok so I went to that spot in the WiFi settings and I found that the sleep mode was set to "never". I changed it to "never when plugged in" and it still turns on when I plug the phone in. This setting was on some other app or setting somewhere where I could change other functions of the phone along with the WiFi. I could change the brightness depending on whether it was plugged in or I could change the volume depending on whether or not it was plugged in, too. I really think that it might have been something I did when I was first rooting the phone. Something that asks what I would like the WiFi to do when I plug the phone in. This problem is turning out to be more of a hassle to get fixed than it is to just deal with it :/ Thanks for all the help, though
    01-31-2011 08:07 PM
  11. doogald's Avatar
    I tried installing Kaos Froyo tonight - I haven't run it since September - and I saw nothing about WiFi settings and having it powered on while it is plugged in.

    I know it may take a while, but maybe if you list all of the apps that you have installed, something will jump out as an obvious candidate.
    01-31-2011 09:43 PM
  12. tropper's Avatar
    Ok so I went to that spot in the WiFi settings and I found that the sleep mode was set to "never". I changed it to "never when plugged in" and it still turns on when I plug the phone in. This setting was on some other app or setting somewhere where I could change other functions of the phone along with the WiFi. I could change the brightness depending on whether it was plugged in or I could change the volume depending on whether or not it was plugged in, too. I really think that it might have been something I did when I was first rooting the phone. Something that asks what I would like the WiFi to do when I plug the phone in. This problem is turning out to be more of a hassle to get fixed than it is to just deal with it :/ Thanks for all the help, though
    See that maybe the prob, never says never sleep wifi, never when plugged in says never sleep when plugged in I have mine set when to When screen turns off.
    EDIT: is Wi-Fi setting set to on all the time because if so that would explain my theory of why it comes out of sleep mode when plugged in. And also do you have Wi-Fi shortcut, or widget on your desktop and if so which one?
    gopher1 likes this.
    02-01-2011 10:15 AM
  13. gopher1's Avatar
    @tropper

    Alright I'll try setting it to that setting and see if that works. The only apps that I have on my phone that access that information are quick settings and the cyanogenmod setting that allows me to have a gps, wifi, flashlight, and brightness toggle in the notification bar. Not sure if there's any way to turn the cyanogenmod setting off but I would rather have it since it makes turning off the wifi easy. I still haven't been able to find the setting page that I had originally found where I switched this "function" on. I know it exists somewhere....I will find this mysterious mystery setting *shifty eyes*
    02-04-2011 01:36 AM
  14. tropper's Avatar
    Your welcome, thats the only place I can remeber seeing a setting like that. I also believe the cyanogenmod settings control more than just the setting bar.
    02-04-2011 11:16 AM
  15. doogald's Avatar
    The only apps that I have on my phone that access that information are quick settings and the cyanogenmod setting that allows me to have a gps, wifi, flashlight, and brightness toggle in the notification bar. Not sure if there's any way to turn the cyanogenmod setting off but I would rather have it since it makes turning off the wifi easy.
    Well, even though you don't want to turn it off, that setting is in settings->CyanogenMod settings->User Interface, called "Notification power widget".

    I have been through each and every CyanogenMod setting and there is nothing even close to activating WiFi when power is on, and I have never seen that in any other setting, except the advanced WiFi settings already mentioned that prevents WiFi sleep when the phone is powered (but that does not turn on WiFi if it is off when you plug it in.)

    As I said, I installed both Kaos and CELB from scratch as a test and never saw anything asking me to turn on this feature that you mention. Perhaps you have an app that you don't think that you have, but there is nothing in a default Kaos or CEL install that has ever appeared to me that matches what you described as a settings page earlier.

    I hope that you find what you are looking for.
    02-04-2011 01:38 PM
  16. fuzmeister's Avatar
    I FOUND IT!!

    When you add the "Power Control" widget to a home screen, there is a section of settings called "Power Event settings." This is where I had triggered this behavior before.

    Wow, what a relief after beating my head against a wall for weeks.

    - Steve
    gopher1 likes this.
    02-08-2011 01:37 PM
  17. gopher1's Avatar
    WOOO!! I can confirm that it is in the widget settings when putting the Power Control widget onto the homescreen. Silly story, I had tried doing that a while ago but the screen didn't look familiar so I didn't bother scrolling down to see what else was available -_- My investigation skills might need a little more work.
    02-10-2011 01:46 AM
  18. bitchesbetrippin's Avatar
    try this from the home screen: menu>add>widgets>powercontrol then scroll down to the power events settings. that was easy...not

    dinc4lyfe
    02-15-2011 10:41 PM
  19. justusdj's Avatar
    THANK YOU SOOOO MUCH. Can't tell you how much time I've spent looking for this. Woooohoooo!
    08-04-2011 01:38 PM
  20. help-please's Avatar
    i added the power control widget to my home screen but where can i find the Power Event settings? this is driving me mad!!
    12-27-2011 07:58 PM
  21. skspana's Avatar
    [/b]esbetrippin;614348]try this from the home screen: menu>add>widgets>powercontrol then scroll down to the power events settings. that was easy...not

    dinc4lyfe
    This is helpful until the "then scroll down" part. After clicking powercontrol, it just adds it to the home screen. There is nowhere to scroll down to find power events settings.

    I look in settings, but it's not there. Can anyone help, please?
    05-28-2012 05:44 PM
  22. doogald's Avatar
    This is helpful until the "then scroll down" part. After clicking powercontrol, it just adds it to the home screen. There is nowhere to scroll down to find power events settings.

    I look in settings, but it's not there. Can anyone help, please?
    The Power Control widget for the Eris has no settings. CyanogenMod has a Power Control widget that allows you to control which widgets are shown and how some of the toggles work, but the Eris Power Control widget is just the widget.
    05-29-2012 11:00 AM
  23. shiloh powers's Avatar
    i am having the same problem on my galaxy s4 sph-L720T i am rooted but i am just running the stock rom kit kat 4.4.2 build number ending in NG5 root and i am not deodexed, i am NOT running cynagen mod and i have tried the settings>advanced and played with the options and even rebooted just to make sure they sink in is there any way to find this setting or an app widget that can allow this device and others that i will share via the other fourms that i use to change this continual problem i seached for this problem in other fourums ie: xda develpoers this is the only help i have found but if you have a link to one that i missed for my device it would be greatly appreciated
    02-19-2015 10:30 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD