07-30-2017 10:41 AM
70 123
tools
  1. GVMnr's Avatar
    it closed by going to setting, then apps, voicemail, then uncheck and re-check it (if you want) . Once unchecked the icon goes away.
    07-05-2013 01:19 PM
  2. Angel Heart1's Avatar
    I tried this..went to apps clicked all, selected phone, clear data and my voicemail icon went away! thank you so much it was driving me crazy!!
    09-14-2013 03:59 PM
  3. pkjunction's Avatar
    It turned out that all I had to do was call AT&T and have them deactivate my voicemail account. Of course getting AT&T to understand that I wanted to deactivate not activate the account want quite as easy. As soon as they deactivated my voicemail account the icon went away. My Googlevoice account voicemail still works fine. My first clue that the AT&T voicemail account might be the cause of the problem was when I changed back to the carrier voicemail from Google voice and closed this setting in the Settings menu, I got the message "No Change", which clued me in that the problem may be because of AT&T.

    Hope this helps someone
    09-29-2013 11:44 AM
  4. ChadiTheGreat's Avatar
    Below is what worked permanently for me:

    1- Clear Data for the Phone's application. Once cleared, the notification disappears.
    2- Call your mobile number from another phone and leave a voicemail.
    3- From your phone, call your voicemail to check the message. The notification should show up again.
    4- Delete the voice message. The notification should disappear.
    5- Restart your phone.

    Hope this helps for some
    Janis2 likes this.
    10-03-2013 09:43 PM
  5. nvb3's Avatar
    I have an htc evo 3d and none of the solutions in this form worked but after trying to solve this for two months I stumbled on to the solution, for the htc evo 3d any way. I hold the power button down until the power options screen appears than I select restart (Green Button) below the button it says Close all apps and restart phone. After the phone restarted it took a few seconds for all the icones to return to normal and Viola! no more annoying voice mail notification. Hope this helps.
    10-04-2013 01:44 PM
  6. Nick McKinsey's Avatar
    Hey there! Thanks for the instructions in your reply. I think it is attached to that visual voicemail. I may just delete it.
    10-06-2013 09:02 AM
  7. IAmJoanS's Avatar
    Finally!!! The annoying voicemail icon is gone! This has been very helpful!!! Thank you!
    10-10-2013 11:19 AM
  8. appsropos's Avatar
    On Android 4.3 and above, this app seems to be able to clear them:

    https://play.google.com/store/apps/d...rnotifications
    Attached Thumbnails HTC Droid Eris: Voicemail notification icon won't go away-1.png  
    12-15-2013 03:06 PM
  9. NevahDat's Avatar
    I tried All of the other suggestions. None of them worked. I tried this and Done!
    Thank you! That icon was ANNOYING.
    Mary Lynn Zahn likes this.
    02-04-2014 01:45 PM
  10. Mary Lynn Zahn's Avatar
    Irks me to have to pay for an App to get rid of the notifcation but nothing else worked. It was worth the 99 cents!
    02-11-2014 07:11 AM
  11. zod711's Avatar
    Working like a charm. Thank you
    03-21-2014 10:59 AM
  12. stranjal7's Avatar
    Yea!! That worked well. Thank you!!
    04-05-2014 09:14 AM
  13. RASINUK's Avatar
    Thanks for the info this app works well.
    Only one problem the $0.99 cents is £0.99 pence over here.
    rip off or what (It's only the kids inheritance)
    10-27-2014 02:14 AM
  14. Luke Mason1's Avatar
    Don't have that option on the Samsung Infuse 4G. Still can't get my voicemail icon to go away after trying several suggestions I've seen on here. Need help!

    ok issue permanent what I did was

    1.Send Voice Mail to myself saying "lol"
    2.Listen back to the Voice Mail
    3.Waited until you hear the key to Delete Message
    4.Delete the message

    and you are FIXED!
    11-27-2014 07:21 AM
  15. vero9's Avatar
    That best that worked for me is the option 4 in voicemail.
    I tried everything, setting: voicemail clear notification, apps:force stop, left a message on my voicemail only without the option 4.

    Thanks a million!
    03-04-2015 10:09 AM
  16. LaraP's Avatar
    I also have Virgin mobile and the icon clears after powering off. Hope it works for someone else too!
    11-29-2015 09:27 PM
  17. Janis2's Avatar
    I have a Motorola Droid LG and after several tries of advice other than clearing data...that one did not appeal to me at all....I saw a good answer and it worked. Call yourself, leave message. When you get that, listen and then clear and the "ghost" icon was gone too. That simple!!! Thanks to whoever left that simple answer and hope it helps someone else ✌
    01-23-2016 02:10 PM
  18. LAURIEK58's Avatar
    it worked througth settings. thanks so much
    08-19-2016 01:18 PM
  19. Sebestyen Artur's Avatar
    problem fixed... cheers man!
    12-17-2016 12:23 PM
  20. Mothershelper's Avatar
    Thanks for all the suggestions. I finally got it cleared off by calling from another phone, leaving a message then erasing the voicemail. Then puff, icon gone.
    Even though this is a very old thread it was helpful to me with my brand new HTC u 11 that had the voicemail notification that wouldn't go away. I tried the restart and that didn't work. For some reason it occurred to me that I hadn't done a system update yet since the phone was only a month old. I did that unrelated to the problem but next thing I knew the voicemail notification was gone so evidently that took care of it! Thanks everyone for motivating me to try a couple of solutions that ended up working.
    07-30-2017 10:41 AM
70 123
LINK TO POST COPIED TO CLIPBOARD