10-20-2012 10:35 PM
66 123
  1. savvy_cowgirl's Avatar
    Ok, I'm trying to follow the video guide to rooting, I got this guide How to Root the HTC EVO 3D [Video Walkthrough] | The Droid Demos from a link on the XDA forum. I was downloading the required packages (may be a problem there, some of them were only .exe & I'm running Linux) I got to the Revolutionary download, went to generate my Beta key, managed to get my Evo to boot into the HBoot thing and it says it is version 1.58.0000 Revolutionary only offers versions 1.30 or 1.40. Then I looked at the top of the screen and it already says SHOOTER XC SHIP S-OFF RL
    Since the Revolutionary page says "Revolutionary is a tool to give you S-OFF on your phone" and mine already says that, and I can't get a version of Revolutionary anyway, I'm guessing at one point this phone has been rooted? Now I don't know what to do, I want it rooted so I can get rid of some stuff I consider bloatware and maybe put on a custom ROM, but I really really don't want to ruin this phone. How does one proceed?
    10-09-2012 11:07 PM
  2. piizzadude's Avatar
    So you bought this second hand?

    If so, the good news is that hald you work is done. S-off means you can pretty much do everything with your phone with ease. All you really have to do is flash a custom recovery via hboot and then install Super user


    give that a try
    savvy_cowgirl likes this.
    10-09-2012 11:22 PM
  3. savvy_cowgirl's Avatar
    Right you are! I did get it second hand, but it was in really good shape. Ok, so I need to download one of the recovery programs TWRP or Clockwork? Maybe TWRP because I don't know about that bit on "if the recovery portion of Revolutionary succeeds:". Then follow a method of flashing it, then I looks like I've already downloaded a program called SuperUser-3.0.7.efg-signed.zip so I put that on after the recovery. Do I flash that too? Can I follow the same instructions of putting it on an SD card like I did the recovery program? Then I can set about finding a nice junk free ROM that I put on follow the same instructions for the recovery? So once I learn how to "flash" off the SD card, that procedure can be used for most things? I may be able to do this! I think! Thank you SO much! Tell your wife this is one of the days you've proved her wrong!
    10-10-2012 12:16 AM
  4. piizzadude's Avatar

    OK quick disclaimer, I do not have your phone, but I am pretty familiar with HTC and I am a total flash a holic so I have some background. I will do my best not to lead you astray, and since you are s-off there isnt much harm we can do.

    yes, once you flash the recovery, you just flash SU and you should be rooted. There is a program on the market called root checker that can make sure for you.

    you can now flash anything you want the same way. Just be sure that you read all the devs instructions before flashing. NOT reading can kill you. here is a list of roms for you to look at: [Complete LIST] Guides | Roms | Rooting | Recovery | Radio's -- Updated 11.5.11 - xda-developers
    savvy_cowgirl likes this.
    10-10-2012 12:44 AM
  5. benny3's Avatar
    if your going to flash a custom rom there is no need to flash the superuser zip. Most if not all custom roms are already rooted. if your going to stick with your stock rom then you will need to flash superuser.
    the best recovery in my opinion is 4EXT which you can install right from the Playstore, it does cost a few bucks but is worth every penny

    4EXT Recovery
    savvy_cowgirl likes this.
    10-10-2012 12:46 AM
  6. savvy_cowgirl's Avatar
    Hmm, I think something may have gone "amuck". I downloaded the TWRP file, re-named it PG86IMG.zip, then used the commands to create the zip.md5 file all was well. I put them on the SD card at the same level as all the other folders. In other words, when I put the SD card in my computer and the card is mounted, I put it there, so that's root level, right? Not in the "adroid" folder with the google stuff. So I put it into HBoot, at the top it shows "locked" in a pink bar, don't remember that before, but still shows S-OFF and version 1.58.0000. It appeared to have found the recovery file, asked if I wanted to update, said yes (pushed volume up button) it said not to power down, then finished and said reboot, ok, cool beans all fine. But when I reboot, I can't find any of the way cool stuff: listed at [RECOVERY] [EVO3D] TeamWin Recovery Project (twrp) v1.1.1 [10/05/2011] - xda-developers no color themes or clean simple menu changes to be found. I'm not sure where I went wrong. Um, Benny, I can't do the playstore as of yet, I, um, have not in fact, actually, er, um, activated the phone. I wanted to root and get rid of the junk and make it behave (like longer wake up alarms) like I wanted before I activated it. I didn't know if I'd need a custom ROM, or what all I would have to try to do that this will be my first time, so I'm still using my other phone so that my phoning and texting isn't dependant upon my learning curve. I haven't even actually tried to bluetooth my contacts over even. Why yes, I am a bit insecure about trying this, why do you ask? ...Oh yeah, Piizadude, you're working on a halo!
    10-11-2012 02:48 AM
  7. piizzadude's Avatar
    Here is where you went wrong, it is just pmigXxx. Zip, or whatever the fe name is. Then flash it in fast boot. You do not need the rest of it on there. After that you need to go directly into recovery and do the surgery.

    Sent from my SCH-I535 using Tapatalk 2
    savvy_cowgirl likes this.
    10-11-2012 02:57 AM
  8. piizzadude's Avatar
    Oh and I think you need to unlock first with htcdev, at least I had to with my other HTC devices

    Sent from my SCH-I535 using Tapatalk 2
    savvy_cowgirl likes this.
    10-11-2012 02:59 AM
  9. benny3's Avatar
    First you want to remove or rename the PG86IMG, When your in Hboot you can toggle down with the volume button to recovery the hit the power this will put you in recovery. find the backup & restore option and make a backup...thats the first thing you want to do, when you have that done we can go from there

    With s-off your bootloader is already unlocked. if you wanted to get rid of the Locked in pink you would need to flash a different Hboot
    10-11-2012 06:07 PM
  10. savvy_cowgirl's Avatar
    OH NUTS!! How long do I hold down this power button??????? Guys, I'm in the homestretch here. I've been following the HTC unlock page to get my unlock code (it's only taken me several hours because I didn't know I needed to create a symlink between fastboot and abd, and probably a few other things I've done) I have my official HTC unlock key, it's installed on my phone, I'm at the point on my phone where I pick Yes to unlock my bootloader, or no I have the green button in the yet circle, I pushed the volume button like it says.........and my phone does Nothing, still showing the same unlock bootloader page. How long do I hold down this button? Do I remove it from the USB cable attached to my phone first? I'm so close, what is wrong here? One site said not to remove it till in recovery........YIKES!
    10-11-2012 10:23 PM
  11. savvy_cowgirl's Avatar
    FINALLY, I don't know how long I held that sucker down, but FINALLY! It booted and it was right, it had erased everything (not that I had done much) I even took my SD card out since it said it would erase before I started this. I'm looking at my boot screen which says UNLOCKED! AND S-OFF! So, now can I dispose of the location stuff and that sort of thing? Or do I need to go back to trying to flash the PG86IMG.zip? And I just from command line in the same folder tell it fastboot flash PG86IMG.zip?
    Thank you SO much! Piizzadude & Benny3 deserve angel wings!
    10-11-2012 10:52 PM
  12. savvy_cowgirl's Avatar
    Ok, next problem I've got both files from here [RECOVERY] [EVO3D] TeamWin Recovery Project (twrp) v1.1.1 [10/05/2011] - xda-developers The TeamWin Projects. I made SURE on the top right of the page for selecting my model I selected Evo 3D, CDMA. I've tried putting the PG86IMG.zip on the SD card, and it errors out, wrong version, and I tried putting the recovery.img in my platform-tools and it tries to flash, but then comes back with FAILED (remote: image error! (BootMagic check fail))
    finished. total time: 1.538s
    I've downloaded it twice. NOW what am I doing wrong? I thought I had it!
    10-11-2012 11:27 PM
  13. piizzadude's Avatar
    Hold on let me get to a pc

    Sent from my SCH-I535 using Tapatalk 2
    savvy_cowgirl likes this.
    10-11-2012 11:34 PM
  14. piizzadude's Avatar
    OK so our goal here is a stock, rooted ROM right? With Recovery of course....correct?
    savvy_cowgirl likes this.
    10-11-2012 11:44 PM
  15. savvy_cowgirl's Avatar
    Um, a resounding "not sure". Here's what it's doing now, since I tried both of the 1.1.1 versions, and neither worked, I downloaded the 1.0.3 version as a zip and put it on the SD card. It DID boot into recovery I choose my PG86IMG3.zip I put the 3 in there so I'd know it was version 1.0.3 and took the 1.1.1 one off. This time when I hit recovery I got the TEAMWIN logo the same E: Bad boot message "TIME" BUT, below that it says --Install /sdcard...
    Finding update package....
    Opening update package....
    Installing update....

    But with the bad boot message, I havent' a clue what it's really doing. Does the TEAMWIN logo normally have 3 red question marks on it?
    Rooted ROM YEPPER! I wouldn't mind trying that system that is suppose to come with the TEAM WIN recovery. I just want the 3D camera to work, get rid of the location, maps, telenav, twitter, facebook and all the other stuff I will never use, and have more space for stuff I will use....If I can get that, down the road I think I may try to flash a custom ROM, once I'm more familiar. I think I'm getting the flashy thingy down......
    10-11-2012 11:58 PM
  16. piizzadude's Avatar
    I am not sure about the team win logo but here is what I can do to help. The first thing that we have to do is make sure that you are unlocked and s-off. Everything you have told me tells me you are, but double check. Power off and then boot into hboot. At the top of the hboot screen it should say both those things. If so, lets move on. If not we have to resolve whatever is funky first.

    Next we have to put on the recovery. I took the liberty to download the file and rename it so download it from here: https://dl.dropbox.com/u/17789768/PG86IMG.zip

    Do not rename it, just put it on the root of your sdcard. I think that the errors you are getting right now could be that it is actually named .zip.zip This one is proper.
    reboot into fastboot and you should get going and have it install. If that fails let me know the error message. I will be here refreshing the page waiting for your response and getting the next step ready
    savvy_cowgirl likes this.
    10-12-2012 12:06 AM
  17. piizzadude's Avatar
    your on ICS right?
    savvy_cowgirl likes this.
    10-12-2012 12:16 AM
  18. savvy_cowgirl's Avatar
    Version 4.0.3, that's ICS, right?
    Ok, downloaded, but your download acted proper, the others the download looked like it wasn't, but the file said it was the proper 5 MB, I put it on the SD card, not in any of the folders and it still says no image when I boot into HBoot. It does say unlocked at the top, and S-OFF, so that's good to go. I even just tried in on another SD card, in case that was the issue. It's not. Says no image found using your file, and a different SD card. Am I suppose to put it in one of the folders on the card? Cause I haven't. Thank you SO much! I'm so close and just can't figure out what it is.
    10-12-2012 12:28 AM
  19. piizzadude's Avatar
    ok screw this, lets try another route. Give me a second to research this. I hate hboot, it can be such a pain
    savvy_cowgirl likes this.
    10-12-2012 12:36 AM
  20. savvy_cowgirl's Avatar
    getting closer, this time I got a message about sideloading not working/failed soemthing, but ALSO got a message that it installed from the SD card, it doens't look like it though, still looks the same, still got a Bad Time message. BOY IS IT, and I feel WAY worse for you!
    It just keeps saying "Loading" then "no image" don't if that helps or not........
    10-12-2012 12:40 AM
  21. piizzadude's Avatar
    wait, quick question. when you go into hboot, is it trying to load it from there, or do you have to choose fastboot then it starts the install?
    savvy_cowgirl likes this.
    10-12-2012 12:49 AM
  22. piizzadude's Avatar
    Settings->Power and make sure Fast boot is checked off.

    Please make sure you have this correct
    savvy_cowgirl likes this.
    10-12-2012 12:51 AM
  23. savvy_cowgirl's Avatar
    Fastboot IS off, double checked. When it boots into HBoot, it doesn't even give me a chance to click down to recovery it just starts scrolling in green saying stuff like image not found, once it said wrong image. I think, goes by fast then asks if I want to update, I tell it yes, it says unzipping, not to power down, a few seconds later it says done, to press power to reboot, and notthing is different. It doesn't want to boot into recovery.
    10-12-2012 01:12 AM
  24. savvy_cowgirl's Avatar
    Ok, if I put the zip in the "Android" folder, I CAN boot into recovery. Then I choose the zip from the Android folder it says
    Added /sdcard/Android/PG86IMG.zip
    --no md5 file found. ignoring
    --install /sdcard/Android/PG86IMG.zip....
    finding update package...
    Opening update package...
    E: Can't open /tmp/sideload/package.zip

    Install from sdcard complete

    Does this help?
    10-12-2012 01:18 AM
  25. piizzadude's Avatar
    then try it the other way. I know the file I gave you is right, the img file is in there. The only other thing I can even think of is an incompatibility.

    We are gonna go a different route. After you try it the other way and it fails, download this file: https://dl.dropbox.com/u/17789768/PG86IMG.zip and run it in fastboot. That is a stock, rooted , ICS rom. We will worry about recovery right after that is installed and make our life easier.
    savvy_cowgirl likes this.
    10-12-2012 01:24 AM
66 123

Similar Threads

  1. What does your serial number start with?
    By davidsnoodles in forum Google Nexus 7 Tablet (2012)
    Replies: 28
    Last Post: 02-07-2013, 07:36 PM
  2. Need help with Inc S 2.3.4 / HBoot 0.98.0000 / S-ON
    By intellekt in forum HTC Droid Incredible S
    Replies: 0
    Last Post: 05-21-2012, 05:05 PM
  3. What version of Android does the EVO 4G come with?
    By un_designer in forum HTC EVO 4G
    Replies: 6
    Last Post: 12-14-2011, 09:45 AM
  4. Replies: 3
    Last Post: 04-19-2011, 05:29 PM
  5. What Droid apps do not work with Google Apps?
    By chipwich in forum Motorola Droid
    Replies: 3
    Last Post: 11-22-2009, 01:52 PM