1. mballa22191's Avatar
    Every I click an app that needs internet it says "No Data" and sometimes on the web it just stops working.When I go into settings and turn Mobile Network off and on it usually works. But having to do this 20 times a day sucks. It does not affect my phone calls or texts. Just web and data.

    i took it to sprint they did a factory reset. It fixed it for an hour, then the problem came back. So frustrating, if anyone can help me I would appreciate it.

    I already did a return within the 30 days so they say they cannot swap it again.
    07-20-2011 04:42 PM
  2. mballa22191's Avatar
    I guess Im going to have to drive to a repair center...
    07-20-2011 07:13 PM
  3. Brianadfl's Avatar
    Have you installed any battery saving apps?

    Sent from my HTC EVO 3D using Tapatalk Pro.
    07-20-2011 09:02 PM
  4. eswhite01's Avatar
    Have you installed any battery saving apps?

    Sent from my HTC EVO 3D using Tapatalk Pro.
    I have the same problem I went to Sprint repair center that did a factory wipe. The phone still drop data I have to reset the data every 5 minutes. I also can't get apps like netflix and YouTube going
    07-20-2011 09:25 PM
  5. mballa22191's Avatar
    No battery savings apps. I did the factory data reset and still having same problem it sucks
    07-21-2011 01:07 PM
  6. npoz's Avatar
    Im having the same problems as well, glad to know its not just me. Happens off and on and normally at times when I need data the most. Very frustrating!
    07-21-2011 06:39 PM
  7. garrettfarnum's Avatar
    Are you on wi-fi or 3G?
    If you're on wi-fi, go to settings>wireless and networks>wi-fi settings, then press menu>advanced>change wi-fi sleep policy

    If you're on 3G, try turning wi-fi off. I used to have this problem all the time.
    07-21-2011 10:03 PM
  8. TheMatrix31's Avatar
    My internet data gets shifty sometimes too. Webpages will stop loading, Twitter/FB will hang, etc. I either turn my wi-fi off then back on, or I go on airplane mode real quick then come back.

    Maybe it'll be fixed in an update.
    07-22-2011 09:06 AM
  9. garrettfarnum's Avatar
    My internet data gets shifty sometimes too. Webpages will stop loading, Twitter/FB will hang, etc. I either turn my wi-fi off then back on, or I go on airplane mode real quick then come back.

    Maybe it'll be fixed in an update.
    Try my post above^^^see if that works.
    07-22-2011 11:57 AM
  10. IAmSixNine's Avatar
    About a week after i got mine i lost all data. But only on 3G. 4G and WiFi still worked.
    I had to have a data reset done. If you still have a cellular connection and the 3G sign is gone its likely the same thing.
    But i would need more info to know.
    07-23-2011 06:49 PM
  11. TheMatrix31's Avatar
    Try my post above^^^see if that works.
    Right now it's set on "after 15 minutes"....should I put it on "never when plugged in" or "never"?
    07-24-2011 08:25 AM
LINK TO POST COPIED TO CLIPBOARD