1. bluephi1914's Avatar
    When I click on my messages widget, I only get numbers displayed, NO names.

    Anyone had this issue with their EVO3D?
    07-28-2011 11:06 PM
  2. bluephi1914's Avatar
    I'm using stock message widget
    07-28-2011 11:07 PM
  3. hchavarria's Avatar
    could it be that it is picking up that number from a source that has not been linked to the correct contact.
    07-29-2011 09:55 AM
  4. Marty1781's Avatar
    I was having this same issue for one of my contacts. In the stock messaging app, the SMS thread would show his phone number but not his name. However, if I opened up the contact, then used the slider at the bottom to view the SMSs that were associated with him, then the thread showed his name. I did a couple of things to fix the issue, not sure which of them did the trick though. I edited the contact to make sure all of the numbers associated with him were entered in this format: (123) 456-7890. I deleted all existing SMSs from this person and made sure I was not the first to text him so as I was not the one to create a new thread in the stock messaging app. Instead, I made sure that an incoming text message from him was the SMS that created the new thread. I linked and unlinked his Google contact and Facebook contact. Again, not sure which of these fixed the issue but its now resolved. Hope something I listed helps you out.
    cgardnervt likes this.
    07-29-2011 11:53 AM
  5. Gates Is Antichrist's Avatar
    SIMPLE FIX. I see so many complicated explanations, and don't know why no one else says the following which is 100% effective for me.. Go Settings/General/Apps. Scroll to Messaging and click it. Click "force stop" (don't worry, it's not as radical as you might fear).

    Now back all the way out and click your message icon. At least for me, names now appear instead of numbers.
    12-01-2016 06:16 AM
LINK TO POST COPIED TO CLIPBOARD