1. boe's Avatar
    Hello,

    I only have one email account set up to sync email. It is my MS Exchange account. I have it set for push.

    Yet for some reason the icon on my home screen is almost always showing an incorrect number of new messages. If I open up outlook - then it seems to sync - not always synced even during key work hours - 8-8 (when I have it set for push).

    I'm not sure if this is a glitch with the 3D or android something I'm doing wrong or if there is a work around. I know 3 other people with the 3D and they all have the same issue.

    I'm new to android so I'll give you what info I think might be important.
    I have both background and autosync checked.
    I have mail, contacts, calendar, update when opened checked. I have update schedule set for push between 8-8 every day.
    09-02-2011 02:03 PM
  2. lfnsr's Avatar
    double check in settings-send&receive-update schedule and make sure "push" is set for both peak and off-peak. sometimes even when i set up my exchange email to push during the initial set up, i still have to go in a correct this. also, make sure you are syncing all the folders you have set up in outlook - if you have any. it is under "folder to sync. i also have "download past mail" set to all. not sure if this will help, but might be one of the issues. thanks.
    09-02-2011 02:52 PM
  3. boe's Avatar
    Thanks - I'll try setting it to push during peak and after and see if that helps - although I hate to use any more battery than I need.
    09-02-2011 03:57 PM
  4. lfnsr's Avatar
    Thanks - I'll try setting it to push during peak and after and see if that helps - although I hate to use any more battery than I need.
    no problem. hope you can figure it out. i am relatively new to android myself - came from bb for the past 6+ years. definitely don't miss bb and haven't looked back. i have one exchange email and 3 others on my 3D with no issues. just have to make sure the settings are correct as sometimes they are not. have a great long weekend.
    09-02-2011 04:08 PM
  5. boe's Avatar
    Thanks - tried your suggestion. I'm thinking it may be a bug - even with it set for push during peak and off peak it still isn't accurate.
    09-04-2011 11:47 AM
  6. boe's Avatar
    I just got the Epic Touch 4G - turns out the incorrect number of messages is a bug in HTC Sense, my ET4G accurately shows unread messages.
    09-19-2011 01:06 PM
  7. Marty1781's Avatar
    I just got the Epic Touch 4G - turns out the incorrect number of messages is a bug in HTC Sense, my ET4G accurately shows unread messages.
    Interesting. I've had a MS Exchange Activesync account setup on my Evo 3D for over a month now and never experienced any issues like what you have described. I do notice that sometimes the email indicator seemingly displays the wrong number of new emails but once I go into the app, I see that is not the case because the new emails are from the gmail account I have setup, so in essence the Mail app/indicator has always been spot on for me. Best of luck with your new phone.
    09-19-2011 03:54 PM
  8. boe's Avatar
    Best of luck with your new phone.
    Thanks - I'm thrilled with it. I thought the Evo 3D was nice but this phone blows it out of the water in many ways. In general I prefer sense over touchwiz but I'm thrilled to have an email indicator that is accurate.
    09-19-2011 04:29 PM
LINK TO POST COPIED TO CLIPBOARD