1. sveilien's Avatar
    I just bought and downloaded Let's Golf 2 3D and installed it but now I'm getting a "Not an originial copy" error. Dammit.

    They have Asphalt 6 3D and Assassin's Creed 3D too.
    06-23-2011 10:44 PM
  2. Everlast716's Avatar
    Holy crap, I bet asphalt 6 3d is gonna be so cool to play. I saw gran turismo on 3d and it blew my mind, now I can have experience with my phone....awww yeah!
    06-24-2011 01:27 AM
  3. MannyZ28's Avatar
    Where did you buy it from? Their site, amazon appstore and android market? I know Nova 2 is in the market, but it's not 3d I think.

    They need to get their crap together at Gameloft, just email them, I am sure they will fix it for you.
    06-24-2011 01:31 AM
  4. foolish501's Avatar
    i had the same problem, bought asphalt 6 & let's golf 2, and let's golf says it's not an original copy, emailed gameloft
    06-25-2011 11:12 AM
  5. OLD_HATCH's Avatar
    have you guys gone into settings/apps and tried clearing app data?

    I had this issue once in flashing between roms on the EVO4G and that fixed it for me.
    06-25-2011 11:18 AM
  6. shahbaz786's Avatar
    Today i downloaded gangsterMV HD game and its data but it can't be open and show a popup message that This is not a original copy of gangsterMV HD.How to solve this plz tell me.
    06-15-2016 02:35 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD