11-30-2014 01:27 AM
33 12
  1. fredster309's Avatar
    You need to update google play to 4.1.10

    05-30-2013 01:33 AM
  2. Emmanuel11's Avatar
    I'm having the same problem :-(
    Attached Thumbnails Fix for the Weather "Current Location" bug-uploadfromtaptalk1370323935563.jpg  
    06-04-2013 12:32 AM
  3. groovepeppy's Avatar
    Already install the 4.1.10, i even wipe cache and dalvik, problem still persist.
    07-10-2013 11:01 PM
  4. snewbs's Avatar
    When the phone sticks on a wrong current location it seems to be related to the "Location service". This should be an app you have installed like a map app. You can reinstall and reset the Location service by selecting the last option in the Weather menu.
    Best to do this when connected to wifi to save costs.
    If you have turned off the location settings in the main menu , the weather app will prompt you to turn them on again.
    Once reinstalled / reset the current location should update. You will need to refresh weather to then get the latest details at the new current location.
    07-12-2013 07:58 PM
  5. kc2fya's Avatar
    I found by conducting a Sync to the Weather and HTC Sense (3.6) resolves this issue. I have my "Auto-Sync" turned off, so once in a while I have to manually sync the two I mentioned. I hope this helps you out.
    08-10-2013 09:27 AM
  6. Roger Norvell's Avatar
    Look At Post #23 by Wab1975 settings, Power, Fast Boot Off *

    Thank you very much, your tip fixed it instantly. When I upgraded to ICS and setup the sync the first time that's when my city in Va was replaced with the buggy "Current Location" but I liked having each city show up in the widget. The upgrade to ICS puts that fast boot on. Now the phone boots slow like with the older ver of android and sense. I'll take slow boot and have things work correctly.
    Thanks now I can stop searching endlessly.
    01-03-2014 11:23 PM
  7. Wealthresource's Avatar
    I have been having the same problem with my HTC One X Plus recently. The HTC weather app shows "Current Location" regardless of syncing the app etc. I found that by updating Settings>>Power and unticking "Fast Boot" then powering off (not restarting) and switching back on resolved my issue!

    Thanks ... this worked for me!
    04-01-2014 08:22 AM
  8. jon72's Avatar
    Went into weather app, tapped on location sources, used the high frequency radio button. Message flashes up about Google sharing location information. Said no previously but decided to say yes cos nothing else worked. Unsatisfactory but it works now.
    11-30-2014 01:27 AM
33 12