08-02-2012 09:06 AM
62 123
tools
  1. dlocks's Avatar
    WRT-54GL running Tomato Toastman.

    Try locking the router into G mode and see if that makes any difference.

    Just wanted to say thanks
    07-19-2012 12:03 AM
  2. TraderGary's Avatar
    I have a Linksys WRT610N router. My router is in the far end of the second story of a two story contemporary house. It is configured to be in N mode only. G mode is disabled.

    My previous EVO 0G 4G and EVO 3D connected reliably between 12 to 16 Mbps anywhere in my house. My wife and I now both have EVO 4G LTE's. They both connect between 24 to 26 Mbps and are obviously impressively faster than previous phones with the same router. I can even get a solid fast connection outside in the far corner of my yard some 300 feet from the router.

    I can connect reliably to dozens of WiFi sites around Atlanta. When I return home I lock on to my home WiFi as I turn in to my driveway. I can sympathize with the problems I see here, but for our two EVO 4G LTE's life is good.

    HTC EVO 4G LTE
    07-19-2012 12:18 AM
  3. digmys's Avatar
    For those saying they haven't had this problem on other phones. I just booted up my Evo3D and OG. The 3D had "Best WiFi Performance" on by default and I never had a problem with it. The OG didn't have this setting (running CM7).

    Like i said, with the LTE, setting best wifi performance to ON totally solves the problem for me, but drops my battery life to 12ish hours. Granted, that is about all I got out of the 3D anyway, and it looks like it was ON by default and on every day I owned the phone (don't remember changing it).

    Also, I have several old routers laying around, I definitely didn't go buy another one just to solve this issue on the phone, and agree buying another router should not be what we have to do to solve this issue.

    But maybe an old linksys router from eBay for a few bucks to improve the wifi performance of all devices in your house, including your LTE? If none of the other fixes work for you, they surely did not for me.
    07-19-2012 12:19 AM
  4. crxssi's Avatar
    For those saying they haven't had this problem on other phones. I just booted up my Evo3D and OG. The 3D had "Best WiFi Performance" on by default and I never had a problem with it. The OG didn't have this setting (running CM7).

    Like i said, with the LTE, setting best wifi performance to ON totally solves the problem for me, but drops my battery life to 12ish hours. Granted, that is about all I got out of the 3D anyway, and it looks like it was ON by default and on every day I owned the phone (don't remember changing it).
    I do not believe that is correct. The default for "Best WiFi Performance" was "off" for the Evo 3D, just like it is on the Evo LTE. But I don't think it destroys the battery on the Evo 3D like it does on the 3D.
    07-19-2012 07:38 AM
  5. BigSushi's Avatar
    Ok here is the fix that has worked (so far) for me. I have the CISCO E3200 Dual Band. I did not want to hassel with reconfiging to G only on the router since I have so many other things connected and DISH Network Hopper/Joey is a pain to reset.
    But I remembered that the LTE has a section in the settings to select what band you want Auto, 5Ghz or 2.4Ghz

    Settings> Wif-Fi> Menu > Advanced> Wi-Fi freauency band> 2.4GHz only
    Other settings in Advanced areKeep Wi-Fi on during Sleep > Always
    Best Wi-Fi Performace > Off

    My Wi-Fi has been solid since I made these changes since yesterday evening and worked all morning long. I hope that this helps others.
    07-19-2012 09:52 AM
  6. BigSushi's Avatar
    Just an update, still going strong on home Wi-Fi
    07-20-2012 11:24 AM
  7. vbockius's Avatar
    I posted this in another wifi thread...fixed my wifi dropping issue...

    I was dropping wifi at home also both when phone slept and sometimes intermittently while using...just playing around i turned off the wifi network notification in the wifi settings (there are 2, top one was checked 2nd one wasn't) When I unchecked the top one, wifi disconnected then reconnected, and I haven't had a disconnect since....I have lots of wifi networks in my neighborhood, maybe network discovery was seeing all the options? It seems to have fixed my issue, maybe it will work for some of you....
    07-22-2012 12:06 AM
  8. Anthonicia's Avatar
    Had the WiFi dropping, 3g connecting, back and forth issue on my old evolte. Exchanged it for a new one and it doesn't have the same issue.

    At work we have an older linksys router that sometimes won't allow me to connect. Would get stuck on getting ip address and never connect. What I did was take a screenshot of my ip address, subnet mask, default DNS 1 & 2 and all that when it did connect. The next time it got stuck on getting ip address I changed my WiFi from dhcp to static and entered in the info from my screenshot of network info.

    U need to have WiFi manager or WiFi analyzer to get the ipconfig data for the screenshot I believe. It's in the advanced menus for any app, so u may need to look for it depending on experience.

    But I haven't had an issue at all since changing to static ip. This went back to my og EVO days too. Just always figured it was my phone and not the router. Tried all the basic things u would think of like unplugging router, resetting both, just never really thought about it being dhcp related.

    Well, I've posted a lot of WiFi fixes on here and new threads still pop up. I hope this helps someone. Probably see an exact thread on what I just explained soon enough. Guess people don't search for existing threads on here. Over at xda u get hell for doing that. Good luck to u all.

    Sent from my EVO using Android Central Forums
    07-22-2012 11:52 PM
  9. pmillr21's Avatar
    Have never had this issue until I got the OTA update 2 days ago. Could always connect and stay connected to wi-fi. Now I can not even connect. No clue what the OTA did to my phone, but the continual searching for wi-fi is killing my battery life. Anybody have the reverse effect since the update????
    08-02-2012 01:41 AM
  10. Lonestaroc's Avatar
    Definite wifi issue!!!# before update got good reception on my room..now I'm lucky if I even get wifi to work
    08-02-2012 02:40 AM
  11. blorgon's Avatar
    I'm noticing drops, but only when I'm charging. I was watching streaming video while plugged into the charger, and the video kept getting stopping, saying I wasn't connected to WiFi, though it would reconnect almost immediately. When I unplugged the charger, I didn't have any more dropped WiFi.
    Anyone else notice this? BTW, I do have the update.

    UPDATE: I was wrong. It drops when it isn't charging too. I wonder if it's only noticeable when streaming, since I don't notice it any other time.
    08-02-2012 03:01 AM
  12. TraderGary's Avatar
    WiFi dead on reliable here. Connects and stays connected to any router anywhere. Never any problems.

    HTC EVO 4G LTE
    08-02-2012 09:06 AM
62 123
LINK TO POST COPIED TO CLIPBOARD