1. SleekBlack's Avatar
    Is any one else having issues with an intermittent data connection? My signal is constantly going in and out. I may be in the middle of an Internet search or app that uses the data connection and the signal completely drops for no reason. I will not blame this on the Sprint Network since my wife's Evo 3d works fine while right next to me. My old 3d never had these issues in the same exact places either.
    It doesn't necessarily seem like it's the network that is actually dropping the signal; however, it seems like it's a software issue.
    I'm not sure, but it seems possible this is related to the aggressive multitasking features of this phone.

    Has anyone else been experiencing this severe loss of data randomly and for no apparent reason?

    I am considering taking this back to Best Buy and switching out for a new Evo as it could just be a hardware issue with my specific handset.
    07-13-2012 03:33 PM
  2. bc2k's Avatar
    The short answer is it might be hardware, or software, or both (sorry!). Guess the first thing is to ask if you've applied the HTC software update released OTA earlier this week. It's supposed to fix at least some kinds of connection dropping issues. And for what it's worth, Sprint reps on the Sprint.com EVO LTE forums have said the phone's wifi-connection dropping is a software problem. Not sure if that's true for 3G as well.

    My experience - my first new EVO had the problem pretty much exactly as you described with its wifi connection; I swapped it at Best Buy. The replacement had no wifi disconnect problems, but couldn't hold onto a 3G connection AT ALL, data or voice. Constantly dropped, and always showed weaker than my wife's EVO Shift. So I swapped for a third unit, which has been fine all around for over a month.

    If you've applied the software update and still have a problem, I'd say definitely exchange the device. Otherwise try the update, see if it seems to fix things. If not, swap and hope the replacement is a winner.

    Definitely not a unique problem; lots of people reporting similar woes.
    07-13-2012 03:46 PM
  3. sasha's Avatar
    Well I sure am experiencing it, been trying to decide if I should take mine back as well. I'm in downtown Chicago and according to the Sprint reps they have some down towers their working on so that's what's probably causing the data to be so buggy. At home I have Wifi and have no issues at all with phone, but away from home I get roaming notifications, my phone is constantly disconnected itself from the mobile network, can't upload pictures without getting a connection error. I was going to exchange it thinking I just got a bad phone, but seeing as though the phone is superb over wifi I'm assuming it's just the network?
    07-13-2012 03:48 PM
  4. SleekBlack's Avatar
    Yeah, this has been an issue ever since I bought the phone. I was hoping the OTA update would fix it, but it didn't. I will try taking it back and swapping for another.
    07-13-2012 03:57 PM
  5. bc2k's Avatar
    sasha, your phone sounds like my second one.

    I understand your reluctance to exchange, with everything else working fine. If you've applied the software update and you're still seeing problems... I don't know. A replacement might be better all around, or might have some other wonky problem.

    Maybe your store would let you activate and try a potential replacement, do a kind of side by side comparison before you leave the store?
    sasha likes this.
    07-13-2012 04:00 PM
  6. sasha's Avatar
    I think you might be right bc2k , but how about the store I bought it from don't have any in right now. I found out I could go to any corporate store so I was going to sop on my way home fro them to exchange it, but why did the tech just tell me they need the box and the receipt..smdh..I do have the receipt at home not even sure I kept the box. Sounds like some stalling tactic to me my 14th day trial end on Tuesday so I'm really trying to make a decision.

    And another thing that ticked me off he told me If I decided to go with a different phone they will charge a 30 dollar restocking fee now if they think I'm a pay 30.00 bucks cause they gave me a crappy phone it's gonna be some trouble!!!
    bc2k likes this.
    07-13-2012 04:12 PM
  7. ReproOne's Avatar
    I have the same issues, and I am not sure what to do either.
    07-13-2012 09:04 PM
  8. RyDawgBoston's Avatar
    I am on my third phone and still have data connection problems. Even did the HTC update and its actually worse. Two days at my house with no 3g connection and phone is roaming.

    I talked with HTC today and they said to send the phone in to have fixed. I might just go to AT&T and get a different brand.

    I will miss the phone, but can not deal with connection issues.
    07-13-2012 09:28 PM
  9. mrcminnesota's Avatar
    I would like to know if there is an ICS issue with Sprint data connection. I have he Epic 4gT and updated to ICS 4.0.4 a week ago - never had intermittent loss of connection with GB. I have a frequent intermittent loss of 3g data connection (live in Mpls/St Paul area). There is no pattern/area for the intermittent loss. My daughter-in-law has the EVO 4G LTE and I noticed that she also has an intermittent data connection on 3G. I asked her about it and she said she has it frequently.
    I asked the question in the Sprint Forums but have not received a response as of yet.
    07-21-2012 04:11 PM
  10. RyDawgBoston's Avatar
    I am on my third phone and still have data connection problems. Even did the HTC update and its actually worse. Two days at my house with no 3g connection and phone is roaming.

    I talked with HTC today and they said to send the phone in to have fixed. I might just go to AT&T and get a different brand.

    I will miss the phone, but can not deal with connection issues.
    Problem solved.!


    I ended up going to At&T and got the gs3. Great phone with great service and super fast lte. It feels good to have a phone that works and a service that provides.
    07-22-2012 01:56 AM
  11. Vysse's Avatar
    I would like to know if there is an ICS issue with Sprint data connection. I have he Epic 4gT and updated to ICS 4.0.4 a week ago - never had intermittent loss of connection with GB. I have a frequent intermittent loss of 3g data connection (live in Mpls/St Paul area). There is no pattern/area for the intermittent loss. My daughter-in-law has the EVO 4G LTE and I noticed that she also has an intermittent data connection on 3G. I asked her about it and she said she has it frequently.
    I asked the question in the Sprint Forums but have not received a response as of yet.
    Could be tower upgrades and a coincidence

    Sent from my EVO using Android Central Forums
    07-22-2012 03:00 PM
  12. zmann's Avatar
    It has happened to me a few times. So many people are having the same issue I'm thinking it's a software issue. I will not run out and swap my phone. I'm sure it will be taken care of.

    Sent from my EVO 4g lte
    07-22-2012 05:39 PM
  13. kiwicarlos741's Avatar
    I have a question for anyone with this problem. Is it doing it when there is only one bar or no bars or does the intermittent problem do it with any type of signal strength.

    Sent from my EVO using Android Central Forums
    07-22-2012 11:34 PM
  14. bertimus2002's Avatar
    I would like to know if there is an ICS issue with Sprint data connection. I have he Epic 4gT and updated to ICS 4.0.4 a week ago - never had intermittent loss of connection with GB. I have a frequent intermittent loss of 3g data connection (live in Mpls/St Paul area). There is no pattern/area for the intermittent loss. My daughter-in-law has the EVO 4G LTE and I noticed that she also has an intermittent data connection on 3G. I asked her about it and she said she has it frequently.
    I asked the question in the Sprint Forums but have not received a response as of yet.
    I have the exact same problem in MSP. I just traveled to Dallas over the weekend and my 3G connection came back while there, but as soon as I landed back in MN, I haven't had 3G at all. I think I may have to find a corporate store to look at the phone, but not sure how that will work if I can get a new one replaced for it (1 yr warranty) or how they will handle it.

    Update:I did a factory reset on my phone (back to OTA stock) and I still don't have 3G data access back on my phone. Looks like a visit to the Sprint store is in my future
    07-23-2012 07:25 AM
  15. agolz12's Avatar
    I have a question for anyone with this problem. Is it doing it when there is only one bar or no bars or does the intermittent problem do it with any type of signal strength.

    Sent from my EVO using Android Central Forums
    Yesterday I was trying to open a webpage on my phone, I would have full phone signal and 3g would show up and then it would drop down to no signal at all, a minute later I would show full bars and 3g. It did that 5 or 6 times before I just quit trying to use my phone.
    07-23-2012 09:32 AM
  16. SleekBlack's Avatar
    Yesterday I was trying to open a webpage on my phone, I would have full phone signal and 3g would show up and then it would drop down to no signal at all, a minute later I would show full bars and 3g. It did that 5 or 6 times before I just quit trying to use my phone.
    Yep, that's exactly what happens with mine. It doesn't matter what the signal strength is at all. I could have full signal and be surfing away or streaming media and then it completely cuts out for no reason at all when I haven't moved from my spot. Then a few seconds later, it comes back and I have data again. I wouldn't care so much if the phone knew how to handle intermittent loss of data, but it doesn't. When I'm streaming something and I lose data, rather than pausing the media and bringing it back to where it was, the returning data signal restarts whichever application was using it from the beginning. It is very frustrating. My mom has the S3 and I see how it's a nice phone. But I don't like it at all, I just want my EVO to function properly. And they'd better not say that this phone "functions as designed"! I honestly think this whole intermittent data loss has a lot to do with some sort of multitasking issue. It's like it can't prioritize properly and doesn't know that the data signal is the one thing that should not be cut.

    However, if this is simply a result of ICS not playing nicely with the Sprint network, I'm wondering if that is possibly the reason the Evo 3D is taking so long to get a proper ICS port from the manufacturer/network.
    My mom has had some similar issues with her S3 as well, albeit not as often. But she has complained about the same intermittent data loss issues. I'm wondering if the fact that the S3 doesn't have as aggressive task killing/multitasking issues as the EVO LTE is the reason the S3 hasn't experienced these issues as often.

    BTW, there is no chance this has anything to do with towers down or being worked on. There is no network upgrading going on here at the moment and my wife's 3D works perfectly fine while sitting right next to me.
    07-23-2012 10:52 AM
  17. bertimus2002's Avatar
    Update to the 3G data issue on my phone:

    Went to Sprint, spent an hour at the store and without TEP, it cost 35+tax to get a replacement EVO 4G LTE. Reconditioned Status = No, so that was an ok deal for me.

    Now I have 3G back, need to get a new screen protector, but at least it's up and running again. Time to avoid that OTA like the plague and hope that the issue stays away again!
    07-23-2012 08:45 PM
  18. ReproOne's Avatar
    Update to the 3G data issue on my phone:

    Went to Sprint, spent an hour at the store and without TEP, it cost 35+tax to get a replacement EVO 4G LTE. Reconditioned Status = No, so that was an ok deal for me.

    Now I have 3G back, need to get a new screen protector, but at least it's up and running again. Time to avoid that OTA like the plague and hope that the issue stays away again!
    Has the new one dropped connection yet?
    07-24-2012 12:57 PM
  19. Nreeldeep's Avatar
    Problem solved.!


    I ended up going to At&T and got the gs3. Great phone with great service and super fast lte. It feels good to have a phone that works and a service that provides.
    I love when people vote with their wallets. Money makes the world go around. Companies (and people) seem to only listen when you lighten their wallets.
    People don't pay hard earned money for a subpar product. I want what I paid for.
    I for one will be damned if I keep a subpar product from a company that shrugs its shoulders and walks the other way, showing me its back.
    I guess what sets those apart who vote with their wallets is they demand to be respected. If that respect isn't given, they go where it is.
    07-24-2012 02:04 PM
  20. bertimus2002's Avatar
    Has the new one dropped connection yet?
    No, the new phone has not dropped the connection yet at all. It activated in less than 30 seconds. I am also refusing to download the OTA that was pushed out since it is working just fine now. I will wait for a more substantial software update before switching.

    The Sprint store said last night that it is a known software issue right now...but they wouldn't elaborate if anything else is coming down the pipe to fix it or not.
    07-24-2012 03:27 PM
  21. I am Matt Jones's Avatar
    I can tell you this isn't just a Sprint issue, or an HTC Evo issue. I have an HTC Thunderbolt on VZW and my connection drops like a seizure. I think I've narrowed it down though. I'm rooted and decided to Freeze the Facebook app in Titanium Backup and any HTC Facebook features. So far since last night I have had no data connection drop. This thread also backs up my suspicions. The OP also has an HTC. I've been streaming music on slacker, browsing the web, and using other apps without even a hiccup. If any of you are rooted give that a try and reply back, I'm curious if it helps.

    Edit: I forgot to mention that I can always make phone calls when my data connection drops. I don't know if anyone else has tried to make a call during an episode or not.
    08-13-2012 08:30 AM
  22. lrn2swim's Avatar
    I was having the same problem, data would just randomly drop signal for between 5 seconds and a minute and then just come back on and work for a while. This would happen pretty much all day long, everyday. Tried everything i could think of, updating prl and profile, deleting data profile using ##72786#, cdma only, domestic voice on and off. Nothing would work. Finally i just returned the phone and got a replacement. Low and behold my new one seems to be working perfectly!! I even did the latest OTA update with no issues. I think the problem is that a great many of these phones seemed to have been shipped out having faulty radios. What a major F up. Love the phone otherwise though.
    08-13-2012 01:32 PM
  23. Mom2Ninjas's Avatar
    I just started having this problem. Going to try another hard reset I guess and see if it stops. Not holding out hope.

    I honestly feel like it is software related. Have had the phone since launch. This problem just started recently.

    Sent from my EVO using Tapatalk 2
    08-16-2012 06:43 AM
  24. ReAndroid's Avatar
    Friends I had same problem with my phone, just tried simple step of selecting network operator manually and it fixed the problem.

    For more detailed illustration of solution you can visit my blog post:

    apps1play.blogspot.in/2016/01/loosing-data-connection-intermittently.html

    It should fix this issue.


    Is any one else having issues with an intermittent data connection? My signal is constantly going in and out. I may be in the middle of an Internet search or app that uses the data connection and the signal completely drops for no reason. I will not blame this on the Sprint Network since my wife's Evo 3d works fine while right next to me. My old 3d never had these issues in the same exact places either.
    It doesn't necessarily seem like it's the network that is actually dropping the signal; however, it seems like it's a software issue.
    I'm not sure, but it seems possible this is related to the aggressive multitasking features of this phone.

    Has anyone else been experiencing this severe loss of data randomly and for no apparent reason?

    I am considering taking this back to Best Buy and switching out for a new Evo as it could just be a hardware issue with my specific handset.
    01-13-2016 12:01 PM
LINK TO POST COPIED TO CLIPBOARD