1. robwalte's Avatar
    Last night my EVO went unresponsive. I had used it earlier in the day without any issues. I didn't get a chance to check it all afternoon, and by 10pm, it was dead. I tried to plug it in with the wall charger, but I couldn't even get the LED to light up. This morning, same thing - won't turn on, no LED, no signs of life at all.

    It's still stock - I haven't rooted it. I did notice that in the last couple of days, some apps weren't responding, and I would get the "loading" circle when I tried to go back to the home screen. No idea if this is related.

    Any ideas?

    Perhaps I posted too soon. I held down the power button for a good 30 seconds, then touched the home button. The phone sprang to life, booted as normal. Very strange.
    07-21-2012 11:31 AM
  2. Captweez's Avatar
    Had the same thing happen to me. My phone was fine earlier, and then all of a sudden turned dead in my pocket. The battery shouldn't have been close to empty.

    Took your advice with the power button and it sprung back to life. I was about to take it back for a replacement.
    07-21-2012 08:33 PM
  3. Pew446's Avatar
    It would seem as though by holding down the power button for that long you probably discharged some capacitors, "refreshing" the phone. At least that's how it works with many laptops.

    Sent from my EVO using Tapatalk 2
    07-21-2012 11:26 PM