1. Reverse Taper's Avatar
    So, I've had this problem on my phone every since I've updated my phone to Jelly Bean and I'm not the only one, but I haven't found anything like this on Android Central. On the Sprint Community I've found it here and a little here halfway down. A description of my exact issue is very well described in this posting.

    In short, after a while of being connected to my WiFi at home, the connection goes "stale" is the only way I can describe it. My phone still says it is connected but whenever I try to do anything on the internet is just gives me that circle and never goes anywhere. Turning the WiFi off and then back on solves the problem until after a while of being idle, it stops working again. Rinse repeat.

    I've tried a lot of the solutions I read here on Android Central, I've analyzed my WiFi signal and channels, I've downloaded two different WiFi managers, I've tried going to just 2.4GHz or G band only and the problem has not gone away. (For reference, these things were all mentioned in the Android Central threads here, here, here, and here.) I have noticed that the wifi managers all said I was connected but no data would transmit.

    At this point I'm pretty certain it's got to be a router setting. I'm running tomato 1.28 on a Buffalo WHR-HP-G54 wireless router. Unfortunately here I get beyond my ability to know what to do. I've considered going back to the stock Buffalo software or maybe trying DD-WRT but I thought I'd ask here first.

    Oh, and the reason I'm dealing with this all of a sudden is I've upgraded my internet and my old DOCSIS 2.0 modem is now restricting my speed, so I need a new one. Normally I'm not a fan of combo equipment but my wife is asking me to get a combo modem/router so she no longer has to deal with this problem. I suppose that is relevant, my wife and sister-in-law both have HTC EVO 4G LTE phones and everyone only has this problem in my house. No other piece of equipment that connects over WiFi, which is a lot, has this problem either.

    Sorry for the long post but I have researched this and I know it can be annoying when a lot of these problems can just be solved by posting a link; however if there is a link for this and I've missed it, feel free to post that!

    Edit1: May be relevant, I'm still running 4.1, I haven't upgraded but I've been thinking about doing so.
    06-13-2014 01:51 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! It really sounds like a router issue. Have you tried turning off router security temporarily, to see if the problem persists? See other tips here: http://forums.androidcentral.com/amb...-problems.html

    It may be worth trying a different router. But I would caution you about the combo modem/routers, because those tend to be associated with more problems, from what I've read and experienced. I have an Arris TG852 combo modem/router on Comcast, and the wi-fi signal simply drops out at unpredictable times. I have to go into its settings and reset the wi-fi module to get it up again. Fortunately, I have another access point in my house, so it isn't a big deal for me.
    Reverse Taper likes this.
    06-13-2014 04:41 PM
  3. Reverse Taper's Avatar
    Thanks for the reply, on principle I am not a fan of combo equipment, I always feel like they never do quite as good a job.

    I read through the guide, I have tried most of those but I'm a little hesitant to leave my network unprotected for an extended length of time. I may instead try changing the encryption like it suggests, I haven't done that one yet. If that still doesn't do anything, maybe I'll give it a go but it just feels so... wrong to leave my network unprotected!

    I really like tomato on my router, it has been so rock solid for all my other devices with never any connection problems. I actually got rid of my older Linksys router a while back because the connection was just so unreliable so I don't have another router to test with. Maybe a good alternative would be to try a different firmware but DD-WRT is so much more than I need which is why I went with tomato...

    It also mentions the Wi-Fi Optimizer. On the HTC EVO 4G LTE, that's the optimization manager, right? I can't ever seem to find a setting for that, where is it?
    06-13-2014 11:58 PM
  4. B. Diddy's Avatar
    Wifi optimization may differ in function across different devices, so I can't be sure about the Evo.

    Posted via Android Central App.
    Please excuse any typos or autocorrect derps.
    06-14-2014 12:07 AM
  5. Reverse Taper's Avatar
    So, quick update. The night I posted my previous reply I changed the encryption from TKIP to AES. I forgot the network on my phone and put the password back in. I tried to do the same on my wife's phone but for some reason I couldn't get the command to come up, but I was tired and went to bed.

    Since that night I have not had to reset my wifi once! At this point I'm cautiously optimistic I might be able to get to a solution. My wife has had to reset her wifi a couple of times so I'm going to make her phone forget the connection and re-set it back up. I also left a wifi manager app on my phone because I liked widget, I'm wondering if that may have some to do with it as well.

    In short, it appears we are on the right track, thanks for the help! I just have to fix her phone too, fixing mine and not hers won't work.
    B. Diddy likes this.
    06-15-2014 12:11 PM
  6. Reverse Taper's Avatar
    Hello, back with another update.

    So, after what appeared to be success, the problem has returned; I think I might have just had good luck or something for a couple of days. This seemed to work on my phone for a while but only for a day on my wife's phone. I've since tried different encryptions but I'm having the same result, still having to reset my WiFi connection on our phones.

    I also started looking harder at the router. I put the router back to default settings and erased all the data in the NVRAM using the Tomato configuration tool. I also read somewhere that someone had success in fixing a similar problem by changing the MTU size from the default of 1500 to 1453; I just did that a short while ago but I'm not hopeful it will solve the problem.

    So, does anyone have a recommendation for a good WiFi/router forum I can visit? The last time it happened on my phone I went into my router and noticed something; whenever we can't get the phones to connect they stay on a br0 interface instead of changing to a eth1 interface, which is above my head so I need somewhere to go! (Though I thought I read on a forum posting that a wireless connection will not work on a br0 interface...) I also can't ping my phones IP address when I experience the problem, so it is definitely a connection between the phone and router problem.

    Any advice is appreciated, thanks!
    06-24-2014 06:23 PM

Similar Threads

  1. [Share] Suggest your favorite game in androidcentral
    By atdmobile_world in forum Android Central Apps
    Replies: 5
    Last Post: 06-20-2014, 03:29 AM
  2. WiFi question
    By frag06 in forum Legacy Android & Other OS's
    Replies: 4
    Last Post: 06-14-2014, 10:37 AM
  3. Bluetooth knocks out WIFI -- Kitkat issue
    By donnieco in forum Droid RAZR HD
    Replies: 1
    Last Post: 06-13-2014, 06:01 PM
  4. Android Touch Pad Problems
    By Joey Deke in forum General Help and How To
    Replies: 0
    Last Post: 06-13-2014, 11:21 AM