1. AC Question's Avatar
    Hi, I have a HTC EVO lte phone *NEVER ROOTED* and for some reason, it continues to reboot. It gets to the first boot screen - HTC - quietly brilliant - then stays there for 45 seconds... goes black and then restarts. I believe some moisture might have gotten into it.

    I have done the hboot screen - and done both recovery and factory reset which immediately just put it right back into the reboot loop. I have taken it completely apart to see if I could find any moisture / none found. Scoured the internet to see if I could find any other techniques, so now I am here looking for help.

    As a side note, I do have the exact same phone that turned into a brick a year ago. So I do have the ability to replace parts. I can occasionally get the bricked phone to start up but then quickly dies.

    Any advice would be greatly appreciated.
    06-08-2015 05:44 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! How much moisture do you think got in? There's no way to really "see" water-damaged components, unless they're blatantly corroded.
    06-08-2015 05:59 PM
  3. oconnorjohn81's Avatar
    It was placed on a wet towel for about an hr... When I laid it down, didn't realize it was damp.

    Thanks for any advice.

    John
    06-08-2015 06:12 PM
  4. B. Diddy's Avatar
    Very difficult to guess which if any component should be replaced. That would require a skilled technician to do some diagnostic testing, I would imagine. The easiest thing to do would be to replace the battery.
    06-08-2015 09:12 PM

Similar Threads

  1. How do I get rid of my signature on my text messages?
    By AC Question in forum Samsung Galaxy S5
    Replies: 3
    Last Post: 09-22-2017, 12:32 AM
  2. HTC One says PIN is incorrect after system update, why?
    By AC Question in forum HTC One Series
    Replies: 2
    Last Post: 11-17-2015, 03:13 AM
  3. Replies: 1
    Last Post: 06-11-2015, 10:09 AM
  4. Replies: 1
    Last Post: 06-11-2015, 10:00 AM
  5. New Android user - question on 4G?LTE
    By quizzer25 in forum ASUS ZenFone 2
    Replies: 3
    Last Post: 06-08-2015, 03:47 PM
LINK TO POST COPIED TO CLIPBOARD