1. Jeffin92833's Avatar
    I rooted my EVO 4G (it’s at 2.3.5), but didn't do a lot with it (still have the Sprint ROM), but I recently noticed that Google Play isn't there, anymore (well, it is there, sort of; I occasionally get the message that com.android.vending has stopped unexpectedly). I must have really done something wrong.

    I have ClockWorkMod Recovery v5.0.2.2 and a quick review shows one backup from 2013 (shortly before I replaced the phone) but, as I recall, that one is not a NANDROID (I don't think this version of CWM even does that).

    I also have Titanium Backup and the one backup I did was for everything, including System apps. Google Play is listed, but restoring Apps+Data and rebooting got me nothing (even though TB said that the restoration was completed). The Google Play backup version is 6.5.87. There is the outside possibility that Play was mangled before I did the backup.

    I can place files on the phone manually via USB for Recovery to install it, but I cannot find the Google Play executable/ZIP/whatever anywhere.

    What are my options? Should I wipe (if so, which options)? Factory reset?

    Thanks in advance,

    Jeff
    01-29-2015 03:11 PM
  2. Jeffin92833's Avatar
    Okay... I found GApps for my EVO 4G (gapps-hdpi-20101114-signed.zip), but booting into recovery and extracting the ZIP file did not restore Google Play.

    If I do a Factory Reset, will I lose root? I've found differing answers to this question elsewhere. I want to know what I need to do to prevent that.


    Thanks in advance,

    Jeff
    01-31-2015 08:32 PM
  3. Jeffin92833's Avatar
    As it turns out, that backup I made with the ClockWorkMod recovery was a NANDROID one, which was indeed fortunate for me, because installing that gapps file (see previous post) caused my phone to constantly reboot until I restored the entire phone (choosing the Advanced option and just trying to restore 'Boot' didn't help).

    After I restored and rebooted, I got rid of the constant reboot problem and Google Play was back. Now I can continue experimenting with the phone.

    I know this part of the site is nearly dead, but everything still shows up in Google searches, so maybe it'll help someone.


    Jeff
    02-01-2015 04:07 AM

Similar Threads

  1. No Likes appear on thread.
    By Madd54 in forum Site Feedback & Help
    Replies: 7
    Last Post: 01-30-2015, 02:51 PM
  2. Replies: 4
    Last Post: 01-30-2015, 03:32 AM
  3. How do I change the default calender on my phone?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-29-2015, 03:25 PM
  4. Why haven't I got 4g or data service?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-29-2015, 03:21 PM
  5. Replies: 0
    Last Post: 01-29-2015, 02:57 PM
LINK TO POST COPIED TO CLIPBOARD