1. thermbug's Avatar
    Rooted about 10 days back. Unrevoked 3.32. Has been working fine.
    Was trying to do appinventor. I couldn't get it to detect under PC. Then tried to see it just as an E:\ drive. Tried USB debugging setting both checked and unchecked. "Connect to pc" set to disk and to ask on each connect.
    So tried the drivers again,
    Tried HTC sync 2.40,
    Tried the 3.0 even though it's for other versions of HTC phones.
    Tried the Hboot android custom driver which worked the 1st time. Made sure to remove drivers from prior installs with pnputil -f -d. Still won't detect and show up as a mass storage device.

    Tried freezing sd related apps and re-enabling the sprint apps that I'd frozen. Disabled no-lock, watchdog, juice defender and app2sd in case they had an effect.

    Still not working on usb.

    So drop into bootloader. Hboot 2.10, S-off
    I go into to bootloader both via quickboot or via power/vol down. On hboot after the flicker of checks it goes to hboot usb, but never shows hboot usb plug.

    I've tried 2 cables, Different ports. 30 second battery pull.
    Do have a 1st nandroid.

    Stock rom, removed sprint apps via titanium backup pro. Have a copy of the applist saved. Have a few titanium backups.

    I do have a question before I start down the path of hard resets, factory resets, titanium restores, app restores or unrooting .I'd suspect OS is confused somewhere since it charges on usb. But it doesn't detect usb either in bootloader?
    Could it be a bad evo usb plug? I've read about this as an Evo issue. It charges but never connects. Another unrooted evo in the house does show as a mass storage device using these same cables.

    Do I restore, reset etc?
    Do I unroot via the sdcard and go see sprint? I downloaded pc36img for the 3.70.651 that I could restore via clockworkmod.
    I did see some references to copying flash_image to fix usb that won't detect.
    What have I left out?
    01-30-2011 10:15 PM
  2. 2CupsWithString's Avatar
    01-30-2011 11:37 PM
  3. Mark_in_Tulsa's Avatar
    I'm sorry if you mentioned it and I didn't see it, but did you flash a ROM or are you just rooted with the stock ROM.

    Also can you go into recovery and use Mass USB Storage. (or named something similar) And then plug your phone in and see if your PC recognizes it?
    01-31-2011 06:33 PM