07-08-2010 07:34 PM
150 123 ...
tools
  1. storino03's Avatar
    I got mine on launch day, from RS, to be exact, and have had ZERO problems with the phone. This topic is for those who have not had any issues and are currently on their first device.

    Bring on the positivism!
    06-19-2010 08:05 PM
  2. Justin V's Avatar
    Aside from a couple rests ive had no problems.
    06-19-2010 08:09 PM
  3. boggs3010#AC's Avatar
    Same here radio shack on launch day. No screen lifting no resets....no cracked buttons. NO random restarts.

    One very very minor issue, if I get a pic text message it is time stamped 5 hours off. (earlier)
    06-19-2010 08:09 PM
  4. wrxdrunkie's Avatar
    No problems yet
    06-19-2010 08:15 PM
  5. idesofmarch's Avatar
    I've had it since launch day and other than light leakage from the bottom(doesn't bother me) I haven't had any issues.

    Sent from my EVO 4G using Tapatalk
    06-19-2010 08:16 PM
  6. Robbie317's Avatar
    Got mine right when best buy opened on the 4th and No problems I have been able to find.
    06-19-2010 08:17 PM
  7. splmonster's Avatar
    I have had mine since launch and no issues to report. Except one stuck pixel, but that's about it.
    06-19-2010 08:19 PM
  8. kinster02's Avatar
    Launch day from the Shack, so far so good!
    06-19-2010 08:20 PM
  9. rodeiguez102's Avatar
    Launch day from sprint, no issues.
    06-19-2010 08:21 PM
  10. aaronpaul's Avatar
    Day after launch....hope that counts. No issues.
    06-19-2010 08:24 PM
  11. tntsniper#CB's Avatar
    I've had mine since launch and I've yet to have any problems...I absolutely love this phone!

    Sent from my PC36100 using Tapatalk
    06-19-2010 08:41 PM
  12. Cory Streater's Avatar
    Absolutely none, which is really odd considering the luck I've had in the past
    06-19-2010 08:46 PM
  13. bp3dots's Avatar
    Also A shack launch day unit, and its been perfect!
    06-19-2010 08:55 PM
  14. vtective's Avatar
    Radio Shack first day EVO with no problems so far!
    06-19-2010 08:55 PM
  15. gabbott's Avatar
    No issues with mine.
    06-19-2010 09:01 PM
  16. Hannoo's Avatar
    I've had it since launch day and other than light leakage from the bottom(doesn't bother me) I haven't had any issues.

    Sent from my EVO 4G using Tapatalk
    Same here
    06-19-2010 09:03 PM
  17. neilept's Avatar
    I have had it since launch day, with no issues, other than 1 reset. Kind of like my Pre, had it from day 1 till EVO launch day with no problems.
    06-19-2010 09:05 PM
  18. Mike20PR's Avatar
    Sprint store evo from launch day here, no problems for me

    ...fine, i have a teeny bit of leakage on the bottom but thats it

    Battery is fine, screens great as well as everything else
    06-19-2010 09:05 PM
  19. Libdawg's Avatar
    I got mine on the morning after launch day. The only problem that I had was the other day after poking around the system and tweaking with some settings Sense UI force closed and then got caught into a loop. I couldn't get back to any of my screens after that so I just did a hard reset. After that all is good. No screen lift and haven't noticed any light leak to speak of. Battery life is good. I can stream Pandora for about 7 straight without charging.

    Edit: Forgot to say that I am on hardware 0002.
    06-19-2010 09:12 PM
  20. McPlot's Avatar
    Launch day. No major problems. Pandora did lock up the Evo once and I had to pop out the battery to restart it.
    06-19-2010 09:16 PM
  21. chrisho's Avatar
    launch day from sprint with no problems yet. thank god lol
    06-19-2010 09:18 PM
  22. njbianco#AC's Avatar
    got mine at Radio Shack on launch has been working perfect since the first time i turned it on
    06-19-2010 09:19 PM
  23. Blubble#AC's Avatar
    Got mine at Sprint corporate store on launch day and I've had zero problems so far. I'm sure that's the case for most users.

    Obviously, the people with problems are going to make more noise, as well they should.
    06-19-2010 09:22 PM
  24. acstewart82's Avatar
    Launch day Evo from RS here. No issues here.
    06-19-2010 09:25 PM
  25. skullnbones's Avatar
    No problems with either of my 2 launch day evo's.
    06-19-2010 09:25 PM
150 123 ...
LINK TO POST COPIED TO CLIPBOARD