1. LikeAChampion3's Avatar
    My Evo updated perfectly, took 10 minutes. My wife's has been stuck on the screen with the updating icon for over an hour....

    Neither phone is rooted.
    06-28-2010 10:46 AM
  2. LikeAChampion3's Avatar
    I'll just post this here since I started this thread and I don't want this to get lost in the other 2 or 3 others out there. I haven't heard anyone have this specific problem, so I feel its justified being in its own thread.

    Basically, the phone is stuck in a loop on the update screen (the one with the green arrows). It sits on this screen for around 30 seconds and then turns off, and then back on and back to the update screen. It has been doing this for over 3 hours now. I have tried pulling the battery and doing a hard reset on the phone (hold volume down and power button), but nothing gets it off this screen and out of this loop.

    I spoke with sprint customer service, tech support, and advanced tech support and the final conclusion was to try to return it to where we bought it for an exchange. Problem is, no one has them in stock. Calling the RS I purchased it from right now...and they are out of stock. Currently holding to speak with a manager.
    06-28-2010 01:01 PM
  3. lucasjohnson's Avatar
    Yea, I just posted in the other thread, same problem with mine.
    I did have the soft root with unrevoked but I had turned it off many of times since then so it was not rooted when I was installing the update.
    06-28-2010 01:10 PM
  4. LikeAChampion3's Avatar
    I am basically under the impression that the phone will need to be replaced as the repair shop "does not even work on Evos" and no one has any idea how to fix it.

    I hope that RS can order one in next day. I wonder what their policy is regarding the SD card and the battery? I would think that I'll be able to hold on to them, we'll see. I'll repost again if I get more information.
    06-28-2010 01:15 PM
LINK TO POST COPIED TO CLIPBOARD