1. its_miller_time's Avatar
    I cannot stand this crap. I went to send an SMS and scrolled through instead of typing, and I freaking want to throw my phone against the wall. How the hell do I stop all the addresses I have emailed from being added to my phone?

    I have unchecked "Show auto Gmail contacts", but the problem persists. I don't see unwanted contacts inside People app, only in the SMS app, when I tap on the head icon next to "To:" column to select a contact, I still see people I once or twice contacted through mail or Gtalk (both online and through my phone). Pisses me off.

    There has got to be a fix..
    07-07-2010 07:57 PM
  2. reagan247's Avatar
    Go into the People app and hit the menu button, then click the option "View". You'll be presented with an option under your "Google" list that says 'Show auto Gmail contacts' make sure that's unchecked.
    07-07-2010 08:09 PM
  3. its_miller_time's Avatar
    Please read above...

    "I have unchecked "Show auto Gmail contacts", but the problem persists."


    (and sorry if there is any perceived sarcasm, it's just that this issue pisses me off to no extent...)
    07-07-2010 08:13 PM
  4. reagan247's Avatar
    My bad, I must have misread that - I thought you'd meant in the computer-browser version of Gmail.
    07-07-2010 08:19 PM
  5. reagan247's Avatar
    Are the people you're only seeing in your SMS app in your Gmail contacts online? A troublesome, yet easy fix would be to just delete them there and allow the phone to sync. If not, I'd clear the People app's cache and let it re-download everything.
    07-07-2010 08:22 PM
  6. storino03's Avatar
    Uncheck the option in phone settings to add contacts not in your phonebook after each unknown number you dial.
    07-07-2010 08:24 PM
  7. its_miller_time's Avatar
    Storino, but the problem is is that it's email addresses.

    So, for example. When I reply to a facebook comment via email, there is some long email address associated with it. Well, as it turns out, it stored each and every one of them in my "most contacted" - even though each email is unique. So, now when I go to the SMS app, there is approximately 400 "replytocomment..." email addresses in my SMS app.



    Reagan, that is what I find myself doing every couple of days. It's a temporary fix, not a permanent one, which is annoying in itself.

    Anyone else?
    07-08-2010 06:46 AM
  8. dwhitman's Avatar
    Probably not exactly what you're looking for, but maybe this will help.

    Your online google contacts are organized into various groups. Focus on two of them:

    "My Contacts" = the contacts that you've either manually added, or explicitly agreed to keep when google suggested it.

    "All Contacts" = "My Contacts", PLUS a bunch of contacts google thinks you might find useful because you sent or replied to email from them once. It's these suggested contacts that are driving you nuts.

    Now, you might think there'd be an easy way to call up that set of suggested contacts to edit or delete them. You'd be wrong. But there is a weird workaround:

    In the online contacts page, look for the Search Contacts text box. Click in it, then type a single space character, then hit enter.

    This finds all your contacts, but for obscure reasons, the search results are broken out into groups: "My Contacts" and "Other Contacts" waaaay down at the bottom.

    The Other contacts are the ones google added without asking you. Review them, and delete all the ones you don't want.
    07-08-2010 12:04 PM
LINK TO POST COPIED TO CLIPBOARD