1. maduhbee#AC's Avatar
    I'm on my second EVO right now, (got lucky by going into a best buy to get my original exchanged) and Though the screen on the bottom left corner isn't coming up (thus causing light leaks), I can definitely bounce it up and down. It just stops right at the tip, so it doesn't go above the sides, causing light leaks. On the bottom right hand side, it's solid. So the build quality has much to be desired... but I should've expected this coming for a product made in china.

    Also, a bug that I see that's pretty consistent with the first EVO I've had, and my current one is that when I'm in my car, using Sprint Navigation, and talking on the phone via Bluetooth, the phone will restart randomly during the conversation. I thought it was just limited to my first "defective" EVO, but it's carried over to this EVO as well. I think it might be Sprint Navigation, as I don't recall having restarting issues with the Google Navigation.

    Has anybody else experienced this?
    07-14-2010 02:33 PM
  2. Holsum's Avatar
    havent heard of that issue before with sprint navigation. but if you are returning the evo for little defects like light leakage i would recommend going with a different phone altogether as you will never be happy with the EVO.
    07-14-2010 02:41 PM
  3. Kevin OQuinn's Avatar
    Just use Google Navigation then. And I'm picky with new things too. It might be nit picky, but I want something that I buy new and are expected to keep for at least a year to start off perfect.
    07-14-2010 02:43 PM
  4. whippingboy's Avatar
    I think there are other threads on this but Google Navigation crashes A LOT - not sure if this is a google Nav thing or Evo thing- (not just force quit but reboots the phone!!!) but it's a major reason I returned the phone and am waiting for the Epic. If the Epic does the same thing- that confirms Google Nav. is WAYYYY too Beta for my use.

    Didn't realize similar issues were had with Sprint Nav as well.
    07-14-2010 02:58 PM
  5. dmrdsm's Avatar
    I've not played with the nav enough yet, but the phone has auto redialed at least 2 times on me when the call I was on was dropped. I haven' researched this yet, but noticed I'm talking, the call drops and then it's redialing. Don't know if it is suppose to do that, or I'm dreaming...but it starts the redial on it's own. Was not on bluetooth at the time.
    07-14-2010 03:57 PM
  6. Kevin OQuinn's Avatar
    I hope they fix whatever the problem is soon.
    07-14-2010 04:03 PM
  7. Makad's Avatar
    Also, a bug that I see that's pretty consistent with the first EVO I've had, and my current one is that when I'm in my car, using Sprint Navigation, and talking on the phone via Bluetooth, the phone will restart randomly during the conversation. I thought it was just limited to my first "defective" EVO, but it's carried over to this EVO as well. I think it might be Sprint Navigation, as I don't recall having restarting issues with the Google Navigation.

    Has anybody else experienced this?
    Yes, this has happened to me twice.
    07-14-2010 04:17 PM
  8. Robbie317's Avatar
    I have used Google Navigation several times and on a long trip (544 miles) with out it crashing or screwing up a call. I travel by car for a living and average 40 - 50,000 miles per year in a car finding different locations... So I have used it a couple of times in place of my Garmin with no problem.... Once a decent car kit comes out I plan on dumping my Garmin all together... I have mine paired up with a Plantronics blue tooth ear piece and it hasn't drop a call or rebooted yet...

    I have had my EVO since June 4... No light leakage problems or screen coming up... I think I got a pretty solid device...

    Only issue I have had is at one point some thing got hung up and the battery would go from 100% to 15% in under 6 hours with NO use at all. This happened after I had the phone for about 2 weeks.... Before that I got 12 - 16 EASILY every day. I downloaded ATK and Spare Parts... Used ATK charged the phone all the way up and about 5 - 6 hours into the night it beeped and flashed "CHARGE BATTERY" using spare parts and looking at the usage there was a block that was full blue but it didn't have any thing written in there... My awake and up times were identical... did a couple of reboots and after 3 - 4 days of this I did a factory reset and it's been golden since...
    07-14-2010 05:40 PM
  9. maduhbee#AC's Avatar
    havent heard of that issue before with sprint navigation. but if you are returning the evo for little defects like light leakage i would recommend going with a different phone altogether as you will never be happy with the EVO.
    Light leakage I can live with. But it's the dust that gets under the glass that I cannot live with. That's what happened to my first EVO, and this one looks like it's going that way. I know they use some really sturdy glass that doesn't get scratched easily, so I clean my phone all the time, with a smile on my face by not seeing a spec of oil/dust/scratch. But today, I saw a couple of dust particles under the screen already, and I can only think of the "slight" rising screen on the bottom left hand side. Like I said, this time, it's not enough for it light to leak (unlike the first EVO) but I'm somewhat bummed about this. Now I'm past my 30 days, and the only phone I can get are refurbished ones from Sprint. What I'm going to do is probably wait until the Samsung EPIC comes out and get a new phone and sell it, so i don't lose anything on it!
    07-14-2010 07:28 PM
  10. Bujin#IM's Avatar
    My EVO fairly regularly restarts when I'm on the phone while using either Google Nav or Sprint Nav.....it's my only frustration with the phone.
    07-14-2010 07:42 PM
  11. McPlot's Avatar
    Did you get the Sprint Nav update yet? It runs 1000% better then before the update.
    07-14-2010 07:50 PM
  12. LocationDudeNYC's Avatar
    My EVO fairly regularly restarts when I'm on the phone while using either Google Nav or Sprint Nav.....it's my only frustration with the phone.
    Happens to me, too.
    07-14-2010 08:03 PM
  13. Bujin#IM's Avatar
    Did you get the Sprint Nav update yet? It runs 1000% better then before the update.
    I did, but the problem doesn't seem to be Sprint Nav specific - it happens with Google Nav as well. There must be something between the phone / gps / bluetooth radios, as it only seems to happen when on a bluetooth call and running a nav program.
    07-15-2010 01:08 PM
  14. turtle3#AC's Avatar
    Be weary of Apps you might have installed that could be running in the background and crashing the phone. I had a similar issue, not when running any Nav apps, but it started after I went to the market and binge-installed a bunch of fun apps I found.

    I systematically started removing some I found to be running in the background (location-dependent) and boom - haven't had another issue.

    I don't believe this "resetting issue" is actually an issue with the device/Google/Android/Sprint. Most likely, it is related to a 3rd party app you've installed that possibly also uses GPS for some feature.

    Consider deleting some apps to find the trouble-maker and see if that helps.
    07-15-2010 02:24 PM
  15. Gelst's Avatar
    I just used Google nav exclusively for a 4.5k mile roadtrip and it crashed one time. Well it just locked up my phone bascially and I had to restart it. I used the nav for probably 8 hours a day for a week. The one time I did experience a problem with it was out in the middle on nowhere on some backroad.. So I can't complain.
    07-15-2010 02:32 PM
  16. sel1965's Avatar
    I have driven to Houston, and Dallas TX the last three weekends using Sprint Nav and no issues what so ever so I don't think this is a bug issue or it would be happening to more than one or two. You might want to check and update your profile or maybe check your apps that you have installed.
    07-15-2010 02:58 PM
  17. theiphonewannabe's Avatar
    I have not had this issue at all. I have been in the same situation as the OP and do not get the same results. Other fun thing to note, my wife has been using Mobile Hotspot at the same time with her phone as we drive. No problems there either.
    07-15-2010 02:58 PM
  18. QuasarZ's Avatar
    Mine will restart when talking while Sprint nav runs in background.
    07-15-2010 05:10 PM
  19. gspam1's Avatar
    Mine will regularly restart when I'm talking on the phone via Bluetooth and using Sprint Navigation. I can do one or the other just fine, but using both causes a restart.
    07-15-2010 11:31 PM
LINK TO POST COPIED TO CLIPBOARD