1. MultiMatt's Avatar
    Has anyone else had issues with their digital compass? Mine worked initially, but a few weeks back, I went to show off Google Sky Maps and felt like a fool when the app stood still despite my turning around 360 degrees!

    Installed a compass app and the needle on it jumps ALL over the place. Sometimes the reading is (somewhat) correct, and other times, it bounces all over the place.

    I have re-calibrated so many times I have lost count. Beginning to think I need to go look into getting this thing swapped out. I am currently demoing a Droid X for a review and for demo at our monthly meetup, and Sky Maps works like a charm on that device. I even filmed it, but I haven't converted it over to YouTube yet.
    07-25-2010 12:39 PM
  2. Yourdogsdead's Avatar
    It's possible there is interference. Is it happening all the time?
    07-25-2010 12:41 PM
  3. MultiMatt's Avatar
    Happening ALL the time. Inside, outside, normal grip, Steve Jobs recommended grip...
    07-25-2010 01:20 PM
  4. dwhitman's Avatar
    I get the same thing. Pretty much unusable - it's sometimes accurate, but other times wildly off and/or jumping around at random. If I don't know which way is north, how can I know if this is one of the accurate times? Can't trust it.
    07-25-2010 02:02 PM
  5. eye4ni's Avatar
    Happening ALL the time. Inside, outside, normal grip, Steve Jobs recommended grip...
    Steve Jobs recommended grip, that is f'n hilarious
    07-25-2010 10:28 PM
  6. Kedar's Avatar
    Try some of the compasses in the market.
    The one made by "background" has good ratings...
    07-25-2010 10:39 PM
  7. TheBundo's Avatar
    Are you wearing a ring or have a watch on the hand you are holding the phone with? This would likely cause a problem since it is an electronic compass, and there is even a metal detector app.
    07-26-2010 10:37 AM
  8. MultiMatt's Avatar
    @kedar - I've tried a few compasses and the needle is jittery on each...

    @TheBundo - only jewelry is wedding ring, but I've handled with my right hand (no jewelry) with same result. Also, while testing Sky Maps on the Droid X, the compass worked fine in my left hand - not affected by my wedding band at all...

    The X has some nice additional settings under Location & Security. It says "rotate the phone back & forth in all three axes until the compass image turns green". Nice touch... wish it were on the EVO...!
    07-26-2010 11:02 AM
  9. olemil#AC's Avatar
    I found out mine is having problems too running a compass app and google sky map. They both worked fine for a few days after installing, now the sky map is very sluggish when rotating and the compass is a dog unless you re-calibrate it everytime you open it. So I guess the magnetic sensor on the EVO's are pretty much junk?? I un-installed both apps and will try them one more time... if they don't work, guess I'm SOL. TIA for any tips.
    09-05-2010 02:28 PM
  10. redphone's Avatar
    I know this thread is a bit stale, but I thought I'd chime in with my recent findings on this topic.

    Ironically, the problem with the compass is actually caused by running the G-sensor calibration. For any phone that has never had the calibration performed, the compass will more than likely work flawlessly. If you run the calibration even just once, you'll essentially hose your phone's compass performance and any app that uses it (including Google Sky Map). The compass will actually still work with any of these apps, but only after you first shake/move the phone around significantly (the "figure 8" trick). Once you close the app though, next time you run it or any other compass-enabled app, you'll have to redo that shaking/figure-8 routine. Yes, this is a pain and certainly not desirable... I'm pretty sure it's a software/firmware bug, since a hard reset does fix the problem.

    I've confirmed this behavior on 2 of 2 EVOs, so I'd bet it affects all EVOs. I'm currently running Android 2.2 with the latest 3.29.651.5 build, although I think this problem affects earlier builds, too.

    I haven't tried to convince anyone at Sprint, HTC, or Google of the issue, since I'm not sure how to get ahold of anyone even remotely close to the "right" person. Customer Service and Sprint's phone tech support certainly are not the right people. If anyone has any ideas or knowledgeable tech contacts (HTC is probably ultimately the right place), I'd love to bring this to their attention.
    10-04-2010 01:38 AM
  11. sparksd's Avatar
    Yeah, I found that holding it flat in my hand and doing the figure-8 was inadequate - moving it all around, up-and-down, twisting and turning gets it calibrated for me.

    10-04-2010 09:07 AM
  12. Diplomat1's Avatar
    I have an HTC EVO which was having lots of trouble with the g-sensor. I downloaded Compass V2.0 from catch.com and the compass wasn't working.

    I then searched YouTube for "best compass calibration method" and found this video . The method shown seems to give the best results quickly.

    I also had trouble with Yelp which uses the g-sensor. I brought up Yelp and then just did the motion from the video and then Yelp would work.

    The following method seems more complete and detailed . The speaker seems to be an authority on the best way to calibrate and gives a number of hints about the g-sensor and how it works.

    If you decide that you really want to clear your g-sensor history (normally not recommended), you can try the following. Bring up the compass application, click on menu, and select "calibrate". Before you click "OK" just do the motion from the first video. You'll feel a vibration when the calibration is complete. Then the compass should work. However, the EVO seems to lose the g-sensor calibration once the application is closed.

    Hope this helps!
    04-04-2011 04:10 PM
  13. Vetdoctor's Avatar
    Ditto to the above. But intersting remark about the compass working if you've never calibrated it. I have done a hard reset on my phone.I'll re-download skymaps and give it a try but to my memory it worked for a short while then failed and that'[s why I started (constantly) re calibrating it.
    04-08-2011 06:53 PM