1. EvoRoy's Avatar
    Has anyone had any charging port problems? I'm using the stock charger and have to wiggle it to get the charging light to come on. Also sometimes the usb debugging registers when its plugged into the wall.
    09-27-2010 08:53 AM
  2. Khaelum's Avatar
    Has happened to me off and on. Some charges seem to connect and work better than others.

    Sent from my HTC Evo using Tapatalk + Swype
    09-27-2010 08:56 AM
  3. imtravis's Avatar
    Mine did that right before it broke off.. then it didn't take a charge at all.
    09-27-2010 09:04 AM
  4. 2CupsWithString's Avatar
    My sprint store exchanged mine but I read on here about some people getting a hard time about exchanging it for the charing port (I also had white spots on the screen but the rep and mostly talked about the charing port and she told me it's a problem on a lot of EVOs).
    09-27-2010 09:12 AM
  5. EvoRoy's Avatar
    I tried my friends charger and it works fine. I'm hoping its just the charger.
    09-27-2010 09:19 AM
  6. Redraider1's Avatar
    I was having the same problem. I looked closely at my micro usb charger plug and noticed it was slightly bent down (the prongs that hold it into place were not sticking out from the bottom). I just carefully bent it back straight and the prongs came back out and now it works perfectly every time again.
    09-27-2010 09:29 AM
  7. dpg's Avatar
    seems mine is starting the wear down too, maybe they can exchange it for me.
    09-27-2010 01:30 PM
  8. saintv90's Avatar
    Mine has been getting worse and worse. I believe these issues are the port on the phone. They are a bit large and leaves the cables room to move. I have to bend cables and play with the phone to actually get it to charge. And then don't touch it or the charge will stop! Really annoying!
    09-27-2010 02:24 PM
  9. saleen2002's Avatar
    is this happenin on all releases of evo or just the early production evo? thanks
    09-27-2010 10:21 PM
  10. leo1977's Avatar
    I was talking with my local repair guy. He told me that this is the most common hardware problem he is seeing with the evo. He showed me one where the port fell right out. He hold me to be careful pulling the charger out and to watch for this.
    09-27-2010 10:40 PM
  11. EvoRoy's Avatar
    This really sucks I think it may be the port on the phone. I am fully rooted and have just begun to play with different ROMs. I'm going to have to unroot and start from scratch if they need to exchange my Evo.
    09-27-2010 11:31 PM
  12. BPHusker's Avatar
    Has anyone been able to exchange theirs without paying the replacement fee? Mine just started doing this last weekend and it has been very annoying.
    09-30-2010 06:46 AM
  13. 2CupsWithString's Avatar
    Has anyone been able to exchange theirs without paying the replacement fee? Mine just started doing this last weekend and it has been very annoying.
    I just walked in to the store and said this is broken and they gave me a new one without a fee.
    09-30-2010 07:02 AM
  14. skife's Avatar
    charging port issue 9 out of 10 times comes from using the phone while its plugged in. Its a really really small port (Poor design IMO) and the cord puts alot of stress on it while plugged in. car chargers even more so because they are coiled.
    09-30-2010 10:02 AM
  15. Gekko's Avatar
    are you putting the cable in upside down or sideways jamming them in until you get it right and thus causing damage to the port and/or cable?
    09-30-2010 10:04 AM
  16. Darth Mo's Avatar
    are you putting the cable in upside down or sideways jamming them in until you get it right and thus causing damage to the port and/or cable?
    Hah, I hope no one is doing that.

    I went through three cables in the year I had my Palm Pre, and now I'm already on a second travel cable for my Evo.

    It seems some micro USB cables don't hold up well to being plugged/unplugged a dozen times per day. It could have something to do with the port as well, but I'm not going to replace the device when swapping the cable works fine.

    I ordered three 6' Micro-B to USB 2.0 cables from Monoprice last week for $6 total shipped. I was a bit wary they wouldn't work since they were so inexpensive, but they work fine even charging with USB and are pretty sturdy. A lot sturdier than the $0.99 one I bought off eBay from Honk Kong that didn't work at all.

    At this point, I can live with replacing a $2 cable every 2-3 months even though I shouldn't have to.
    09-30-2010 10:52 AM
  17. btj's Avatar
    Every phone I've ever had has done that over time. Usually a new cord does the trick.
    09-30-2010 10:57 AM
  18. bagger's Avatar
    I just had to go to sprint for my second replacement evo due to the micro usb port breaking loose! The first time, I didn't get any trouble and was on my merry way.

    BUT

    This time, oh this time..... I was told I need to go through esurion. I ended up having to ask for a manager.... then battle with the manager that simply plugging in my charger should not dislodge the port and is not damage that warrants using Esurion vs the normal Sprint insurance.... then had to explain that if Sprint wants higher customer satisfaction ratings, this is not the way to do business.

    After that, I then let them know that if I had to go through Esurion, I would get my new phone, ebay said new phone, followed by dropping Sprint and going with another carrier where I explained I get a bigger discount through.

    I now have a refurb on the way..... but the taste in my mouth is rather sour..... I will be refering to threads like this if those a-holes tell me they "never have problems with the charging port" again!
    09-30-2010 05:38 PM
  19. dekcufi's Avatar
    No one should be paying for a flawed design! It is not an evo specific problem. WHen they tell you that it is from talking on the phone with it plugged in and not covered under warranty ask them to show you in the manual where it says that warranty will be void if you talk on the phone while it being plugged in!
    09-30-2010 07:20 PM
  20. Super Noob's Avatar
    It might be the cable and not the port. Mine quit charging or connecting to the computer so I thought it was the port that had gone bad. I borrowed a friend's Aria cable and it worked.

    The HTC cable is 2 parts, the USB cable and a wall outlet adapter. I used his cable and it worked. Instead I only use a new USB cable I bought to connect to the computer and a 1-piece wall outlet to charge the Evo. No more problems.
    09-30-2010 07:29 PM
  21. bagger's Avatar
    It might be the cable and not the port. Mine quit charging or connecting to the computer so I thought it was the port that had gone bad. I borrowed a friend's Aria cable and it worked.

    The HTC cable is 2 parts, the USB cable and a wall outlet adapter. I used his cable and it worked. Instead I only use a new USB cable I bought to connect to the computer and a 1-piece wall outlet to charge the Evo. No more problems.
    I don't know about others, but my port was completely disconnected from the circuit board (still in the phone though)...... it's not the cable in my case since I have a half a dozen monoprice cables in varying lengths from 6-15 feet
    10-01-2010 04:59 AM
LINK TO POST COPIED TO CLIPBOARD