1. MonsterMatt's Avatar
    So I know this is just silly and is simply aesthetic but I really want to replace the protips widget from Cyanogen and replace it with the green version so it will go with my theme.

    However just trying to overwrite it with the green verson will come back it "application not installed" and when i try to delete Protips.apk from the system/apps folder it won't let m do that any way to replace the Cyan version to the Green one?

    11-28-2010 10:29 PM
  2. bender1077's Avatar
    You need to remove completely, but it is a system app so you cannot simply uninstall.

    If you installed the Android SDK you should be able to use ADB to remove system apps. I'm not sure of the exact file name so I wrote "protipswidget.apk", but it could be something different.

    After you remove protips, I would reboot the device, and then adb install to /system/app/ the preferred protips widget.



    adb remount
    adb shell
    cd /system/app/
    rm protipswidget.apk
    adb reboot

    Terminal Emulator is a free app on the market that also works great. Here is the code to enter when in TE:

    cd /system/app/
    mount -o remount,rw /dev/mtdblock3 /system
    rm protipswidget.apk

    Let us know if it worked.
    MonsterMatt likes this.
    11-29-2010 10:27 AM
  3. MonsterMatt's Avatar
    Im having issues using the Terminal Emulator as I don't have adb installed I figured I'd do it this way...

    Is that code all one block or does each command line go after one another exactly as you typed? Because when I type su it goes down a line showing a #then I type in cd/system/app/ and hit enter and it comes back not found?
    11-29-2010 01:36 PM
  4. MonsterMatt's Avatar
    So with more tinkering I tried to remove it via Terminal Emulator and I got a "can't remove protipswidget.apk : No such file exists"
    So I think im typing this line in wrong can you clarify for me please?

    mount -o remount,rw /dev/mtdblock3 /system
    11-29-2010 01:43 PM
  5. MonsterMatt's Avatar
    Lol sorry for triple posting but just wanted to say thank you Bender1077 for pointing me in the right direction, so I did more research and found a way through the Terminal Emulator!

    I used this

    su (enter)
    mount -o rw,remount /system (enter)
    rm -r /system/app/Protips.apk (enter)

    Thanks again.

    Topic can be closed now.
    11-29-2010 02:55 PM
  6. bender1077's Avatar
    Sorry! Would have got back to you, but I'm really never on this site!

    Glad it worked out.
    11-30-2010 02:03 PM