1. duke8804's Avatar
    I have the evo and a netgear router and the evo connects and runs perfect the only issue is that I am unable to log on to the management console for the router from my phone and I can from my computer with no issues.

    I go to the address which is and the screen pops up asking for user name and password. I enter them in and it acts like the password is incorrect I have tried changing the password to 12345678 just to make sure I had no typos and still no luck. I have tried the default browser, dolphin browser, and opera but none will let me log in.

    Does any one know what the issue could be.
    01-18-2011 05:07 PM
  2. caleb02's Avatar
    user name is admin
    password is password
    01-18-2011 05:18 PM
  3. duke8804's Avatar
    I change the password for security reasons. As I stated I have no issue long in from a computer just from my evo.
    01-18-2011 05:32 PM
  4. DaneHR2's Avatar
    I also have a Netgear router, trying to login produces the same results. It just resets and asks for the name and password again. Duke have you ever logged into any other brand of router? I have not tried.
    01-18-2011 08:02 PM
  5. kitster's Avatar
    Have you tried another browser besides the stock browser? I have a Netgear RangeMAX Next router, used Dolphin HD and went right in.

    Because of the use of frames on the router wizard home page makes navigation on your EVO a little less than optimal, but it still works.

    Try downloading Dolphin or Miren and try again!

    Good luck.
    01-18-2011 09:41 PM
  6. duke8804's Avatar
    Miren did the trick. Thank you.
    01-18-2011 11:41 PM