1. FightingChance's Avatar
    Hi. Got my EVO new in June. (Hardware ver 0002 I believe).

    This is new behavior since the maintenance release that added Swype not too long ago. In my car I have one of those 'bullet' style 12v sockets that has a USB female port, and a 8" micro USB cable that plugs into that to power my phone while I drive. Since the last maintenance release, plugging the phone into this power source mounts the SD card as if I plugged the phone into a PC and chose 'mass storage device'. Strangely, the boxwave dock I use at home does not do this (the phone charges only). This is very annoying since I can't play my MP3s stored on the card now. Any ideas?

    Thanks.
    01-19-2011 03:33 PM
  2. drjb74's Avatar
    When you plug your phone in to the USB cable, look under notifications. Do you have a notification that says "Disk Drive?" If so, click on it and select charge only. This should change it from mass storage mode.

    I thought I read somewhere on the forums that the amount of power coming from your outlet will signal the phone what is going on. For example, when you plug it into the wall, you don't get a choice for this, because there is too much power to be anything other than a wall outlet.
    01-19-2011 04:16 PM
  3. FightingChance's Avatar
    No notification icon appears in the top bar when plugging the phone in. Only a 'Preparing SD card' notification appears when I unplug it. Is there any other place to check phone status?

    The charging mode when plugged in is 500ma (USB charging), and not 1A or AC charging. This shouldn't technically trip behavior one way or another.

    My gut feeling is that a basic section of the HTC kernel was changed regarding USB root devices and descriptions which accidentally included some esoteric part that now included my charging method. (aka there is no fix unless kernel updates that come after happen to fix it)
    01-19-2011 05:25 PM
  4. hakeem5000's Avatar
    I'm having the exact same problem since the update last month. Very frustrating. Can't play music when I am in my car and charging anymore. I don't have the option to change how it is charging, it only charges and won't allow access to my SD card while charging. Still can't figure it out.
    01-20-2011 10:52 AM
  5. workindev's Avatar
    Try going to settings -> Connect to PC -> Default connection type and make sure that Charge Only is selected.
    01-20-2011 12:02 PM
  6. vel7wil's Avatar
    Also had my eVo since june and I regularly go from in the house charging to the car charger and not se this propblem,,even since the last update....Try connecting to a pc and when the option scene come up check the charge only option and dont ask again and done....that should help or even stop the behaviour
    01-20-2011 12:10 PM
  7. FightingChance's Avatar
    The default charge schema is set to 'charge only' already. I have tried turning off and on the 'ask me' prompt. The phone does not ask nor make visual notification that the SD card has been mounted. When I go into Settings, then to SD and Phone Storage, the card is listed as 'unavailable', almost as if there was no SD card installed at all. I also tried the stock cable in place of my shorter cable; no difference. I would be interested to try a 12v DC charger that terminates in a micro SD plug rather than my current USB female plug.

    Good to know some others have this problem as well. I may soon take this to HTC as only they will be able to fix it.
    01-20-2011 03:16 PM
  8. FightingChance's Avatar
    I'm having the exact same problem since the update last month. Very frustrating. Can't play music when I am in my car and charging anymore. I don't have the option to change how it is charging, it only charges and won't allow access to my SD card while charging. Still can't figure it out.
    Which car charger or parts are you using?
    01-20-2011 03:46 PM
  9. workindev's Avatar
    I would rule out a problem with your car USB adapter before taking it to HTC. USB has 4 pins: 5V, Ground, and 2 differential data pins. Some devices just look for the power and ground pins, while others use the data pins to determine if it is plugged into a computer or just a power adapter. For example, the Iphone requires that the data pins be shorted together in order for it to charge from a USB power adapter.

    It is likely that the software update did change something about how the phone looks to see if it is connected to a computer or a charger, but the solution is going to be with the charger, not the phone. My phone works just fine with my car charger after the software update.
    01-20-2011 04:11 PM
  10. FightingChance's Avatar
    I would rule out a problem with your car USB adapter before taking it to HTC. USB has 4 pins: 5V, Ground, and 2 differential data pins. Some devices just look for the power and ground pins, while others use the data pins to determine if it is plugged into a computer or just a power adapter. For example, the Iphone requires that the data pins be shorted together in order for it to charge from a USB power adapter.

    It is likely that the software update did change something about how the phone looks to see if it is connected to a computer or a charger, but the solution is going to be with the charger, not the phone. My phone works just fine with my car charger after the software update.
    This is most likely what has happened; at least, it's what I expected most but your info on the USB pins solidifies that somewhat. This was always a temp solution because I want a car dock that keeps the phone on power without me having to plug it in, but still it's good to have this archived for others having this problem. Very curious why they changed the behavior from what it was previously, though. (if this is indeed the root cause)
    01-20-2011 04:35 PM
  11. rwenterprises's Avatar
    I've been having the same problem and suspected all along that the problem is as you've described. What car charger adapter are you using that's
    not giving you any problems? I'm using a Philips cig adapter that comes with the extendable/retractable cable and multiple device accessory tips. Both my stock usb and this Philips cord give me the same problem when plugged into the cig adapter but not when plugged into the stock ac adapter. Your input would be appreciated.
    03-02-2011 10:43 PM
  12. workindev's Avatar
    It's a generic one that I got at one of the made-in-china accessory stores, I think it was handhelditems.com.
    03-03-2011 12:46 PM
  13. FightingChance's Avatar
    UPDATE

    Finally got a normal DC car charger and hooked it up to the HTC car dock and *still* get this same problem.

    I figure it must be my phone specifically or some other weirdness, I would think this would be a major issue, as charging your phone while accessing the SD card contents is a pretty big deal. Any additional insight is appreciated.
    03-17-2011 01:59 AM
  14. FightingChance's Avatar
    Okay, I went to a Sprint store and I think I have a working theory about what's going on.

    At the Sprint store, my phone was just as random charging correctly off some chargers and charging but making the SD card unavailable on others. The behavior was different (correct) on a hardware version 0003 phone; it would charge without incident.

    Using Spare Parts app, I am able to see which charging state the battery is in (1 amp AC or 500 mA USB). In AC states, the phone charges fine. In USB charging states, the SD is unavailable.

    My theory is that HTC has at least two or more code branches for the EVO/Supersonic, based on hardware revision. During a code merge, code for later hardware models superseded code for mode 0002 regarding USB states and charging, and that code was pushed to our phones during the Sprint maintenance update.

    Now, how to deal with this... I'm pretty sure we're screwed, as HTC is most likely the one responsible for this and as I understand it's not easy to converse directly with them. I'll continue researching this; I'm afraid even new ROMs will not fix this if they use the codebase that has this flaw in it. Suggestions welcome.
    03-17-2011 04:38 PM
LINK TO POST COPIED TO CLIPBOARD