1. matthewriley's Avatar
    Hello,

    I'm an experienced Android user and recently my Dad picked up a HTC EVO. I set him up with all the Google services and apps like Gmail, Contacts and Calendar. I exported all of his contacts and appointments out of Outlook to CSV and uploaded them to Google so they can sync down to his EVO. Unfortunately when I go to his Google account sync settings, his phone does not show the option to sync his Google Calendar. The exact option I'm talking about is under (from the home screen) Settings -> Accounts & sync -> your Google account. The phone shows Books, Contacts, and Gmail but the option for calendar is missing. Is this the case on all EVO's?

    I have a screen capture of my phone (HTC Incredible) that has the option below that I'm talking about. His HTC EVO does not have it for some reason. Is this a Sprint restriction? Any ideas on how to add it?

    Any help is greatly appreciated.

    Matt
    01-26-2011 04:15 PM
  2. turbostang's Avatar
    My EVO shows sync contacts, gmail, calender, so it doesn't look like a Sprint restriction.
    01-26-2011 04:44 PM
  3. jj14x's Avatar
    On my stock EVO, under settings -->accounts and sync --> (manage account section)google - I see "Sync contacts", "Sync Gmail", and "Sync Calendar"
    01-26-2011 04:46 PM
  4. project.in.process's Avatar
    are you giving your phone ample amount of time to recognize that his Google account now has a Calendar portion associated with it?
    I've added multiple calendars and a good amount of the time, they're simply not recognized by the phone as existing. After about an hour, on the initial attempt to sync, i'll do a complete 'sync all' of the phone (using the widget provided with the phone) and then go into settings and it will show that a Calendar is then ready/able to be synced.

    just an option/something to think about.
    01-27-2011 10:24 AM
  5. I.R.R.V.'s Avatar
    I had the same problem a long time ago, I think if you click on my name you should be able to see the posts I've made, shouldn't be to hard to find the ones concerning the calendar, and how I solved the problem I had. I would post a link but I am using the phone, and more importantly I'm lazy......... lol
    01-27-2011 10:53 AM
  6. aairraa's Avatar
    My phone also does not have this option. It only shows contacts and mail. How do I get it to recognize my google calendar to sync?
    06-20-2011 09:11 PM
  7. hpicken's Avatar
    I am having the same problem now. My evo will sync email but not the calendar function. I thought I'd delete the account on the phone and then set up again in case there was a problem with how I set it up, but it says I can't do that without resetting the phone to factory settings.
    10-26-2011 08:02 AM
  8. hwoodpi's Avatar
    I found this on the Gmail Support forum and cut and paste it here. The author is a JohnSk (no profile) who is TOP contributor he submitted it on 04/30/11. AGAIN this is not my post. But since this issues has been upsetting to me I thought it would help those in need for stress relief from the problem. Oh and it worked the first time i tried it. The guys a genius.

    JohnSK worte:
    The source of your problem is that, although your phone appears to have only one phone book, Android actually has multiple phone books under the covers. When you create a new entry, you have the option to select the phone book you want the entry to set the "Contact Type" to "Google" rather than "Phone" if you want the entries to be synced with Google Contacts. Android gives a warning when you change to Google that some fields will not be available--but puts the entry into the phone book that gets sync'ed with GMail.

    The next question is how to get old contacts that you might have created in your Phone address book over to GMail. To do that, you need to export them from the Phone address book (from inside your Contact list: Menu--Import/Export--Export to SD Card--Phone) and then import them back into the Google address book (from inside your Contact list: Menu--Import/Export--Import from SD Card--Google). The nuisance is that once you've done that, you'll have two entries for each of those contacts, so you'll have to manually go through your contacts list and, for each duplicate entry, delete the one that says it is a Phone entry at the top. It's a pain--but a one-time exercise if you remember to always enter new contacts as Google contacts from that point forward.

    There is an alternative that eliminates the duplicate entry problem--but it presents more risk than the means I described above. After exporting the entries from the Phone address book, you can erase all entries from the Phone address book as a single operation by going into your contacts on your phone, clicking View and selecting "View," unchecking everything but "Phone" in the list of phone books, then deleting all entries. The risk is that if you then have problems importing the entries from the file you exported, they're gone.
    02-01-2012 08:58 PM
  9. mperschke's Avatar
    Do a factory reset! This just happened to my wife with her SGS2.
    02-02-2012 01:51 PM
  10. vikslen's Avatar
    Thanks. Where would I find said widget?
    02-24-2012 04:52 PM
LINK TO POST COPIED TO CLIPBOARD