1. blutuu's Avatar
    I am trying to turn my Evo on but I can't. It worked fine yesterday but the problem started this morning.

    I plugged my phone to a charger and attached the charger to a usb extender.
    (I have done this before and had a similar problem, but eventually got it to work).
    So far I haven't been able to get my phone to turn on for 2 seconds.

    Here is what I do:
    I plug the charger into the Evo and hold the power button (shouldn't have to hold it) and the first boot screen shows up (phone vibrates and all) and after about 1 second, it immediately shuts back off.

    I tried doing the "hold down the volume button" and junk, but the same thing happens. I hope it's just the battery and buying a new one will fix it. Besides that does anyone know for sure what it could be?
    03-02-2011 11:35 AM
  2. dan330's Avatar
    sounds like you have a battery issue...

    it maybe dead.. or way to low to charge.

    i have read that if the battery falls below a threshold.. it will not charge the battery.. (they say it is a safety feature).

    take it into sprint.. they will give you a new battery.

    PS.. if this problem has showed up before.. when you do this...
    why the hell would you do it again????
    03-02-2011 10:41 PM
  3. tangozebra's Avatar
    Yeah, I had this happen, battery got drained and had to charge it for a day to get it to start - even with it plugged in, and even with it plugged in and the battery removed.
    03-03-2011 10:07 AM
  4. FatalErrorz's Avatar
    Yep...that's the battery. What color is the LED when it's plugged in?
    03-03-2011 11:53 AM
  5. vel7wil's Avatar
    Sounds like a short in ur extender.....caused ur baterry to either not charge or to dis-charge
    03-03-2011 12:59 PM
  6. blutuu's Avatar
    I figured it wasn't a big deal to plug it back in, but I guess it was.

    Yep...that's the battery. What color is the LED when it's plugged in?
    Uh the phone has been off for about a day (on the charger mind you) and there is no LED or any kind of signal of power.

    I tried turning it on a few minutes ago and it came on for about 2 seconds this time, but it only does that once every time I plug the charger into the phone. If I wanna try it again I have to remove it and repeat.

    I ordered a new battery and it'll be here today. Hopefully that will fix my problem. Thanks for the replies.
    03-03-2011 01:26 PM
  7. zmann's Avatar
    I agree with all here. I think you will be fine with the new battery.

    03-03-2011 01:31 PM
  8. dan330's Avatar
    you do know that it is still under warranty.. 1 yr from purchase. sprint will replace it .. free at a service center.
    03-03-2011 03:37 PM
  9. Fumetsu's Avatar
    This happened to me once. Try holding both volume buttons and hit power. It should reset.
    03-04-2011 12:13 AM