1. w9med's Avatar
    Is anyone else having problems updating Angry Birds and Seasons on their EVO? Both updates start to load, then give a download error.
    03-11-2011 06:11 PM
  2. firedroidguy's Avatar
    Mine updated just fine, restart your Evo and try again
    03-11-2011 11:42 PM
  3. timinwpb's Avatar
    I've found that I needed to unmount my SD card in order to download Angry Birds and each update.
    03-12-2011 12:29 PM
  4. skyfox99's Avatar
    Try just deleting your android secure folder on your sd card.

    Sent from my PC36100 using Tapatalk
    03-12-2011 12:43 PM
  5. hopefulfarm's Avatar
    I updated mine last night with no problems.
    03-12-2011 10:05 PM
  6. w9med's Avatar
    Tried all those suggestions and still getting download unsuccessful.
    03-12-2011 10:32 PM
  7. NxTech3's Avatar
    try removing the SD card completely
    03-14-2011 10:02 AM
  8. HawaiiD's Avatar
    Is anyone else having problems updating Angry Birds and Seasons on their EVO? Both updates start to load, then give a download error.

    have you tried rebooting your phone?

    I just updated ABS and it took about 20 seconds to download(4G).

    and installed right away no problems.
    03-14-2011 08:23 PM
  9. w9med's Avatar
    Bot sure what it was, everything else was updating just fine. I tried to remove angry birds, but it would not let me reinstall. Finally did a factory reset and not it is updating just fine. Oh well, problem solved.
    03-15-2011 03:00 AM
  10. f1usgp's Avatar
    I get this error everytime I try to update: Unknown-18.
    03-15-2011 10:34 AM
  11. acuramax's Avatar
    My update was a bit sluggish too, but I have very weak cell signal at home, so I switched to wifi, and it went much faster. Hope that helps.
    03-19-2011 06:55 PM
  12. roblee37's Avatar
    had this problem on evo and streak 7 .. found this forum and help with what ryan yo posted... intalling app unsuccessful - unknown error -18 - Android Market Help .. but unmounting card or transferring app back to phone helps also..
    03-19-2011 07:25 PM
  13. firedroidguy's Avatar
    Angry birds has now moved to computers
    03-20-2011 04:18 PM
  14. Verdes8891's Avatar
    My update went fine without a hitch.
    03-20-2011 06:22 PM
  15. sandrshe's Avatar
    Same thing was happening to me. Found out that /sdcard was corrupt. I backed up its contents to pc and then used the phone to format the /sdcard. Moved my files from pc back to the card. Good to go. Give that a try.

    Sent from my PC36100
    03-20-2011 09:10 PM
  16. jhasty's Avatar
    I tried several times. Then I looked through the folders and saw that /cache had barely enough space left for the download. Several Download-x.apk files were in there. I deleted those and uninstalled a coupled of big, unused applications that I saw in the davlik-cache folder.

    Once I had 20+ MB in /cache, the download and install worked fine.

    Anyone know why these Download-x.apk files are left around? Do they get cleaned up somewhere?
    03-21-2011 05:39 PM
  17. Tre Lawrence's Avatar
    Every now and then, I just go in and delete those left over .apks.
    03-21-2011 10:57 PM
  18. midmofan's Avatar
    Hallelujah! Success at last! The solution for the update problem and at least some of the installation problems (like angry birds rio) is as follows:

    First, hook your phone to a computer with a usb cable - need to have your phone in "disk drive" mode. Most likely your phone will at first say "charging only." you will have to click on this to pull up a screen that allows you to change it to "mount as disk drive." Note: this may take several attempts. If your computer does not recognize the phone as being hooked-up at first, unplug it and try again.

    Now, open the new drive that will appear on your computer (which, of course, is actually your phone's sd card).

    Next, locate the file folders named ".android_secure" (it should be near the top of the listings).

    Click on and open up this ". android_secure " folder and look for a file named "smdl2tmp1.asec"

    Delete it! Destroy it! Kick it out of your life! It's what is causing the problems!

    Unplug your phone. Phone will say something like "preparing sd card." It could take a bit but after that you can update all the apps including those on your sd card and angry birds and download Rio hassle free.

    This, IMO, is much better than the suggestions that involve deleting the android_secure file altogether since you DO NOT have to move your apps off of the sd card and then back on again for it to work!

    Credit goes to "the Engineer" who, near as i can tell, was the first to post a version of this fix. As there a a whole bunch of threads on this issue, please pass the fix on.
    03-24-2011 01:20 AM

Tags for this Thread