1. jjeffcoat's Avatar
    I'm having a problem with my Shift maintaining a USB connection. When I connect and mount as disk drive, it connects just fine. But frequently after a few minutes it will revert back to "charge only" on its own for no apparent reason. If I pull down the menu and connect as USB again, it mounts again just fine. Sometimes it will stay connected, sometimes it will again after a few minutes switch back to "charge only" for no reason.

    Any ideas what could be causing this? It's a bit annoying.
    08-04-2011 10:01 AM
  2. crump84's Avatar
    Just a couple of ideas, have you tried a different cable? The htc cable that comes with the phone is notorious for going bad within a few months. Also make sure your using the main usb hub. I would also try taking the card out and mounting it directly into your pc, just to make sure your card isn't corrupt.

    Sent from my Gingerbread Speedy 4G using Tapatalk
    jjeffcoat likes this.
    08-04-2011 10:11 AM
  3. jjeffcoat's Avatar
    Think it's happened with more than one cable but not sure. I have several Palm and one Blackberry microUSB cables, will try switching to one of them. Use one of the Palm cables for charging on my nightstand because it's a little longer than either the HTC or BB.

    Boy I hate the idea of pulling the SD card, you have to remove the battery first and it's a pain. I think I still have a USB card reader and SD to micro adaptor somewhere that still work... If the card's bad it's not a major deal since I'm planning to switch to a class 10 32g card sometime anyway.

    Thanks for your suggestions!
    08-04-2011 11:07 AM
LINK TO POST COPIED TO CLIPBOARD