1. feq451's Avatar
    New to android. My phone connects fine to my wifi at home, at my parents, and open networks at a restaurant. At work today and it will not connect. I am currently using the network to type this on a laptop so the network works. I reset the router which didn't help.

    It seems to be stuck in a loop of obtaining ip address and disconnected. I have tried forgetting the network and rebooting the phone, neither helps.

    I have read other boards reporting similar but nobody posted a fix. This is an unsecured, broadcasted SSID, netwokr.

    Any help?

    adam
    01-09-2011 08:47 AM
  2. anon(26204)'s Avatar
    My evo and my evo shift does the same thing at my work as well. What I do is leave my wifi on and let it keep attempting to connect. Then after a while...like about 15-20 minutes it connects and I never have the issue again. I go to work and it automatically connects.

    This was sent shifting on my EVO Shift 4G using Tapatalk
    01-09-2011 08:53 AM
  3. feq451's Avatar
    it's been trying for over 3 hours now. still unable to connect
    01-09-2011 09:00 AM
  4. reverepats's Avatar
    it's been trying for over 3 hours now. still unable to connect
    thats funny.....my home works, sisters house, and airport, but havent tried my work yet.....have your checked the security settings?.....maybe something doesnt match up with that?......just trying to think why it wont cennect......
    01-09-2011 09:17 AM
  5. feq451's Avatar
    its an open public wifi network at work. connected to a similar network at a restaurant without trouble. works on my secured home network and my parents. dont' understand it
    01-09-2011 09:23 AM
  6. RUSH's Avatar
    Maybe the WiFi connection isn't compatible with your phone.

    Remove/reinsert t he battery... reboot the device again.

    Best of luck.
    01-09-2011 09:53 AM
  7. reverepats's Avatar
    Maybe the WiFi connection isn't compatible with your phone.

    Remove/reinsert t he battery... reboot the device again.

    Best of luck.
    what do you mean connection not compatible with his phone?......can a connction not be compatible with a particular phone?....im just curious...thanks
    01-09-2011 10:02 AM
  8. kalex's Avatar
    It actually can. Enterprise grade hardware has a lot of granular settings. One of it might not be compatible with Android. Its not that uncommon. I kind of find it hard to believe that your work network is unsecured open wifi connection. Did you talk to your network admins at work to see if they can help you out? it could be security model they are using, it could be mac filtering and other things that cause this to happen.
    01-09-2011 01:17 PM
  9. feq451's Avatar
    i work in a hospital and we have access to the open hospital wide wifi. it's not actually for work. what particular setting should I talk to my it about. they are pretty useless and don't usually care. is there one setting that particularly causes it.

    anything else to look for. I like my phone but this actually could be a make it or break if I can't use it at work.

    adam
    01-09-2011 01:48 PM
  10. jesusice's Avatar
    I was in a hospital last week and while both the wife and my Androids could connect to the public wifi neither of us could download anything.

    Sent from my PG06100
    01-09-2011 02:24 PM
  11. feq451's Avatar
    I should also add my pre had no problems connecting to the wifi. I need to find someone else with android and ask them
    01-09-2011 02:35 PM
  12. anon(26204)'s Avatar
    I was in a hospital last week and while both the wife and my Androids could connect to the public wifi neither of us could download anything.

    Sent from my PG06100

    Yeah you probably couldn't download anything because of the firewall the hospital had. When I log into the wifi network at work, some sites I can't download from and some sites I can't even go to. Which also happens if I'm on one of the desktop computers at work as well.

    But anyway, when I turn my wifi off on my phone and switch to 3g, everything is all good.


    This was sent shifting on my EVO Shift 4G using Tapatalk
    01-09-2011 06:10 PM
  13. feq451's Avatar
    I tried someones OE EVO and it won't connect either. Its obviously a setting on the router does anybody have any idea what it might be or what I can ask IT to change. Its odd that my Palm PRE works/connects fine. Who would have thought different os's would behave differently on something so common as wifi.

    Thanks for abu help
    Adam
    01-09-2011 09:07 PM
  14. bsvoboda's Avatar
    I have a orig EVO. Same problem. Download "wifi browser" from market. Set adv wifi settings on phone to not use static IP. Try dolphin browser. Your cisco router at hospital on public network has a [accept] terms of use screen that pops up when wifi try's to connect. The app I mentioned intercepts this and allows you to open browser, and you accept. Set wifi browser for "enable login detection" and Login action = "popup webview" and do not check the "show connection error". For next 4-6 hrs are good to use wifi for anything. You have to do this each day.

    I got this to work on both my new Viewsonic G Tablet and the EVO.
    haus likes this.
    01-10-2011 07:52 PM
  15. rgrinberg77's Avatar
    My recommendation is for all of u guys to check the firmware on ure routers. I had the same issue with my ipod touch. I upgraded the firmware on my router and had no more issues with connectivity.
    02-16-2011 08:50 AM
LINK TO POST COPIED TO CLIPBOARD