1. Thrasherx2k1's Avatar
    This may be only a problem with my handset but just thought I would ask if anyone else is experiencing it. Everytime I use Google Navigation it has the hardest time locking my GPS signal down. The satellite dish thing flashes at the top in the notification bar while this is happening. Even when the GPS is locked it is re routing often and putting me on a street a block or two away. Now here is the weird part. When I run Telenav in the same areas where I was losing GPS signal it doesn't lose my signal with Telenav. It locks it down and never has to re route ever. So is anyone else experiencing this? I have owned a few Google phones and never ran into Google Navigation having GPS issues...
    01-30-2011 02:46 AM
  2. nedywest71's Avatar
    Hi,
    I got Moto DEFY and from time to time I have the same issues.
    I think because Google Maps/Nav on Moto DEFY is still in BETA version.
    Is Google Maps/Nav still in BETA in general or only on my phone.There is not any Update in Apps Store.
    Thanks!
    01-30-2011 05:48 AM
  3. RUSH's Avatar
    Pretty much nothing we could do about that. Google would have to address this issue. You could try uninstall and reinstall Google map. It may work better after that. Menu - settings -applications - manage applications -all - Tap on force-stop, clear data, and cache. Uninstall any updates if available.
    01-30-2011 05:59 AM
  4. GoneTomorrow's Avatar
    I'm not sure this is a phone or OS specific issue. I had the same problem on the Samsung Instinct, Palm Pre, and now the Shift. It happened constantly on the first two phones when using Sprint Navigation, but worked fine in Google Maps. On the Shift it does it less, but still happens.
    01-30-2011 11:51 AM
  5. YoungCorruption's Avatar
    i've used it once and the only problem i had was when i took a turn it didn't rotate while i turned so i got confused but i fixed that problem with the little button on the screen
    01-30-2011 12:35 PM
  6. DavidF78's Avatar
    The first couple of weeks, gps was solid on this phone. The last couple of days however have been pretty bad. It will take 4 or 5 minutes to lock on and sometimes not at all until I kill gps and turn it back on. For about an hour Friday morning I could lookup an address on Google maps, but navigation was "unable to find route". Sprint Nav was working fine.
    01-31-2011 09:42 AM
LINK TO POST COPIED TO CLIPBOARD