1. Popat's Avatar
    I have had my Evo Shift for a couple of weeks, and out of the blue I kept on getting an SD Card Error. Unmount Read Only. Then when i tried to umount the Card, the SD Card would be read only, and nothing would copy to the card. I tried a power reset, and then I tried to eject the Card, and reinsert it. Nothing worked, and the error message just kept on coming back.

    I took it to the Sprint Store, and the Tech just gave me a new phone. Don't know what could have caused this issue.
    Anyone else having this issue?
    01-31-2011 12:25 AM
  2. yordikins's Avatar
    I had/have the same problem with my phone. I thought it was that the phone didn't like the new 16gb card I put in it as I only saw this issue when I switched to the new card. What I just did that seems to have fixed the problem so far was to insert the card into my card reader on my computer formated it then stuck it back in the phone. On reboot it came up and said that the card is probably damaged and should be formated I said OK to the message box and it has been working since.
    01-31-2011 03:38 AM
  3. yordikins's Avatar
    Gurr never mind... just got that stupid read only error again. I'm going to switch back to the 2Gb and see if I still get the error.
    01-31-2011 04:05 AM
  4. yordikins's Avatar
    Yeah so I went for a full day on the 2GB sd card the phone came with... no problems. Anyone else have a problem using a larger SD card with the shift?
    02-01-2011 02:31 AM
  5. LancerzRalliart's Avatar
    My phone just started doing this with the factory 2gb card...wth

    Sent from my EVO Shift
    02-01-2011 05:05 AM
  6. Dave Blake's Avatar
    I have a 16gig San Disk card I got from the shack about 2 years ago it has been great with all my devices. I haven't had any issues.
    02-01-2011 07:02 AM
  7. GoneTomorrow's Avatar
    Same here, using a Patriot 16GB Class 4 micro SD with no issues whatsoever, and it's nearly full of MP3's. Sounds like it's a problem with your SD card.
    02-01-2011 07:18 AM
  8. LancerzRalliart's Avatar
    My 16gb san disk micro sd is arriving tomorrow but right now the factory 2gb card is not letting me save anything on it, the error keeps popping up when I try to save something. It has about 1.3gb of free space, and this is a stock phone no root with the stock SD card.

    Sent from my EVO Shift
    02-01-2011 10:58 PM
  9. AdamR's Avatar
    This happened to me oncebefore with my 16gb card. Formatted it , and worked fine after.
    Today I kept getting a read only error every 5 minutes.
    This is what you do: connect to computer, mount as a disk drive, then right click>properties>tools>scan disk for errors.
    It fixed a few errors and I haven't gotten it to come back yet.
    02-02-2011 12:05 AM
  10. yordikins's Avatar
    Well the 16gb card that was giving me problems was a patriot class 10. I've used it in my computer with the SD adapter and it works fine with my computer. I am going to try it again in the phone maybe it was a bad connection. I'm a little concerned there maybe something wrong with the shift though especially if people are having the same problems with their stock cards...
    02-02-2011 02:18 AM
  11. LancerzRalliart's Avatar
    This happened to me oncebefore with my 16gb card. Formatted it , and worked fine after.
    Today I kept getting a read only error every 5 minutes.
    This is what you do: connect to computer, mount as a disk drive, then right click>properties>tools>scan disk for errors.
    It fixed a few errors and I haven't gotten it to come back yet.
    I'm gonna try this when I get home, but my phone only gets the error when I open a app that was on the SD card or trying to save anything to the card...if I have problems when my new SD card arrives today I'm gonna do a hard reset and if that doesn't work its back to best buy.
    02-02-2011 07:02 AM
  12. LancerzRalliart's Avatar
    Well I scanned the sd card for errors and it fixed them, now i can take pictures again and view them without getting the error. The 16gb card should be here soon though, but at least the 2gb card is functioning properly now.
    02-02-2011 08:14 AM
  13. Popat's Avatar
    Sprint just ended up giving me a new phone. The SD Card Issue has not returned, but I am going to try and download a couple of apps and see if the problem returns. This may be an Evo Shift issue. Time will tell.
    02-03-2011 08:47 PM
  14. yordikins's Avatar
    So I formated my 16GB card on my computer, put some music on it and then put it back in the phone. Its been working OK with no errors for two days now... Could all of our problems just be due to bad physical connections when we pull and replace the card?
    02-03-2011 11:37 PM
  15. mikkitphd's Avatar
    1st droid phone (although I played with the Samsung Galaxy Tab and the Epic before this purchase), so forgive me if I don't know the correct terminology/etiquitte... I didn't know to select unmount the SD card so I didn't do it. I just took out my 2GB card & copied the files onto my mac and stuck in my 16GB Micro Center card ($26.99!) and although it wouldn't lay down easily, I just went ahead and copied back the files and re-loaded what programs my phone didn't find after the switch. The only problem I'm having now is the same one I had before the switch - it keeps telling me I've got insufficient space, but after I delete an app, I'm able to install it again. How can I open up space on the phone? I've already moved all the the apps I'm allowed to move to the SD card. Help?
    02-04-2011 10:08 AM
  16. taralucida's Avatar
    Just got this phone last night, we're at about 18 hours, and started having this issue. Just tried the quick fix and hoping it lasts! But now when I restart the phone after having the battery out, it is resending a whole bunch of old text messages from the last 2 weeks (sent from my old phone!)
    02-12-2011 02:56 PM
  17. reed4richards's Avatar
    I am also having the problem on my 2 week old Shift. I can't unmount the card or attach the phone to the computer and use it as a disk drive. I hope the problem is with the stock sd card and not the phone to card connections. I'm getting a new card tomorrow and I guess I'll see how that works.
    02-23-2011 11:18 PM
  18. economist25's Avatar
    Same problem here with an 8 gig scandisk card I tried the fix to no avail... this is definately an issue...
    02-28-2011 07:14 PM
  19. reed4richards's Avatar
    I got my new card and now everything is fine. I made sure the card fit snuggly, so I'm wondering if this has more to do with the fit than the card. I thought about this yesterday and all my problems started when I opened up the battery and took out the card to examine it. Maybe I didn't put it in securely? Anything, it's been a few days and everything is fine....
    02-28-2011 08:31 PM
  20. brown_mocha18's Avatar
    i just experienced the exact same problems as everyone else, it started yesterday afternoon, once i took my battery out and then put it back, maybe an hour or two later under *notifications* it said "Unmount Read Only - tapping . . ." ( everytime i try tap on that, it'll just disappear so i can't read it at all ) and when i go to my photo album it'll state "unable to save file to SD card due to insufficent file permissions" . . . then i took the SD card out and put it back but everything is still saved on the card ( contacts, photos, etc ), i just don't understand what the problem is, and sprint isn't open tomorrow ( sunday ) so i'll have to wait until monday to acknowledge the problem ! this is so annoying . . .

    *btw, i've had my evo shift for a month ( feb 16th ) .
    04-02-2011 09:19 PM
  21. proudfrog's Avatar
    I was having the same problem with my 8 GB card. When I tried to back up the data unto my laptop prior to re-formatting, the process hung up. I then started to back up the card folder by folder until I found the folder that wouldn't copy and paste over. Then I went file by file inside that folder. Lo and behold, it was a music file, those damn Counting Crows!!! Once I deleted the "corrupted files from the card, backed up the card, re-formatted the card, and then point all the "good" files back on the card, everything is running perfectly, no more card errors.

    I listen to Train now, no problems whatsoever.
    04-03-2011 06:47 AM