1. Phone#IM's Avatar
    Ever since I upgraded to Gingerbread on my phone I cannot seem to send text messages to anyone when I go to compose a new message.

    Anytime I got to compose messages and type a message to a recipient and hit send my phone says please wait in a grey box and then the box disappears and nothing happens and then when I hit the back button it says message saved as draft.

    I have pulled the battery and restarted my phone several times but to no avail. My phone is not rooted if it helps.

    Can anyone help solve my problem?? Or do i have to take the phone back to Sprint to get it fixed??

    Thanks in advance.
    06-18-2011 10:42 PM
  2. JAGRacer1875's Avatar
    I am having the same issues. Everytime I try to respond to a text and sometimes sending a new one it just saves it as a draft instead of sending it. I thought I fixed it by powering it off and restarting it but that was only a temporary fix, that has not worked today. It is annoying.
    06-19-2011 03:47 PM
  3. bfrog's Avatar
    I am also having the texting problem is there any fixes yet??
    08-13-2011 01:03 PM
  4. Roosterman's Avatar
    I haven't had the problem you guys described. I've been using GO SMS Pro because of issues with texting before. There is the new update which is claimed to fix some SMS problem. Might want to make sure you have it.
    08-13-2011 01:38 PM