1. ReproOne's Avatar
    I am wondering if anyone has a solution to the HTC Hero ring lag on Sprint. At best, a caller will hear two rings before my HTC Hero starts to ring.

    There are posts about this on SprintUsers and BuzzAboutWireless, but with no solution. Those posts, for reference, are as follows:

    Ring Lag - SprintUsers.com

    Sprint Community : Ring "lag" as some mentioned
    11-08-2009 03:55 PM
  2. Jerry Hildenbrand's Avatar
    I have always had this issue with sprint, regardless of the phone used. Call cs and they can extend the number of rings before a caller gets VM for you. Only way I have ever found to get around it.
    benhmadison likes this.
    11-08-2009 06:14 PM
  3. ReproOne's Avatar
    I've usually had Samsung phones on Sprint and never had the problem. I've found out that the Slot Cycle Index is set to two on this phone and that if I could change it to 1 it may ring faster. I know how to see the value for the Slot Cycle Index, by enering ##debug# and then selecting 1X. It will be in the list that comes up.

    What I do not know how to do is change the value. I have my MSL.
    11-08-2009 09:17 PM
  4. Jerry Hildenbrand's Avatar
    Sprint tries to get all manufacturers to set the SCI to 2. Less stress on the network. Couple of things-

    are you using Gvoice or any VVM?
    Try it with Sense disabled and see the result.
    Any apps that intercept the incoming call before its passed to the phone? Caller ID apps, custom display for scertain callers etc.
    Try calling from a number not in your address book. See if you hear less rings before your hero rings.

    This sounds like a Hero specific issue, and i didn't notice it much because it's similiar to what I normally have with sprint.

    ##debug# throws an error here. Any step left out? I'll also see if i can elevate the process for the phone app. Might be worth a shot.
    11-08-2009 09:34 PM
  5. ReproOne's Avatar
    I am not using Gvoice, and I have not tried disabling Sense UI.

    I just changed by Slot Cycle Index from 2 down to 0, and I will see how it reacts now. I entered ##DATA# and then the MSL. From that menu, you can change the Slot Cycle Index.

    It does appear that either Sense UI or some background application prevents the phone from checking frequently though.
    11-08-2009 10:37 PM
  6. unixpsycho's Avatar
    I am not using Gvoice, and I have not tried disabling Sense UI.

    I just changed by Slot Cycle Index from 2 down to 0, and I will see how it reacts now. I entered ##DATA# and then the MSL. From that menu, you can change the Slot Cycle Index.

    It does appear that either Sense UI or some background application prevents the phone from checking frequently though.
    You must want to kill your battery! An SCI value of 1 should be sufficient.
    11-08-2009 10:42 PM
  7. Jerry Hildenbrand's Avatar
    Looking through things I think roaming alert, roaming ringtone voice privacy settings and call guard will all intercept incoming calls before passing them to the phone process. Try disabling them.

    And I agree....SCI = 0 will kill your battery pretty quickly. If that's what it takes to solve your issue, you still have at least a day left in your 30. That's probably going to be unacceptable.
    11-08-2009 11:19 PM
  8. ReproOne's Avatar
    I did not notice any improvement with SCI set to 0, nor did I have any worse battery drainage. I've set my SCI back to 2. My phone also has the roaming alert, ringtone, and privacy stuff turned off. If my phone is actively on and being used, the caller will hear about two rings before the Hero rings. If my phone display is off (standby), the caller may here between 2 to 4 rings, possibly more.

    I tried this with another Hero at the local Sprint store, and got the same results. We also tried other phones, and they all rang after or during one ring on the caller side.

    It appears to be something specific with the Hero on Sprint.

    Any other suggestions?
    11-09-2009 07:47 PM
  9. Jerry Hildenbrand's Avatar
    Of course this is all speculation, but I'm almost positive it's a lag issue tied to Sense somehow. And also of course, we can't completely wipe Sense as it provides all the comm functions.

    The other wierd thing - a GSM hero, using either a T-mo sim or an AT&T sim doesn't do it...even while roaming, according to some folks I threw this at. Sure sounds like something is flucked up with the CDMA mishmash that was done to get the hero out the door. The only things i can think of would be to contact Sprint (*2...never go into a store for real issues ) and see if they can extend your rings, and try to get a trouble ticket started. I understand Sprint already has some bug fixes for the Hero from htc but havent released any. I suggest everybody push every issue as far as they can to get what we can get from them.

    Or you could simply swap back to what you were using before you got the hero, and wait for 2.0. Whatever you do, don't jump on the moment. Screen is nice, but everything else is a downgrade from what you're used to with the hero and I can guarentee you won't be happy.

    Wish I had better input. I'm sure there's lots of folks affected and they don't even realize it.
    11-09-2009 08:30 PM
  10. ReproOne's Avatar
    Thanks for the reply. I too wonder if it is tied to Sense, but I cannot completely wipe it to test. I have thought about the moment, but I like the Hero.

    I thought about calling *2, but that usually ends up making things worse for me or my phone.
    11-09-2009 09:24 PM
  11. SnoopyWG's Avatar
    Turning off both the roaming alert and roaming ringer shortened it from 4 to 2 rings on my HTC Hero.

    w
    01-16-2010 06:09 PM
  12. KSmithInNY's Avatar
    Changing the SCI to 1 worked for mine and my buddies Hero. We both went from 3/4 rings to 1/2.
    01-17-2010 01:50 PM
  13. KSmithInNY's Avatar
    FYI - Ring Lag Fix

    If you do a search on this forum you'll find the thread i just linked too as well as a thread about PRL's and roaming stuff. I'm skeptical on the whole PRL/Roaming stuff simply because i have my roaming crap turned off from day 1, seems pointless as i have unlimited roaming, and i search for a new PRL about once a week so for me to have experienced this issue contradicts that being the problem/fix.
    01-17-2010 05:59 PM
LINK TO POST COPIED TO CLIPBOARD