06-19-2013 08:32 PM
26 12
tools
  1. tonksnatcher's Avatar


    I tried searching for an answer for this but had no luck.

    Since the update I have been experiencing an almost 100 percent failure when I receive an MMS. Before the update it would happen randomly but very seldom. I get most of my MMS when I am at work so my wifi is definately turned off at the time. At home I bounce back and forth from wifi on and off so there is no telling during those times.

    Has anyone else experienced this and if so is there a solution out there that I am just missing?

    Any help would be appreciated.

    Oh and I am not rooted.

    thanks
    snatcher
    11-22-2009 07:28 PM
  2. Quis89's Avatar
    I noticed I couldnt send MMS after the update. I did a soft reset on the phone and gave it a day and its been working fine ever since. Dont know why it wasnt working but I'm glad it came back around, lol.
    11-23-2009 09:34 AM
  3. tonksnatcher's Avatar
    I have tried resetting a few times but doesn't seem to work. I still can't receive MMS on either the native messaging program or Handcent. I will get some random notifications at times as well with both. They will come up from one of my normal contacts but when I click on it to view it, it will change to a random series of numbers or say anonymous. My regular texts are fine though, only MMS have the problem.
    11-23-2009 05:01 PM
  4. tonksnatcher's Avatar
    Am I really the only person not receiving their mms messages? It is pretty much 100% of all mms can not be downloaded using either native messaging app or handcent. I have received messages from multiple contacts from different carriers and all fail.
    11-25-2009 10:12 AM
  5. jhilker's Avatar
    I'm having the same problem...
    11-25-2009 09:57 PM
  6. barkerja's Avatar
    Are you connected to wifi when trying to download the mms?
    11-27-2009 12:29 AM
  7. tonksnatcher's Avatar
    WiFi is normally off. Of the last 7 or 8 I have tried to view the WiFi was definately off.
    11-28-2009 11:17 AM
  8. Jerry Hildenbrand's Avatar
    Update your profile menu--settings--about phone--system updates--update profile.
    reboot the phone
    call sprint, tell them you do have the latest profile for your phone and they need to disable sms/mms, send one to verify it's blocked, then enable sms/mms, then verify again.

    This is what was done to fix a hero here after the update, and it has worked fine since.
    11-28-2009 05:52 PM
  9. tonksnatcher's Avatar
    Talked to Sprint and of.course they said they couldn't disable myessgaing and re enable it so I just backed upy info and did a hard reset and everything sea to ne ok so far
    12-01-2009 11:58 AM
  10. tonksnatcher's Avatar
    FYI

    Started happening again after a day or two. Don't know what else to do.

    "download of message ... was unsuccessful" is getting old every time I get a message.
    12-03-2009 11:16 PM
  11. Jerry Hildenbrand's Avatar
    What I would suggest -
    Take it to your local Sprint store.
    Make the Tech send you several MMS messages, and let him see they don't open.
    They replace the phone.
    When it happens again, take that one in as well.
    Raise a little fuss, get a nice credit (they love to give credits to shut customers up), then explain that it happens on 2 phones, therefore it's a PROBLEM ON THEIR END. Politely tell them they could have saved the cost of the new phone + shipping + your time and trouble + the amount (if any) of credit you got if the tech had listened to something ANOTHER TECH figured out already for many others.

    I love Sprint. Usually everything works. But they are stubborn as hell when it comes to troubleshooting. Their techs refuse to think outside of their box. In a case like yours, it's simply unacceptable.
    12-04-2009 12:06 AM
  12. tonksnatcher's Avatar
    Thanks for the advice, I will try this weekend and see how it goes.
    Thanks again.
    12-05-2009 10:11 AM
  13. repinphilly247's Avatar
    Thanks for the advice, I will try this weekend and see how it goes.
    Thanks again.
    Hey, I'm fairly new to the forums (only 2 posts).

    I have the same problems as you with the MMS. It was working great up until the update. Now I can only send MMS but when I get one it says download unsuccessful. I was on the phone with Sprint for an hr and a half and they couldn't fix it so they told me to try a hard reset or take it to a tech. I don't really want go through the time of a hard reset to get everything back to where it was. I was just wondering if you resolved your problem and how did you do it?
    12-18-2009 09:52 AM
  14. tonksnatcher's Avatar
    Still not resolved, but I've been pretty busy lately so I have nor really tried to deal with it again yet. I have some vacation coming up so I will try again then. Yeah don't bother with the hard reset all you will do is lose everything and have to do all the work to get it back. I will update once I know more.
    snatcher
    12-18-2009 09:11 PM
  15. tonksnatcher's Avatar
    Still not resolved, but I've been pretty busy lately so I have nor really tried to deal with it again yet. I have some vacation coming up so I will try again then. Yeah don't bother with the hard reset all you will do is lose everything and have to do all the work to get it back. I will update once I know more.
    snatcher
    12-18-2009 09:12 PM
  16. soulfulzeta's Avatar
    Okay everyone.

    I had the same problem. If you use Handcent (SP?) SMS that MAY be your problem. The tech (Adam from Oklahoma City) informed me that when you install 3 party apps since at the SMS app, it will block MMS (Even after you've uninstalled it). Try uninstalling all Handcent if you use it and then call Sprint to reset your phone. Mine worked after that and I've had no problems so far. It's been a few days for me now.
    12-20-2009 11:07 AM
  17. pingpongitore's Avatar
    Update your profile menu--settings--about phone--system updates--update profile.
    reboot the phone
    call sprint, tell them you do have the latest profile for your phone and they need to disable sms/mms, send one to verify it's blocked, then enable sms/mms, then verify again.

    This is what was done to fix a hero here after the update, and it has worked fine since.
    This worked perfectly for me as I was having the same issue. After updating the profile it worked 10/10 times. Everyone should try this. And yes I too was using Handcent before the battery drain issue was fixed. Give it a try and tell us how it worked out.
    12-20-2009 11:21 AM
  18. soulfulzeta's Avatar
    This worked perfectly for me as I was having the same issue. After updating the profile it worked 10/10 times. Everyone should try this. And yes I too was using Handcent before the battery drain issue was fixed. Give it a try and tell us how it worked out.
    Tell how how they fixed the battery drain issue. Was that supposed to work after the update? My battery STILL sucks!
    12-20-2009 11:25 AM
  19. pingpongitore's Avatar
    I was talking about the SMS issue where it would drain your battery because it would stop the connection process after the SMS sent. So before they updated the Hero everyone was using things like Handcent SMS, and some people in earlier threads of the post said this was partly to blame why our MMS was now failing.

    Basically all I was saying was the fix posted by gbhil worked for me, haha. Should have kept the message short I guess.
    12-20-2009 11:32 AM
  20. soulfulzeta's Avatar
    I was talking about the SMS issue where it would drain your battery because it would stop the connection process after the SMS sent. So before they updated the Hero everyone was using things like Handcent SMS, and some people in earlier threads of the post said this was partly to blame why our MMS was now failing.

    Basically all I was saying was the fix posted by gbhil worked for me, haha. Should have kept the message short I guess.
    Oh okay...I understand now.
    12-20-2009 12:06 PM
  21. repinphilly247's Avatar
    I did a hard reset and my mms worked after that. And i am still using handcent. It's only been a day and a half so I will let everyone know if it works a week from now. If it stops working i guess i will do another hard reset and stop using handcent.
    12-20-2009 07:48 PM
  22. luiscgreer's Avatar
    So I have the new Epic (Galaxy S) and was having major issues with MMS not downloading. When I turned of WiFi....it worked? What the cheese crackers is that all about? And I have crappy reception in my house...isnt that the biggest point of WiFi? anyhow...at least i can get some pics
    09-09-2010 12:29 AM
  23. Fazulka's Avatar
    Wow, that really sucks that the epic has the same problem. I don't think all the android phones do. My hero with 2.1 still has the same problem, but I noticed that in Froyo, if it is a working build, it downloads them even if connected to Wifi, but it connects to both networks while downloading the message. I guess mms works differently with sprint than other companies. They should make an app that gets the pictures through the internet. you can look at them at this website:
    pictures.sprintpcs.com
    09-09-2010 07:08 AM
  24. Ladilove194's Avatar
    I have found all the correct settings for Android to send and receive MMS.

    On the Android settings itself:
    Note: It doesn't matter if Wifi is on or off...the next steps will work,

    On the Stock Messaging App:
    1. Select Delete old messages
    2. Unselect everything elses

    On the Handcent App:
    1. Go to settings, then Application Settings - Default Messaging App-Select Disable
    2. In the Send Message settings - Select Auto Convert to MMS and Auto Resize and Auto Convert
    3. Go to Receive Message settings - Uncheck auto receive, roaming auto retrieve and most important, UNCHECK Advance Download, check Auto Download,

    It took me some trials and error but these enabled me to be able to send and receive MMS messages.
    10-21-2011 03:45 AM
  25. m a x i m u s's Avatar
    I have found all the correct settings for Android to send and receive MMS.

    On the Android settings itself:
    Note: It doesn't matter if Wifi is on or off...the next steps will work,

    On the Stock Messaging App:
    1. Select Delete old messages
    2. Unselect everything elses

    On the Handcent App:
    1. Go to settings, then Application Settings - Default Messaging App-Select Disable
    2. In the Send Message settings - Select Auto Convert to MMS and Auto Resize and Auto Convert
    3. Go to Receive Message settings - Uncheck auto receive, roaming auto retrieve and most important, UNCHECK Advance Download, check Auto Download,

    It took me some trials and error but these enabled me to be able to send and receive MMS messages.
    tried this, but still no MMS. actually, i couldnt find the Advance Download option, so i couldnt uncheck it. i decided to just use the stock messaging app for mms'.
    10-31-2011 02:52 PM
26 12
LINK TO POST COPIED TO CLIPBOARD