1. zeravla531's Avatar
    Not sure if anyone would know the problem, but my WiFi will work for about 2 seconds then stop. My laptop and computers never have a problem, only my Hero.

    I have since factory reset the phone, and now wiped and rooted it and i still have the same issue.

    Know what it can be?

    It's a WPA-Personal WiFi
    02-25-2010 07:27 PM
  2. BreedOfSpawn's Avatar
    My Wifi also kicks in and out, its just the Hero being a Hero. Try downloading an app called Static Wi-Fi. It will automatically run itself when you enable the wi-fi and help keep the signal up.
    03-16-2010 03:41 PM
  3. Andrew Ruffolo's Avatar
    There is also a wifi bug with the Hero depending on your router. I don't know if that was ever fixed. I don't use wifi, so I wouldn't be able to tell you.
    03-16-2010 05:11 PM
  4. voghan's Avatar
    It depends on our router. I have a linksys N with no problems but a friend of mine had this problem. He did eventually fix it by using WEPA2 + AES for security.
    03-19-2010 10:28 AM
  5. slickseris's Avatar
    You might be to far from the router.
    03-19-2010 10:42 AM
  6. zeravla531's Avatar
    Thank you guys for the help. I'll try tha app first, then maybe the WEPA2 + AES... I'm definitely not too far away though, i'm talking like 6 feet away.
    03-19-2010 11:25 AM
  7. Andrew Ruffolo's Avatar
    before 2.1 on my Hero, the wifi sucked. It would rarely connect. I have no issues now, so I think a lot of it is software related. I was worried I had a bad wireless card on the phone, but wireless tether works perfectly, so it couldn't have been that.
    03-19-2010 12:37 PM
  8. zeravla531's Avatar
    So far so good with 2.1, hopefull it was as you said, software related.
    03-19-2010 12:40 PM
  9. Loki#AC's Avatar
    what worked for me:

    I changed the security setting on my Linksys Router to G only, and then from WPA2 Personal: TKIP/AES to WPA2 Personal: AES.

    then I have to make sure my phone Screen Display (under settings) doesn't timeout while I'm using the wifi.

    so when I know I want to use wifi I change the display setting to timeout in 10 minutes. Then turn on wifi. And I stay connected with no problems.

    I have the wifi and Settings shortcuts on my homepage so it's not a big deal.
    03-30-2010 09:46 PM
LINK TO POST COPIED TO CLIPBOARD