1. scottf0624's Avatar
    I just got my Hero on Friday and my battery life was dreadful, I tried the SMS trick to no avail. I then noticed that my exchange Email was constantly connecting every 5 seconds. To extend my battery life, I changed my settings for Exchange Mail from As Items Arrive to every 15 minutes. If anyone know a trick to go back to As Items Arrive and it doesn't costantly sync the mail, please let me know...

    Thanks
    10-26-2009 08:13 PM
  2. t0ast3d's Avatar
    Settings > Accounts & Sync

    Uncheck one (or both) of the first options
    08-01-2010 04:16 AM
LINK TO POST COPIED TO CLIPBOARD