06-05-2013 05:59 AM
51 123
tools
  1. HunterKen7's Avatar
    Ever since the update yesterday, Google Now keeps telling me that my location service is off. I checked and everything is turned on. I even cleared app data, reset phone, turned on / off google now and it still is telling me that it is off. Anyone else have this problem?
    JMK3rd likes this.
    05-16-2013 07:21 AM
  2. Maximilian Ryck's Avatar
    Same here, tried everything. Apparently related to gooapps.
    05-16-2013 08:50 AM
  3. HunterKen7's Avatar
    Ok, thanks. I will hold off and wait for them to resolve. Just wanted to make sure it wasn't some configuration I was missing.
    05-16-2013 09:40 AM
  4. HunterKen7's Avatar
    It seems I'm having issues with Location in general. Websites, other apps, weather are all having issues with determining my location. I have everything enabled. Arghhhh
    netcub likes this.
    05-16-2013 01:16 PM
  5. LeoRex's Avatar
    Was it working up until yesterday, or did you just notice (because you were trying out the update to Now)?

    Google Location Services piggybacks on you data or Wi-Fi, so it's not like it could be a messed up GPS radio.

    Check you Google account settings.. I know there is a location setting buried in there somewhere.

    Any recent OS updates?

    Sent from my SCH-I200
    05-16-2013 01:31 PM
  6. HunterKen7's Avatar
    It was working fine up until yesterday. I've checked everywhere...Settings >> Location >> everything is checked. Google Settings app, everything is checked. It's like Location in general is broken somehow. Websites (google.com) can't get my location, the weather app is saying "My Location" now, and Google Now is telling me location services are off. I'm running stock Sense that came with the ATT HTC One
    05-16-2013 03:35 PM
  7. drfyzziks's Avatar
    Yeah, this is happening to me too. It's not a settings issue - all location settings are enabled, WiFi and GPS are active, etc. Full reboot of phone too, but the problem won't go away.

    I suspect it's a bug in the Google Search app - I believe it auto-updated yesterday.
    05-16-2013 05:23 PM
  8. anon(5999904)'s Avatar
    05-16-2013 08:31 PM
  9. LindtChocolate's Avatar
    Have you guys restarted with fastboot ticked off?
    05-16-2013 09:24 PM
  10. SCjRqrQCnBQ19QoYCtdl's Avatar
    Mine is fine. I was going to suggest the green google settings app, but sounds like you are saying that is on too.

    I know that google now gives the message that location services are off if the google settings app location setting is not on, regardless of the HTC Settings for location.
    05-16-2013 09:50 PM
  11. SCjRqrQCnBQ19QoYCtdl's Avatar
    Have you guys restarted with fastboot ticked off?
    That is a good suggestion. My fast boot is turned off.
    05-16-2013 09:52 PM
  12. anon(5999904)'s Avatar
    My location settings are definitely on. When i go into google now it says "Location service is off". When i go into maps it says "Please enable a My Location source in system settings". My weather app is just saying "Current location" instead of where i am. The only way location will work now, is if i have the GPS on.
    05-16-2013 10:01 PM
  13. SCjRqrQCnBQ19QoYCtdl's Avatar
    My location settings are definitely on. When i go into google now it says "Location service is off". When i go into maps it says "Please enable a My Location source in system settings". My weather app is just saying "Current location" instead of where i am. The only way location will work now, is if i have the GPS on.
    If it was me, and I was sure I had all the location settings on (phone and google settings app) and it still had the problems after a boot with fast boot off and fast boot on, I would do a factory reset.

    If it still didn't work, I would go to AT&T and ask for a replacement. I don't think it is gong to be resolved at that point because it doesn't affect all the phones. I suppose google could have messed something up and could possible push an update but I very much doubt it if it is affecting a small portion of one phone model.
    05-16-2013 10:19 PM
  14. drfyzziks's Avatar
    If it still didn't work, I would go to AT&T and ask for a replacement. I don't think it is gong to be resolved at that point because it doesn't affect all the phones. I suppose google could have messed something up and could possible push an update but I very much doubt it if it is affecting a small portion of one phone model.
    Forgot about fastboot - good suggestion, but didn't do the trick. I wouldn't be surprised if yesterday's updates did sneak a little bug in - we've seen that sort of thing before. I'll hold off on the factory reset for a couple days & see what happens.

    Thanks.
    05-17-2013 12:19 AM
  15. HunterKen7's Avatar
    I found out that it wasn't lying. The GoogleLocationService was not running. No matter what I did, it would not start. Go to Settings >> Apps >> Running and you should see a Google Service with GoogleLocationService running. Here are screenshots from my wide's properly working HTC One:
    http://i.imgur.com/oW2nB6X.png
    http://i.imgur.com/x3ZARzY.png
    I ended up doing a factory reset (not deleting storage) and everything is fine. The service is running again. I dont know what happened!
    chris hackett and Sazrat like this.
    05-17-2013 11:01 AM
  16. anon(5999904)'s Avatar
    Ok I might do a factory reset then. What is the best way to reset my phone without losing all my apps and app data?
    05-17-2013 10:40 PM
  17. omegis83's Avatar
    My One did the same thing but my theory is that if you turn GPS off, it takes a day or two for Google now to show the change once GPS is restarted. If that makes any sense. I'd get the same message that location services were off. After turning GPS on and it running for some time, the message went away and I started getting my navigation cards.

    Sent from my HTC One using Android Central Forums
    05-17-2013 11:00 PM
  18. SCjRqrQCnBQ19QoYCtdl's Avatar
    My One did the same thing but my theory is that if you turn GPS off, it takes a day or two for Google now to show the change once GPS is restarted. If that makes any sense. I'd get the same message that location services were off. After turning GPS on and it running for some time, the message went away and I started getting my navigation cards.

    Sent from my HTC One using Android Central Forums
    No that isn't it. I have gps off almost always, and still Google now is getting location info.

    Posted via Android Central App
    05-18-2013 12:12 AM
  19. anon(5999904)'s Avatar
    Just factory reset my phone and its working perfectly now.
    05-18-2013 02:12 AM
  20. dopepee's Avatar
    Just factory reset my phone and its working perfectly now.
    Did you reinstall all the updates after you factory reset? And does it still work?
    05-18-2013 03:05 AM
  21. EggoEspada's Avatar
    Did you reinstall all the updates after you factory reset? And does it still work?
    Worked for me; reset the device and my apps are up to date.

    I recommend that people use the HTC Backup app that's available for download from the Play Store to backup their device. It makes a back up of everything in Dropbox. Also when doing the factory reset, no need to erase internal memory.

    Sent from my HTC One
    05-18-2013 10:55 AM
  22. James Clawson's Avatar
    You don't have to turn off fast boot to do a full power cycle, all that you have to do is press the restart option instead of shutdown. and I've tried it all - tried clear data, reboot, turn off all location settings and turn them back on, uninstall and reinstall, and even tried just leaving it not updated and even that didn't help. it would appear that the update changed something outside of itself although I have no idea that
    05-19-2013 11:43 AM
  23. HunterKen7's Avatar
    For those of you with the issue, check under Settings >> Apps >> Running. You should see Google Services with the Location service running inside. Nothing I did got that service running again, even with everything checked.

    One thing I noticed was that when I turned on the Google location check mark, it did NOT ask me to confirm my selection and agree to google's terms. When it works, there is a dialog box that should pop up when enabling Google location service.

    Ever since the factory reset, it has been fine.
    05-19-2013 12:12 PM
  24. Sazrat's Avatar
    I had the exact same issue. Backed up, factory reset.

    All working as normal.

    Thanks for the advice.

    Posted via Android Central App
    05-20-2013 12:41 PM
  25. ShinKen's Avatar
    http://productforums.google.com/d/ms...E/fUgvLD7qVHsJ

    Looks like it is something on Google's side...

    Posted via Android Central App
    05-20-2013 01:10 PM
51 123

Similar Threads

  1. Google Now keeps saying my location service is off
    By HunterKen7 in forum Legacy Android & Other OS's
    Replies: 103
    Last Post: 02-07-2015, 02:00 PM
  2. Google Now weather card opens wrong location on tap
    By mrwashy#AC in forum Google Nexus 7 Tablet (2012)
    Replies: 5
    Last Post: 11-03-2014, 01:28 PM
  3. Anyone else fine Google Now cards not all that useful?
    By Snareman in forum Verizon Galaxy Nexus
    Replies: 25
    Last Post: 07-23-2012, 10:28 PM
  4. Google Talk keeps signing me out
    By ccrooks in forum Android Apps
    Replies: 3
    Last Post: 09-15-2011, 09:17 AM
  5. Keeps telling me my SD card has been removed
    By jordo487 in forum HTC EVO 3D
    Replies: 4
    Last Post: 07-20-2011, 04:58 AM
LINK TO POST COPIED TO CLIPBOARD