1. scottdeto's Avatar
    I got the update notice in Google Play for the new Google+ released today (May 20). It has a notice at the top that "Your device isn't compatible with this version". What gives?
    05-20-2013 02:44 PM
  2. Kevin OQuinn's Avatar
    Yeah, it seems to be an issue for anything running ICS or JB. I'm sure Google is aware and will fix it.

    Posted via Android Central App
    05-20-2013 02:49 PM
  3. karmamule's Avatar
    I just downloaded the latest version and it's working fine so either they fixed it already or it's only certain flavors of the One that have the problem.

    Sent from my HTC One using Android Central Forums
    05-20-2013 02:56 PM
  4. bigrey81's Avatar
    I got the update notice in Google Play for the new Google+ released today (May 20). It has a notice at the top that "Your device isn't compatible with this version". What gives?
    Mine updated just fine

    Posted via Android Central App
    05-20-2013 04:53 PM
  5. Aj Oq's Avatar
    Mine updated just fine

    Posted via Android Central App
    09-06-2013 09:52 AM

Similar Threads

  1. Any way to fix "your device isn't compatible with this version"?
    By jimmiegeddes in forum Verizon Galaxy Nexus
    Replies: 4
    Last Post: 01-11-2017, 10:39 AM
  2. Your device isn't compatible with this version
    By RobinCris in forum General Help and How To
    Replies: 40
    Last Post: 08-07-2016, 10:54 PM
  3. Now Getting "your device isn't compatible with this version"
    By gaznjax in forum Google Nexus 7 Tablet (2012)
    Replies: 4
    Last Post: 11-27-2012, 06:40 AM
  4. Is there any way to fix "your device isn't compatible with this v
    By jimmiegeddes in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 2
    Last Post: 03-24-2012, 10:24 PM
  5. Rooted Nook Color your device isn't compatible with this item
    By melanie_mg in forum Barnes & Noble Nook Color
    Replies: 3
    Last Post: 03-21-2012, 11:11 AM
LINK TO POST COPIED TO CLIPBOARD