1. Xylaria's Avatar
    Hi all,

    I bought a HTC One Google Edition some time ago.
    It worked great for months, no issues at all.
    The GPS was working great in all parts of the country (Belgium)...
    However, recently, I'm having some weird issues.
    In certain parts of the country, my GPS drops out and does not view any satellites. It's only the GPS on my One. I have checked the same area on my Car's GPS and my Desire, and they have perfect GPS signal.
    It's always the same area, btw. When driving to work, I know when I'll loose signal. And only when I'm driving home after work, when I reach that same point, I'll lose the connection again...

    I did a factory data reset but this didn't work.

    I read in some google results to disable google+ and this appeared to help quite some people, but I disabled almost all google apps, and still cannot lock onto GPS in certain areas.

    Earlier today, I figured out that in those areas, I manage to get a GPS signal when going into Airplane mode.
    However, when I go out of Airplane mode, I will lose the signal again...

    I have disabled:
    Google Hindi/Korean/Pinyin Input
    Google Play Books/Music
    Google Play services

    The only apps I have installed since the factory reset are WhatsApp, Ingress and GPS Test and GpsFix (but these don't help).

    Please let me know what kind of information I need to provide which would help you help me
    11-10-2013 02:05 PM
  2. And_TX33's Avatar
    I bought the HTC One Developer Edition in mid-2013. I never had any GPS problems until recently. I used it now and then, but just recently starting geocaching with it frequently with my kids. The problem I'm having is the phone will not lock onto any satellites. The main GPS testing app I've been using for a year or two is called GPS Test (by Chartcross Limited). When I open the app now it maybe will lock onto one satellite. And that satellite seems to be toward the edge of the visible plain of satellites overhead. I never used Google Location Reporting. Until recently the GPS worked well with all the apps that used it. Now it just won't lock onto satellites period, regardless of the app.

    There were basically two things that happened (that I can think of) between the time it always locked onto lots of satellites and when it didn't. First I had installed and was using the UCCW app. I had installed this app in order to try out the Google Now UCCW app. I have been running Android 4.4 and it recently updated to version 4.06.1540.3. I actually think there have been two Android updates since when the GPS was working well.

    I disabled the UCCW app it at first I thought it may have helped. I disabled it, restarted phone. Kept trying to get satellites to lock on and they did. The next time I went outside to use the GPS it wouldn't lock on again. The most recent time I was able to re-establish satellites I did this: Open the GPSTest app. Go to settings and click the "Clear AGPS" icon. The app's documentation suggests doing this when acquiring location is slow. Now I've tried this before and even tried clearing and updating the AGPS, without luck. The difference this time was after clearing the AGPS data I sat there with GPS Test open for several minutes. Usually it acquires satellites within seconds so I guess I was more patient this time. Over the course of maybe 5 minutes it acquired enough satellites to gain 10 foot accuracy.

    The next day it wouldn't lock onto satellites again. So I am at a loss. I've gone back and made sure Google location reporting and history is disabled. I disabled UCCW and Google Now. I force stopped all the nonessential apps that happened to be running. Within GPS Test it has always indicated that I was using the WGS84 Datum, but I also tried others without luck. I honestly don't know if changing the datum in the GPS Test app will affect the datum used by the phone in other apps. Still trying to read up on this. For now it seems WGS84 is the most popular. I don't live in the continental US, so I thought switching to another datum may help, but since the phone locked onto satellites quickly for several months I don't think that is the problem.

    Wish I could be of more help. I'm very interested in a solution to this problem also.
    01-13-2014 01:55 PM
  3. cpcrowley's Avatar
    I also have an HTC One Developer's Edition and has the same GPS problem. I went through and cleared the cache on every app that might access the GPS and I also deleted several apps that might access the GPS, not all of them but the lesser known ones, NOT Google My Tracks, where I first noticed the problem. This solved the problem for me.
    03-01-2014 09:30 PM
  4. silverhack's Avatar
    I also have this problem with the stock 4.4.4 ROM, even after resetting to factory defaults, with no other apps loaded.
    12-13-2014 10:35 AM
  5. Cmic's Avatar
    My Htc one gps also stopped working. Today I downloaded HTC service pack from Google play and that solved the problem.
    05-27-2015 01:02 PM

Similar Threads

  1. Replies: 1
    Last Post: 05-29-2014, 10:43 AM
  2. Google Nexus 5 - sound issue : random buzzing noises
    By evivbulgroz1 in forum Google Nexus 5
    Replies: 5
    Last Post: 01-22-2014, 05:19 AM
  3. No more Software Updates option in About menu HTC One ATT
    By sidekickkdx in forum AT&T HTC One
    Replies: 2
    Last Post: 11-10-2013, 02:54 PM
  4. Minor Issue
    By mickeyboat in forum Samsung Galaxy Note 3
    Replies: 3
    Last Post: 11-10-2013, 02:21 PM
  5. Skype Issue - Constant restarts
    By nightdesigns in forum HTC EVO 4G LTE
    Replies: 1
    Last Post: 11-10-2013, 12:14 AM