1. funb's Avatar
    I've read a number of threads on here and elsewhere but I still can't get my alarm clock to wake me up in the morning following the 5.0.2 upgrade this weekend. Could someone have a look at my settings and let me know what I've done wrong?

    Even if I set my clock app as priority it doesn't go off. My "Interruptions" are still under "Do Not Disturb", and I don't seem to have that time window setting anywhere; it's as if my phone doesn't want to disturb me before 6am or something. Do I need to turn off airplane mode?

    ??

    Plan B is to rollback to a previous version. What a dumb "feature"; I was late for work twice this week!
    Attached Thumbnails Can't get alarm to work following 5.0.2 "upgrade"-screenshot_2015-03-12-06-24-40.jpg   Can't get alarm to work following 5.0.2 "upgrade"-screenshot_2015-03-12-06-19-34.jpg   Can't get alarm to work following 5.0.2 "upgrade"-screenshot_2015-03-12-06-19-48.jpg   Can't get alarm to work following 5.0.2 "upgrade"-screenshot_2015-03-12-06-20-06.jpg   Can't get alarm to work following 5.0.2 "upgrade"-screenshot_2015-03-12-06-20-26.jpg  

    Can't get alarm to work following 5.0.2 "upgrade"-screenshot_2015-03-12-06-20-36.jpg   Can't get alarm to work following 5.0.2 "upgrade"-screenshot_2015-03-12-06-21-02.jpg  
    03-12-2015 03:44 AM
  2. UJ95x's Avatar
    Hmm, I'm not familiar with HTC's icons or how they use silent mode in Lollipop. Is there some option to set the silent mode to only last a set number of hours? In stock Lollipop, you can set it to go back to "all notifications" after a set amount of time. If you turn off silent, will the alarm go off?
    03-12-2015 04:48 AM
  3. funb's Avatar
    If there is such a setting I am not aware of it. Prior to the 5.0.2 upgrade my alarm would go off like.. well, like clockwork, every morning, when phone was in both silent & airplane mode. One would assume that the "silent" setting only applies to the ringtone & notifications as per the last screenshot?

    I'll experiment tonight with phone in non-silent mode. Unfortunately I can only test one setting per night as this only seems to be an issue in the early hours and/or my phone has been 'asleep' for some time. Luckily I now have an elaborate system of other phones and radio alarms while I'm in this iterative test phase
    03-12-2015 04:57 AM
  4. UJ95x's Avatar
    If there is such a setting I am not aware of it. Prior to the 5.0.2 upgrade my alarm would go off like.. well, like clockwork, every morning, when phone was in both silent & airplane mode. One would assume that the "silent" setting only applies to the ringtone & notifications as per the last screenshot?

    I'll experiment tonight with phone in non-silent mode. Unfortunately I can only test one setting per night as this only seems to be an issue in the early hours and/or my phone has been 'asleep' for some time. Luckily I now have an elaborate system of other phones and radio alarms while I'm in this iterative test phase
    Couldn't you test with faux alarms? Better than finding out in the morning that you're late for work again
    03-12-2015 12:16 PM
  5. funb's Avatar
    I have.. it was the first thing I tried! I set it for 6h27 or something and it worked, even though airplane mode was still on and my phone was set to silent. Which makes me think it goes into some sort of deep hibernation in the wee hours thus preventing my alarm from going off...

    ...which would of course be the dumbest thing ever!

    Any ideas? I'm going to try without airplane mode tonight but ideally I'd like to have my alarm go off even when airplane mode is on and phone is set to silent. I'm so used to having my phone in this state I just know I'll forget at some point and I'll be late for work again I've read of other people installing another app that "wakes up" their phone 20mins before their alarm is due to go off but again this doesn't seem very efficient. Why can't my alarm just work waaahh I need pie
    03-12-2015 12:49 PM
  6. UJ95x's Avatar
    I have.. it was the first thing I tried! I set it for 6h27 or something and it worked, even though airplane mode was still on and my phone was set to silent. Which makes me think it goes into some sort of deep hibernation in the wee hours thus preventing my alarm from going off...

    ...which would of course be the dumbest thing ever!

    Any ideas? I'm going to try without airplane mode tonight but ideally I'd like to have my alarm go off even when airplane mode is on and phone is set to silent. I'm so used to having my phone in this state I just know I'll forget at some point and I'll be late for work again I've read of other people installing another app that "wakes up" their phone 20mins before their alarm is due to go off but again this doesn't seem very efficient. Why can't my alarm just work waaahh I need pie
    So it worked when you tested it, even in silent mode?
    Hmm...the airplane mode shouldn't have anything to do with it. But if you have that on, I'm guessing there aren't many more notifications you could get. Why not try without silent mode just to be safe?
    03-12-2015 02:59 PM
  7. funb's Avatar
    Hmmm indeed. I'm now convinced it has something to do with wakelock/deep sleep mode as I've tested several times in airplane/silent and that works fine. I've now installed the Timeriffic app as per suggestions elsewhere, and set it to adjust some settings 5 mins before my alarm is due to go off. Timeriffic will turn on WiFi and set my alarm volume to 100% (ha, ha) which will hopefully wake my phone up and then me 5 mins later. I'll report back in the morning o7
    03-12-2015 03:10 PM
  8. UJ95x's Avatar
    Hmmm indeed. I'm now convinced it has something to do with wakelock/deep sleep mode as I've tested several times in airplane/silent and that works fine. I've now installed the Timeriffic app as per suggestions elsewhere, and set it to adjust some settings 5 mins before my alarm is due to go off. Timeriffic will turn on WiFi and set my alarm volume to 100% (ha, ha) which will hopefully wake my phone up and then me 5 mins later. I'll report back in the morning o7
    Is there anything else you can use as an alarm in case that fails?

    Sent from my Galaxy S4 running SlimLP 5.0.2
    03-12-2015 03:25 PM
  9. funb's Avatar
    Yip! I've been using another phone and a (retro!) radio alarm all of this week
    03-12-2015 03:30 PM
  10. UJ95x's Avatar
    Yip! I've been using another phone and a (retro!) radio alarm all of this week
    Great
    Let me know if it works tomorrow!
    03-12-2015 03:53 PM
  11. funb's Avatar
    MY ALARM WENT OFF!

    The only thing that changed was the Timeriffic app. My phone was still in silent & airplane mode. So it seems like the theory is correct that the alarm will not work if the phone is in "deep sleep" - an exceptionally stupid 'feature' if this has been done deliberately for 5.0.2.

    My alarm clock is the ONLY thing I need to work when my phone is in deep sleep - now I have to remember to set two apps. My memory is awful! Hopefully some bright spark will change this functionality for the next release.
    UJ95x likes this.
    03-13-2015 02:26 AM
  12. UJ95x's Avatar
    MY ALARM WENT OFF!

    The only thing that changed was the Timeriffic app. My phone was still in silent & airplane mode. So it seems like the theory is correct that the alarm will not work if the phone is in "deep sleep" - an exceptionally stupid 'feature' if this has been done deliberately for 5.0.2.

    My alarm clock is the ONLY thing I need to work when my phone is in deep sleep - now I have to remember to set two apps. My memory is awful! Hopefully some bright spark will change this functionality for the next release.
    I don't think that would do anything. I set my phone to "None" at night (running Lollipop) and I set it to turn off after a set number of hours. But the alarm still sounds...the alarm shouldn't be affected by any "deep sleep", in fact...deep sleep is something you want as it saves battery.

    Either way, glad that worked for you
    03-13-2015 02:43 PM
  13. funb's Avatar
    I don't think that would do anything. I set my phone to "None" at night (running Lollipop) and I set it to turn off after a set number of hours. But the alarm still sounds...the alarm shouldn't be affected by any "deep sleep", in fact...deep sleep is something you want as it saves battery.

    Either way, glad that worked for you
    What did you set to "None"? *trying to learn*

    I don't know, it seems weird that it starts working again after I do the jiggery-pokery with Timeriffic to wake it up... And yes I agree with you - the alarm shouldn't be affected by deep sleep, but it seems that after the latest upgrade that it is.
    03-13-2015 03:01 PM
  14. UJ95x's Avatar
    What did you set to "None"? *trying to learn*

    I don't know, it seems weird that it starts working again after I do the jiggery-pokery with Timeriffic to wake it up... And yes I agree with you - the alarm shouldn't be affected by deep sleep, but it seems that after the latest upgrade that it is.
    My phone is on stock Lollipop, so I can set it to "None" (for notifications) and absolutely nothing will come through.
    03-13-2015 11:16 PM
  15. funb's Avatar
    But I DO want alarm notifications. Specifically, I want my alarm to work when it is set to Priority. Even more specifically, I want my alarm to work without the need for another app. I also have stock Lollipop. Are you on 5.0.2?
    03-14-2015 07:18 AM
  16. UJ95x's Avatar
    But I DO want alarm notifications. Specifically, I want my alarm to work when it is set to Priority. Even more specifically, I want my alarm to work without the need for another app. I also have stock Lollipop. Are you on 5.0.2?
    Oh, I know you do. Just saying that I have it to None, but make it turn off before my alarm has to ring.

    You're not on stock Lollipop, that's HTC Sense running their version of Lollipop. Stock is like what you'll find on Nexus phones. And yes, I'm on 5.0.2

    Sent from my Galaxy S4 running SlimLP 5.0.2
    funb likes this.
    03-14-2015 04:58 PM
  17. funb's Avatar
    Oh, I know you do. Just saying that I have it to None, but make it turn off before my alarm has to ring.

    You're not on stock Lollipop, that's HTC Sense running their version of Lollipop. Stock is like what you'll find on Nexus phones. And yes, I'm on 5.0.2

    Sent from my Galaxy S4 running SlimLP 5.0.2
    Ah! Ok got it. So this is all HTC's fault, also explains why I can't set the None thing to a timer. Grr. Guess I'll wait for the next update then... Thanks for listening to my ranting Sometimes it helps just to let it out haha
    03-15-2015 06:19 AM
  18. UJ95x's Avatar
    Ah! Ok got it. So this is all HTC's fault, also explains why I can't set the None thing to a timer. Grr. Guess I'll wait for the next update then... Thanks for listening to my ranting Sometimes it helps just to let it out haha
    No problem. Glad you at least found a work around for the time being
    See you around the forums!
    funb likes this.
    03-16-2015 01:19 AM
  19. vistascape's Avatar
    i have same problem with lg g2 after updating to 5.0.2.

    my alarm is not working when the phone is in soundless mode. wtf is happening?
    03-05-2017 09:57 AM

Similar Threads

  1. Can I do screen casting to an hdmi car stereo?
    By TJs11thPre in forum General Help and How To
    Replies: 4
    Last Post: 05-07-2015, 12:51 PM
  2. Alternative to Android File Transfer for Mac
    By Yazy Lee in forum Samsung Galaxy S4
    Replies: 4
    Last Post: 04-17-2015, 11:12 PM
  3. Why doesn't car mode work + popup crash messages?
    By v1ced in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 03-16-2015, 07:09 AM
  4. is it possible to convert 4.1 to 4.4 in my mr.tab
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-12-2015, 12:59 PM
  5. Replies: 1
    Last Post: 03-12-2015, 12:57 PM
LINK TO POST COPIED TO CLIPBOARD