1. HeliSteveNZ's Avatar
    Hi All,
    A few weeks ago my Google App suddenly started using Skype as the dialer even thou I didn't have an account with Skype. I uninstalled Skype so now if I use voice command or manually try to call a contact from my contacts list a message "No phone app installed" appears. Also if searching companies and trying to use the call function from the results does nothing in the Google app.
    Have been chatting to HTC support for hours going through settings, Safe Mode and Factory resets that did not solve the problem. I suspected the Google App has been changed during the last app update but posting a thread on a Google forum resulted in an expert thinking it is a phone issue.

    Help please.
    09-06-2016 04:50 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! What happens if you go to Settings>Apps, tap Menu, then Reset All App Preferences?
    09-06-2016 04:34 PM
  3. HeliSteveNZ's Avatar
    Hi B. Diddy, Nothing happens or should I say, no change.
    09-08-2016 06:01 PM
  4. B. Diddy's Avatar
    How about going to Settings>Apps, selecting Google, and Clearing Cache/Data? I know you already tried a Factory Reset, but perhaps by the time you tried it after the reset, your phone had already synced data from your Google account in the cloud, including something that was causing things to behave strangely?
    09-10-2016 02:10 AM
  5. HeliSteveNZ's Avatar
    Hi B. Diddy, nothing changes.
    09-13-2016 12:49 AM
  6. B. Diddy's Avatar
    What kind of voice command are you using? Is it "Ok Google," or the HTC-specific voice command interface?
    09-13-2016 12:53 PM
  7. HeliSteveNZ's Avatar
    OK Google. But even without voice commands and manually typing the command it will not use my phone dialler.
    09-14-2016 08:17 PM
  8. B. Diddy's Avatar
    This is weird. Was Skype preinstalled on the phone, or did you install it yourself?

    Try reinstalling Skype, then go to Settings>Apps, select Skype, and see if you can Clear Defaults. (I know you already tried Reset All App Preferences, but let's see if clearing the specific app's defaults does anything.)
    09-14-2016 10:39 PM
  9. HeliSteveNZ's Avatar
    For your first question, I had installed Skype a long time ago and had used it then signed out of my account. Had to be at least a year ago I had done that. When this problem first start and I tried to call a contact the Skype App started and asked for a Sign-in.

    For the second part of your inquiry; I reloaded Skype, typed "Call Mum" and Google Now retrieved my mother's contact details. If I press the phone icon Skype will start.
    I've gone to apps, Skype and cleared defaults (there were non listed). Tried "Call Mum", same result, Skype started.
    This time I disabled Skype and tried again, "No phone app installed" appears.
    Tried again in Safe Mode, same issue "No phone app installed"

    I will be very thankful if you can solve this one.
    09-15-2016 02:51 PM
  10. B. Diddy's Avatar
    I should've asked this before, but if you tap the stock Phone app, does the actual Phone app open up? Is it possible that you Disabled the stock Phone app at some point? Go to Settings>Apps, and see if Phone is Disabled.
    09-15-2016 03:41 PM
  11. HeliSteveNZ's Avatar
    Hi, yes it opens the stock phone app, nothing had changed there. There are two Phone apps, one with a blue icon and the other green which I assume is standard. Both are not disabled.
    09-15-2016 04:40 PM
  12. HeliSteveNZ's Avatar
    Another interesting part to my problem is with the Call function after searching businesses. See attached screen shot.
    This is a search of the local hardware store and normally I can select the Call function and the phone app will open and the number loaded for calling. This stopped working as well and nothing will happen when selecting. BUT, if I uninstall the updates and it runs the older version and do another search for the hardware store and then select the Call function IT WORKS. It gets better, if I install the Google Updates and try it again it STILL WORKS. BUT at some stage as time goes on and I try this function it will not work. So something changes somewhere at some time and virtually impossible to what and when. In the mean time no change to the "Call Mum" scenario during all this, still "No phone app installed".

    Bet this makes you scratch your head.

    Google App has suddenly stopped using HTC dialer as default dialer-screenshot_2016-08-31-18-53-10.jpg
    09-15-2016 05:45 PM
  13. B. Diddy's Avatar
    I'm scratching so much I'm starting to bleed.

    Do you happen to be signed up for the beta version of the Google app?
    09-15-2016 08:40 PM
  14. HeliSteveNZ's Avatar
    I've signed up, loaded a Beta version and the issue still there. Only the "Call contact" has the issue. The Call function from a searched business is still OK, for now.
    09-15-2016 11:46 PM
  15. B. Diddy's Avatar
    Harumph. I'm grasping at straws now. Are your contacts all stored in your Google account, the local Phone account, or some other account?
    09-16-2016 01:19 AM
  16. HeliSteveNZ's Avatar
    Morning Diddy. All my contacts are from my Google account and after a factory reset they automatically load to the phone as soon as I sign into my account.

    I would like to know if this is a Google app issue or a HTC issue. Is there a GOOD contact at HTC I can use?
    09-16-2016 03:01 PM
  17. B. Diddy's Avatar
    I'm not really sure where the problem lies. What version of Google Play Services is your phone using? I'm on 9.4.52. You could try clearing the cache and data for Google Play Services (although I would guess that a factory reset would have done that as well).
    09-16-2016 10:43 PM
  18. HeliSteveNZ's Avatar
    I have the same version. Do operate a M7 as well?
    09-19-2016 02:12 AM
  19. B. Diddy's Avatar
    No, I don't have an M7. I wish I did so I could test things out more regarding this issue!
    09-19-2016 03:16 AM
  20. HeliSteveNZ's Avatar
    Hi B. Diddy, I've finally given up with my phone and ordered a Samsung. Just as I did the latest Google App was loaded and now it will not open for me on the M7. Obviously Google is not supporting the M7 in any updates now. Bye bye HTC, they WERE a good phone. Shame
    12-07-2016 06:39 PM

Similar Threads

  1. Replies: 0
    Last Post: 09-06-2016, 04:20 AM
  2. Cant connect to google server try again letter
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-06-2016, 02:56 AM
  3. In search for android app: tool to type standard text fast
    By Christophe Wybo in forum Android Apps
    Replies: 1
    Last Post: 09-06-2016, 02:55 AM
  4. Videos stops
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-06-2016, 02:54 AM
  5. Deleting apps from SD card
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-06-2016, 02:47 AM
LINK TO POST COPIED TO CLIPBOARD