1. Kittycatpenut's Avatar
    I got a m8 a couple days ago after switching to T-mobile and I would really like to unlock/root/mod it. I've rooted other phones before and haven't had this much trouble with them.
    I get through all of the steps, run fastboot flash unlocktoken Unlock_code.bin which runs fine (gives option to unlock or not, I select yes with the power button) and reboots the phone. The phone is wiped as it's supposed to be, and I turn off the fast boot and turn on usb debugging in the options after the basic set up. When I boot it into fastboot to install the recovery, it still says *** LOCKED *** at the top of the screen, and I get this when I try to install it

    XXX-Inspiron-N5010:~/Downloads/fastboot$ sudo fastboot flash recovery Recovery.img
    [sudo] password for XXX:
    target reported max download size of 1830608896 bytes
    sending 'recovery' (14818 KB)...
    OKAY [ 1.635s]
    writing 'recovery'...
    (bootloader) signature checking...
    FAILED (remote: signature verify fail)
    finished. total time: 2.169s

    I've tried this on two different computers and with different recovery files, one running Windows 8 and the other Ubuntu five times and I can't find anyone else that has had the same problem. I would appreciate any help with this as it's getting extremely frustrating

    Posted via the Android Central App
    10-13-2014 09:31 AM
  2. Golfdriver97's Avatar
    I am relatively weak with rooting HTC devices, but did you use a method for your version of Android and carrier?
    10-13-2014 09:40 AM
  3. Kittycatpenut's Avatar
    Yeah, it shouldn't have had any problems

    Posted via the Android Central App
    10-13-2014 10:19 AM
  4. TarekElsakka's Avatar
    I was a M7 user for two years and then jumped to the M8 and I have never encountered or even seen such a problem before, it is rather weird. I looked at this thread in which the OP has a similar problem to yours and he ended up bricking his device, so I think you'd be better off holding out and then contacting HTC about it if you really want to root it. It also seems like it is a hardware issue with the mainboard which requires replacement in order for the bootloader to be unlocked.

    The most basic thing you can try right now is using a different cable if you haven't already and trying one more time.
    10-13-2014 12:41 PM
  5. Kittycatpenut's Avatar
    The especially weird thing about it is that I don't get any sort of error message on the phone or computer. It reboots after I select that I want it unlocked, and my device is wiped, but it isn't unlocked. I've tried three different cables (the one that came with it, a cable from the T-Mobile store,and my ps4 controller cable) with the same results.
    I would try it again but I'm tired of re-customizing my phone. I guess I'll just stick with stock for now

    Posted via the Android Central App
    10-13-2014 01:40 PM
  6. TarekElsakka's Avatar
    Yeah.. that's your only option for now I guess. Think about contacting HTC since it seems like they owe you a mainboard. Granted, unlocking the bootloader voids warranty, but at least they owe you an unlockable one just like the rest of us!
    10-13-2014 02:42 PM
  7. benny3's Avatar
    I have to ask, Are you selecting Yes with the volume button before you hit the power button?
    10-14-2014 03:26 PM
  8. paschall's Avatar
    Google sunshine unlock works perfectly. It's a small cost of $25.00 but I'm on Verizon HTC one m8 unlocked and s-off. And completely stable.
    10-16-2014 05:36 AM

Similar Threads

  1. How can I update my S4?
    By AC Question in forum Ask a Question
    Replies: 8
    Last Post: 02-27-2015, 09:28 PM
  2. How to clear/disable timeline in my files app?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-20-2014, 10:47 PM
  3. How do I transfer photos from the Nexus 7 to PC?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-14-2014, 02:13 AM
  4. Which carriers have unlocked bootloaders?
    By scooter389 in forum Ask a Question
    Replies: 2
    Last Post: 10-13-2014, 08:05 PM
  5. What app do i need to change my message wallpaper?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-13-2014, 09:17 AM
LINK TO POST COPIED TO CLIPBOARD