1. nolanite's Avatar
    So, after some time(hours) searching around on xda and here, im unable to solve my issue: but i think it is the hboot version.

    I have succesfull unlocked the phone. I am in the bootloader, it says unlocked, official software. when i try to 'fastboot boot recovery.img' my TWRP recovery it fails 'FAILdtb not found'. From what ive read, its the fact that my phone is HBOOT 3.19.0.0000. Is there a recovery tool that supports this hboot?

    Could i flash an older hboot to one which supports the recovery tool?

    some other info that might be important: I live in China(work). The phone was initially locked, but all phones in china support basically any SIM card you can put in it. This phone in particular i bought at China Mobile.

    The phone model is HTC M8Et

    This may be relevent, in particular the CID...

    c:\mini-sdk>fastboot getvar all
    (bootloader) version: 0.5
    (bootloader) version-bootloader: 3.19.0.0000
    (bootloader) version-baseband: 1.21.213311501.11G
    (bootloader) version-cpld: None
    (bootloader) version-microp: None
    (bootloader) version-main: 1.00.1400.7
    (bootloader) version-misc: PVT SHIP S-ON
    (bootloader) serialno: HC49RY900808
    (bootloader) imei: 355610060101513
    (bootloader) imei2: Not Support
    (bootloader) meid: 00000000000000
    (bootloader) product: mels_tuhl
    (bootloader) platform: hTCBmsm8974
    (bootloader) modelid: 0P6B80000
    (bootloader) cidnum: HTCCN701
    (bootloader) battery-status: good
    (bootloader) battery-voltage: 0mV
    (bootloader) partition-layout: Generic
    (bootloader) security: on
    (bootloader) build-mode: SHIP
    (bootloader) boot-mode: FASTBOOT
    (bootloader) commitno-bootloader: 3923c206
    (bootloader) hbootpreupdate: 11
    (bootloader) gencheckpt: 0
    all: Done!

    My main goal is to install a ROM which does not have chinese bloatware on it and which supports google things more easily. China built in stops a lot of google apps. I will run a VPN to use anything google of course, but this is all ready to go i just need to get this new ROM isntalled.

    this is the ROM i want(and the guide ive used) - Android Revolution HD for the M8

    thanks in advance!
    03-07-2015 02:38 AM
  2. nolanite's Avatar
    EDIT: so i can install a ROM, not root :P ive already rooted (i think...)

    Also the phone is Android 4.4.4

    Also, if i dont care about all of the personal information, will the stock bootloader allow me to undo a rom(if it doesnt work) back to factory settings without the use of a recovery tool like TWRP? IS the only point of a recovery tool to keep apps and personal stuff?
    03-07-2015 02:39 AM
  3. NEXUS_HTC_PS's Avatar
    The "boot" command requires the recovery.img needs to be on the same folder as your SDK-tools.

    Posted via the Android Central App
    03-07-2015 09:42 AM
  4. NEXUS_HTC_PS's Avatar
    Well regardless, whether flashing or booting it needs to be in the same folder as the tools. And to answer your other question, no, you cannot revert back to factory settings with fastboot. Make XDA your best friend, read, and any questions you have ask here.

    Posted via the Android Central App
    03-07-2015 09:44 AM
  5. nolanite's Avatar
    i had it in the sdk folder, it just was giving me that error about dtb something. After searching around the net some more, i found my solution in chinese. It turns out my phone is an HTC One M8Et or M8 EYE, whats different im not sure. I was able to find a TWRP tool that worked, and then was able to manually install SuperSU via zip via TWRP. My phone is now TWRPed, rooted, and awating the download of the ROM i will attempt to use.

    If anyone else is using this Chinese (China mobile) version of the HTC One M8Et EYE here is the website that walked me through is. You will have to use google to translate the page in order to read it, which is not perfect, and as it translates it, 'brush' means flash.

    www dot rootzhushou dot com/ndetail/772 dot html (i cant link, sorry)

    Will let you know what happens with the ROM once it downloads.
    NEXUS_HTC_PS likes this.
    03-07-2015 10:13 AM
  6. benny3's Avatar
    Booting into recovery without installing it isnt supported any more. You need to flash it now
    03-07-2015 08:57 PM
  7. nolanite's Avatar
    Update:

    After downloading the ROM (Androidd Revolution for the H8) i installed it via TWRP recovery and did the davik/cache wipe but upon reboot it failed to load the ROM, it simply went straight into the bootloader where i had to recover back to my stock ROM Not sure what the issue is, if anyone could identify the problem that would be awesome!!! Today im going to try to download another ROM for the H8 and try it, to eliminate a download error in the file or something.

    My international (China) version of the phone is the HTC One H8Et or H8 EYE. I searched around the china web for some ROMs but didnt find anything that looked worth a damn.

    My main goal is to enable google services on my phone.(Chinese apps/fake versions suck, not to mention i cant read chinese) I tried the Gapps package for 4.4.4 and installed it with TWRP but it didnt work, i had to recover back using TWRP. Ive also tried a few tricks with google services:

    So I launched Root Explorer and went to the system/app folder. Then I changed the permissions of the 3 APKs: GoogleServicesFramework.apk, GoogleLoginService.apk and Google_Play-v3.8.17.apk to rw-r--r-- to match all the other files in the folder and rebooted. Since then everything has been working fine! Now I can browse the App store and download and install files without a problem!

    So, the steps I recommend are:

    1. Root your phone.
    2. Download the attachment above.
    3. Extract GoogleServicesFramework.apk, GoogleLoginService.apk and Google_Play-v3.8.17.apk from the RAR file and copy them to the system/app folder on your phone with Root Explorer.
    4. In Root Explorer click Mount R/W. Change the permissions of the 3 files to match the permissions of the other files in the folder (rw-r--r--). Then click Mount R/O and exit Root Explorer.
    5. Reboot your phone.
    6. Go to Accounts & Sync in your phone's settings, click Add account and enter your Google/GMail account details.
    7. Go to your apps and Launch Google Play.
    i tried this, which had worked for someone else, and i think im on the right track, but i still get google services force closing. google play does now open, but has no access to the internet. i think it needs the other services to support it... are there more google services that maybe im missing that i need running?
    03-07-2015 09:48 PM
  8. nolanite's Avatar
    Also, ,im curious as to what hardware difference there actually is between different version of the H8. For instance, why wouldnt that ROM work on my version? Im assuming there basically is no difference, and that its maybe low level coding? Firmware differences? Is there any way to just install the H8 GSM version of firmware etc from the ground up and be done with the chinese everything?

    Would installing a stock american H8 recovery image do this? Or would it have issues with firmware maybe?
    03-07-2015 09:51 PM
  9. nolanite's Avatar
    i keep thinking about this and i cant understand what is blocking the google services. i am able to install them all, google play store, google play services, the login services, etc. I even placed them inside the system/app folder and set their permissions identical to other system apps. What could be force closing them? Is there some way i could identify which program is closing them and disable it? Is it a deeper firmware block on them or something? Do you think getting S-off and isntalling a new firmware would enable google services or the ability to put a ROM on the phone?

    Also my phone seems to be only identified by adb while i am in TWRP, not sure what thats all about. How do i check my firmware version?
    03-08-2015 03:44 AM
  10. whitelunchbag's Avatar
    You shouldn't be flashing M8 ROMs on the M8 EYE. Just asking for trouble

    Posted via the Android Central App
    03-08-2015 06:16 AM
  11. nolanite's Avatar
    UPDATE

    after bricking by accident(lawl) i was able to install a stock version ROM for the M8Et EYE 4.4.4 which had GOOGLE apps, playstore, services, etc enabled and WORKING. It still requires a VPN to connect(obviously) but they work and do NOT force close like the stock ROM you have when you buy the phone.

    Breakdown:

    Unlock loosing basic walkthroughs aka adb and HTC website.

    TWRP backup, at this link(specifically for the M8Et EYE) because other version of TWRP for the M8 will not work

    www dot rootzhushou dot com/ndetail/772 dot html (i cant link, sorry)
    this is the link(kind of) to a version of TWRP that will work on the M8Et EYE

    Now backup your current stock ROM.

    Now install a new uber stock ROM with google apps and no force closing BS.

    im working on uploading the .rar of the file to google drive, but until then,

    GOOGLE the file name, "KTU84P_M8_EYE_1.00.1400.1.rar"

    this will return chinese websites and download links, use right click translate page(chrome), to do your best. Most likely you will need to install Baidu to install the file. Baidu is safe, it is basically a program which gives you access to cloud files. This can be tricky to get the file, but its well worth it if you have an M8Et EYE, because nothing else ive found will enable you to use google apps on your phone.

    TO INSTALL ROM - this is the file version of a BACKUP. So, to install, you will have to install it like you would revert to another backup ROM. Find your TWRP backup folder and place the unzipped .rar (or rather the file folder of the same name inside) into that folder. NOTE: It will just be a folder, not a zip or rar. Backups are installed from folders, not zips.

    I hope this helps any of my fellow expats in China with an M8Et EYE. It has made my life SO MUCH better.

    Ill update this with a google drive link to the ROM once ive uploaded it. Until then, chinese download/Baidu cloud is your only option. Good lucks.
    03-10-2015 09:15 PM
  12. nolanite's Avatar
    google drive file link soon
    03-11-2015 02:13 AM
  13. theilsanne's Avatar
    Hi!

    I have an M8 EYE as well, and I was able to successfully root and activate all the Google applications etc. on my phone, and disable all the Chinese ones - this was in December/January. I updated to Android 5.0.1 (Lollipop) by accident, and now my Google apps don't work anymore, the error message being "unknown issue". Would anyone know if re-rooting in the same way would help me out? The OS is different, and I understand that, but I wasn't sure what exactly helped me activate Google last time either. I was in the process of 'unrooting' when they activated for me.

    Can someone please point me in the right direction?
    05-17-2015 05:47 PM

Similar Threads

  1. Replies: 1
    Last Post: 03-07-2015, 05:44 AM
  2. Can I get Bluetooth on my Nextbook 8?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-07-2015, 05:35 AM
  3. Why can't I enable dual SIM sending on Go SMS?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-07-2015, 05:20 AM
  4. Replies: 0
    Last Post: 03-06-2015, 11:36 PM
LINK TO POST COPIED TO CLIPBOARD