09-24-2015 08:51 PM
128 1234 ...
tools
  1. gregorylj's Avatar
    yes. i was on tech support with at&t and we basically established that the issue was entirely about migrating from iPhone. I turned off all messaging on my old iPhone (that I've been using as an iPod touch) and deleted the threads where I had group texts on both the HTC and the iPhone. This helped in many cases, but I'm still having the issue with some others. I may go back and delete all the text messages and iMessages on my old iPhone. The other advice offered was to ask the people texting you to check their contacts and make sure they don't have you listed as an iPhone in their iPhone.
    04-25-2014 10:58 AM
  2. J-Dam's Avatar
    My text messages get sent almost instantly to everyone except iPhone users. They eventually get sent, but usually take a minute or two....or three.
    04-25-2014 01:19 PM
  3. craftmatic35's Avatar
    yes. i was on tech support with at&t and we basically established that the issue was entirely about migrating from iPhone. I turned off all messaging on my old iPhone (that I've been using as an iPod touch) and deleted the threads where I had group texts on both the HTC and the iPhone. This helped in many cases, but I'm still having the issue with some others. I may go back and delete all the text messages and iMessages on my old iPhone. The other advice offered was to ask the people texting you to check their contacts and make sure they don't have you listed as an iPhone in their iPhone.
    You may need too call Apple support and get them to remove your number from their imessage system. I have seen on various forums where that was the only way former iPhone users were able to receive texts from those that still have iPhones.

    Sent from HTC One M8 Using AC Forums app
    LelandC and Dizfunctions like this.
    04-25-2014 01:37 PM
  4. jim32940's Avatar
    I am on Sprint and having exactly the same issues. Outgoing texts not going and multiple copies of incoming texts received.
    04-25-2014 09:31 PM
  5. jim32940's Avatar
    I am having same texting issues with my new m8 on Sprint. Texts will not send . Receiving multiple incoming texts. Thinking about s5 instead. But have found s5 with same issues on forum. You note works.,thinking about just going back to my HTC Evo Lte it was working ok.
    04-26-2014 07:16 AM
  6. accordngs's Avatar
    I came from an S4. Had the same issues regardless if any people in the group text have an iphone. I recall seeing a thread on XDA about this too. HTC definitely has a bug with their MMS.
    04-26-2014 09:43 PM
  7. Dizfunctions's Avatar
    It has to do with imessage. You have to remove your number from everywhere you are logged in on imessage and log out of imessage

    Sent from my LG-D801 using Tapatalk
    04-27-2014 01:14 PM
  8. Cali4nnya's Avatar
    I got my M8 a week ago today. It was amazing the first 3-4 days. I am now having issues sending text messages. I am also having issues sending screenshots and pics. It says the file is too big for the recipient. Sending simple photos and screenshots shouldn't cause an issue where file size is concerned.
    And btw, I didn't not switch from IPhone. My previous phone was an Android as well.
    05-02-2014 04:21 PM
  9. 4cdndctn's Avatar
    AT&T M8 --- same issue. 2 phones, 4 SIMs and still having intermittent issues sending. I may be getting rid of the M8.
    06-02-2014 09:09 PM
  10. aramos87's Avatar
    I haven't had a single issue with sending or receiving texts and I have had the M8 since day one, also on AT&T. Where are you guys that are having issues located?
    06-02-2014 09:27 PM
  11. 4cdndctn's Avatar
    North Jerz

    Sent from my HTC One_M8 using Tapatalk
    06-02-2014 09:31 PM
  12. aramos87's Avatar
    Has it been just today? Or has it been happening frequently? I only ask because sometimes AT&T has outage issues.
    06-03-2014 12:01 AM
  13. 4cdndctn's Avatar
    Has it been just today? Or has it been happening frequently? I only ask because sometimes AT&T has outage issues.
    I have been through 2 phones and 4 SIM cards to no avail. Multiple account setting changes as every tech I speak with thinks they are going to be the hero to resolve the problem.

    Sent from my HTC One_M8 using Tapatalk
    06-03-2014 04:21 AM
  14. dty06's Avatar
    I've never had issues with texting unless I've had poor signal quality. But that's only happened once, so no complaints from me. I'm using a One M8 on VZW.
    06-03-2014 08:20 AM
  15. accordngs's Avatar
    I haven't had a single issue with sending or receiving texts and I have had the M8 since day one, also on AT&T. Where are you guys that are having issues located?
    But have you had issues with MMS messages? I have found SMS works fine but the second I add a picture or make it a group text - it converts to MMS and is unreliable. The messages will not always send and take multiple attempts.

    The other problem is you might not know if you aren't receiving them because .... well... you wouldn't be receiving them. I only figured it out when I was in a group chat and saw one of the other guys phones also in that group chat. I then realized I was missing a whole bunch of messages coming my way.
    06-03-2014 01:39 PM
  16. aramos87's Avatar
    But have you had issues with MMS messages? I have found SMS works fine but the second I add a picture or make it a group text - it converts to MMS and is unreliable. The messages will not always send and take multiple attempts.

    The other problem is you might not know if you aren't receiving them because .... well... you wouldn't be receiving them. I only figured it out when I was in a group chat and saw one of the other guys phones also in that group chat. I then realized I was missing a whole bunch of messages coming my way.
    I had those issues, not receiving messages, before on my M7. All I had to do was get a new SIM card, which are free from an At&t store. Once I put in a new SIM, I had zero issues.
    06-03-2014 02:57 PM
  17. accordngs's Avatar
    I had those issues, not receiving messages, before on my M7. All I had to do was get a new SIM card, which are free from an At&t store. Once I put in a new SIM, I had zero issues.
    I'm already on my 2nd HTC M8 and my 2nd sim card... problem isn't as bad on the 2nd phone but still there. (I'm Verizon btw)
    06-03-2014 05:17 PM
  18. aramos87's Avatar
    I'm already on my 2nd HTC M8 and my 2nd sim card... problem isn't as bad on the 2nd phone but still there. (I'm Verizon btw)
    I'm pretty sure Verizon only uses their SIM cards for LTE, where as At&t use it for voice, sms/mms, and data. My issue was while using AT&T, which is probably getting a new SIM fixed it.
    06-03-2014 09:33 PM
  19. youeatlard's Avatar
    I am having issues with txt not sending or delayed sending. I receive txt ok but have repeated issues with sending. One out of every 5 to 10 will completely fail to send no matter where I am. Verizon can not figure it out. Is anyone else having any issues with txt.
    As far as I can tell it's an HTC specific software issue. It only seems to happen to me when multiple networks are present. My guess is that for me it's probably the Sprint Connection Optimizer. I can only guess that Verison has something doing the same under a different name. (Probably the same HTC program rebranded by the carriers.). Whatever it or it's gateway's issue is, I get delayed or double text messages sent often with my M8 and MMS pictures fail about 50% of the time.

    I believe it has to do with the way the phone handles data when the screen is off, but I'm not sure.

    I'll try deleting the optimizer program and update later.
    06-13-2014 08:10 AM
  20. 4cdndctn's Avatar
    As far as I can tell it's an HTC specific software issue. It only seems to happen to me when multiple networks are present. My guess is that for me it's probably the Sprint Connection Optimizer. I can only guess that Verison has something doing the same under a different name. (Probably the same HTC program rebranded by the carriers.). Whatever it or it's gateway's issue is, I get delayed or double text messages sent often with my M8 and MMS pictures fail about 50% of the time.

    I believe it has to do with the way the phone handles data when the screen is off, but I'm not sure.

    I'll try deleting the optimizer program and update later.
    I too noticed the majority of my issues occur when I send a quick text then the screen is turned off, usually by my dot matrix case closing. ATT claims they are not having these issues with other HTC One's, meanwhile I'm on my 3rd (3rd SIM too), and I've had issues with all 3. My account has been re-provisioned multiple times so I'd like to think it's not an account setup issue which has occurred multiple times.
    06-13-2014 09:43 AM
  21. johnmcc0710's Avatar
    I have had a texting issue with Verizon and my M8 also. It is sporadic. I have sent messages and it is reported it is empty when received and at times I send a text and was told it was never received. I use the Verizon messaging app but it has also happened with Textra and the stock messaging app.

    I spoke with Verizon and we tested all seemed fine. Weird!!
    06-13-2014 09:55 AM
  22. Dizfunctions's Avatar
    I've had texting issues with my LG G2, but it resolved itself somehow and I have no idea how it happened...

    Sent from my LG-D801 using Tapatalk
    06-13-2014 01:46 PM
  23. youeatlard's Avatar
    I have had a texting issue with Verizon and my M8 also. It is sporadic. I have sent messages and it is reported it is empty when received and at times I send a text and was told it was never received. I use the Verizon messaging app but it has also happened with Textra and the stock messaging app.

    I spoke with Verizon and we tested all seemed fine. Weird!!
    Has it happened on 3G and 4G or only on 4G? Has it happened only while connected to a WiFi network? Happen more with the screen off?
    06-13-2014 04:41 PM
  24. ddot196's Avatar
    One thing I've noticed with HTC phones in regards to text is this: when I send a text and I immediately lock the phone, it will not send. It's almost as if the data cuts off for a split second when you lock the phone. This used to happen on my old HTC one x. I totally forgot about the problem until I started texting on this and noticed I'd pull my phone out and saw that my text failed to send. I had the moto x prior to the m8 and never had this sort of problem. But with HTC phones they always fail to send when I lock my phone as it is sending the text. Now I just send it and wait a second or so to make sure it sends before I lock it.

    Posted via Android Central App
    06-13-2014 06:52 PM
  25. johnmcc0710's Avatar
    Has it happened on 3G and 4G or only on 4G? Has it happened only while connected to a WiFi network? Happen more with the screen off?
    Hi has happened on 4G and at home a network extender which runs 3G and also on WiFi. I haven't payed attention as far as screen off. I suspect it may be an issue with the Verizon messaging app. I found out last night my messages were delayed to someone. I disabled the VZ messaging app and will run with the stock one. I do make sure that it says sent and the screen is on. I may change the timeout in the display higher too.
    06-14-2014 08:12 AM
128 1234 ...

Similar Threads

  1. HTC One in Captain America TWS
    By Regulator in forum HTC One M7
    Replies: 2
    Last Post: 04-06-2014, 09:01 AM
  2. HTC One (M8): Zoe Issue
    By HardMack in forum HTC One M8
    Replies: 1
    Last Post: 04-05-2014, 07:28 PM
  3. straight talk s4 active apn issues
    By waregurl in forum Samsung Galaxy S4 Active
    Replies: 0
    Last Post: 04-05-2014, 06:28 PM
  4. HTC One (M8) Clock
    By Geordie2 in forum HTC One M8
    Replies: 1
    Last Post: 04-05-2014, 05:42 PM
LINK TO POST COPIED TO CLIPBOARD