09-22-2015 08:06 AM
60 123
tools
  1. AshtonVibe's Avatar
    If I may offer some ways to fix this. Go to WiFi, then press on the option icon (three dots), then advanced. Here you will see some options to change.
    Make sure auto connect is on. Uncheck WiFi WAN detection. Keep WiFi on during sleep: set to ALWAYS. WiFi frequently ban on AUTO. Uncheck WiFi optimization. Uncheck auto switch to network.

    Posted via Android Central App
    05-24-2014 08:18 AM
  2. AshtonVibe's Avatar
    Now you should be able to get away with keeping WiFi optimization on and auto switch to data if you prefer. Each scenario will be different, and settings may depend on you provider too.

    Posted via Android Central App
    05-24-2014 08:21 AM
  3. kct1975's Avatar
    I'd just like to mention it again that, if you are with Sprint, your problem might be the Sprint Connections Optimizer. If you have it on your phone, I would strongly suggest that you remove it from your phone.

    Sent from my RCT6378W2
    05-24-2014 09:27 AM
  4. Krystal Deger's Avatar
    @Heytham Ajine, that worked for me! Thank you. My bf and I both have the M8 and we are both having this problem after the most recent software update. Thank you!
    05-26-2014 02:02 PM
  5. Krystal Deger's Avatar
    @Heytham Ajine, that worked for me! Thank you. My bf and I both have the M8 and we are both having this problem after the most recent software update. Thank you!
    05-26-2014 02:04 PM
  6. Griffin Walter's Avatar
    I am using D-link model and it works fine, what's the wifi model you were using?
    05-27-2014 01:10 AM
  7. Almeuit's Avatar
    I'll be getting the M8 soon. I'll let you know how it works with my AC router ( http://www.amazon.com/gp/aw/d/B00FB4...ref=mp_s_a_1_1).

    Sent from my T-Mobile Note 3 using AC Forums.
    05-27-2014 12:10 PM
  8. lyriciss's Avatar
    I have a Sprint HTC One M8 that I just bought on Saturday. No wifi issues yet. Let me knock on wood now, though.
    05-27-2014 01:36 PM
  9. jlaplante3's Avatar
    Thanks! Saved me a ton of time trying to troubleshoot!
    07-07-2014 07:20 AM
  10. cjr4497's Avatar
    My M8 is through Verizon, and I have no WiFi issues. My home WiFi password is 20+ characters as well.

    Sent from my HTC One M8 using Tapatalk
    07-07-2014 08:02 AM
  11. Nota Prophet's Avatar
    this worked better for me...you tube loads video feed much faster yet when push to play still takes forever to play...tried everything...called tmobil...called comcast...called htc...nobody can tell me anything....mobil data off works better....still have to restart phone every once in a while...i want my htc m8 to work i dont want to resort to getting another phone!
    08-15-2014 10:06 PM
  12. Carkid367's Avatar
    I randomly have our where my WiFi will either cut itself off (sprint m8 with connections optimizer off) or randomly when I'm on the phone it will not display the network I normally connect to, just the ones I don't. It happens at work and at home. Just tried to change the WiFi direct thing and I'll see if it helps

    Posted via Android Central App
    08-16-2014 06:41 AM
  13. kct1975's Avatar
    I randomly have our where my WiFi will either cut itself off (sprint m8 with connections optimizer off) or randomly when I'm on the phone it will not display the network I normally connect to, just the ones I don't. It happens at work and at home. Just tried to change the WiFi direct thing and I'll see if it helps

    Posted via Android Central App
    Just FYI...
    (I posted this earlier in the thread)

    Simply turning off the Sprint Connections Optimizer will not work, because I have found that it simply re-enables itself.

    The only way I have found to eliminate the Sprint Connections Optimizer from interfering with the WiFi, is to disable it. In previous versions of HTC Sense, you could disable it from the App menu in Settings, but now it seems that you have to root your phone to Freeze the App.
    08-16-2014 07:07 AM
  14. spaceskimo's Avatar
    This problem is driving me insane (I'm on Verizon btw). It's not my router either, it does this on every network I connect to. Lately it's becoming more and more frequent, in the last 24 hours it's probably dropped my connection 6 times. There's no sure fire way to get it working again either. I'll restart the router- nothing. I'll turn on and off the wifi and mobile data- nothing. I'll forget the access point- nothing. I'll restart the phone- nothing. Then it will just randomly connect back to the network several minutes later. This is completely unacceptable considering the cost of the phone, the whole reason phones are like this today is for their internet abilities. This is also my second HTC One M8, the first one was returned due to a stuck pixel. The first one had the same network problems, the new one I got wouldn't connect to the network straight out of the box (I thought it was broken) and seems to have worse wifi problems than my original one. It's unbelievably frustrating and HTC needs to send out a patch for this ASAP.
    08-16-2014 10:34 AM
  15. Alexander Buff's Avatar
    I'm having the same issue as well on a T mobile M8 .... The only fix that has worked is to turn the wifi off and back on again. I have energy saver on but I didn't think that would effect anything because I'm usually over 70% battery life.
    08-16-2014 05:58 PM
  16. Android Optimizer's Avatar
    It's not my router either
    What about your modem? Do you have the two combined? Is your modem old? (Having a DOCSIS 3.0 modem can make a huge difference when it comes to staying connected to the Internet). Older modems can drop connections without you even knowing it. Your router may make everything look fine on its end, but if your modem is dropping the connection your router may not even know it. As far as your home connection goes: What type of service do you have for your wifi, what model router and modem are you using, how far are you away from your router when using your phone for wifi, if you run a speed test on some where like speedguide.net, speedtest,net, or Speed Test | Time Warner Cable (if you're on TWC) what does it say. (Test it using both your phone and a computer).

    Since not everyone with an m8 on Verizon is having the problem (myself being one person who has an m8 on Verizon, and has no problem) I don't think you can blame it on HTC.
    Post your wifi and mobile data settings, those of us without the problem can tell you where our settings differ, and then maybe you can alter your settings to get it working.
    08-16-2014 06:26 PM
  17. Beth E's Avatar
    Thanks! This worked for me!
    11-01-2014 12:41 AM
  18. Lok52's Avatar
    Spent the next to the last week here at home on WiFi the entire time, no problems. Gone for a week when the only thing I did to my phone was get the 4.4.4 update from Verizon, now it won't connect to my home WiFi. It just keeps cycling through "Connecting..." and "Saved,secured with WPA"
    11-01-2014 07:52 PM
  19. Android Optimizer's Avatar
    Spent the next to the last week here at home on WiFi the entire time, no problems. Gone for a week when the only thing I did to my phone was get the 4.4.4 update from Verizon, now it won't connect to my home WiFi. It just keeps cycling through "Connecting..." and "Saved,secured with WPA"
    I've heard of some people having that issue fixed it by:
    Telling the phone to forget the network
    Unplug the router for a few minutes. (If you have a separate modem you might as well unplug that at the same time).
    Plug the router back in after a few minutes unplugged (and the modem if you unplugged that too)
    Have your phone create a fresh connection to that network

    If that doesn't work a system clear cache might do something for you. (If you haven't already tried that).
    11-01-2014 10:08 PM
  20. Lok52's Avatar
    I've heard of some people having that issue fixed it by:
    Telling the phone to forget the network
    Unplug the router for a few minutes. (If you have a separate modem you might as well unplug that at the same time).
    Plug the router back in after a few minutes unplugged (and the modem if you unplugged that too)
    Have your phone create a fresh connection to that network

    If that doesn't work a system clear cache might do something for you. (If you haven't already tried that).
    I tried clearing the system cache already, no good. I will try unplugging stuff when I get gone this weekend.

    Posted via Android Central App
    11-03-2014 08:01 AM
  21. turner75's Avatar
    ATT M8 4.4.2. changed my passcode to less than 9 characters like thesuperjmart said. Stays connected now.
    11-30-2014 12:12 PM
  22. cushy1863's Avatar
    Had a similar problem on home network with HTC one m8 and sky hub connection intermittently dropping off, switch off WiFi on phone then back on then it would be ok for a while, so went into sky hub router settings and checked connected devices, HTC showing but Mac address different than showing in phone settings so deleted phone from router connected devices then
    manually entered phone Mac address as found in advanced settings in phone WiFi settings, into router
    this seems to have fixed problem so far, fingers crossed
    12-02-2014 02:44 PM
  23. Jerouk's Avatar
    I'm having this problem over in the UK
    To qualify:
    phone: HTC One m8 running 4.44.
    Symptoms: wireless connection dropping (on work and home network). Unable to reconnect without a restart on phone.
    Wireless Router: British Telecoms home hub.
    What I've done so far: renamed device, tweaked advanced wireless settings, primarily turning off battery saving optimisation on wireless.
    I'm not rooting my phone in a hurry as I'm on a good insurance package that will be voided if I do that :-p
    The MAC address issue sounds promising as it would explain the symptoms somewhat, though why the router would lose/misread the correct address for the phone is beyond me.
    I'll look at this if the problem reoccurs and report back either way.
    Cheers all,
    J
    12-03-2014 06:11 AM
  24. johnny--2k's Avatar
    I think I have figured out what is going on with this wifi problem.

    It seems to be interference with the bluetooth raido and i spent over an hour on the phone with HTC to confirm this.

    If you have wifi and BT radios both on, but BT is NOT paired to anything, it seems to be scanning constantly and interfering with the wifi signal, causing it to slow down significantly or drop completely. I was able to duplicate this without fail multiple times using speedtests.

    If you do try this, and get similar results, please call HTC support and report it. Since I was the only one that HTC has heard from, they can't do much yet until more people report and they can look further into it.
    12-05-2014 04:45 PM
  25. Rashid Mohamed's Avatar
    Hi every one, I've been using HTC M8 for a while. I'am happy with the phone except the WiFi issue I'am facing in my Office.
    The WiFi over here is a WPA-Personal with TKIP Encryption with 10 character password.
    After saving this connection when I select it,it shows Signal strength: Excellent and security: WPA PSK.
    When I try clicking Connect it shows: saved, secured with WPA. After some time it disconnects automatically.
    I have tried everything I've seen in the blog .

    Every one else in my office is getting the WiFi connection except me. And I'am able to connect my WiFi at home where there is WPA2-Personnal With AES encryption and 10 Character password.

    Can any one help please?
    12-08-2014 07:52 AM
60 123

Similar Threads

  1. Replies: 17
    Last Post: 04-01-2017, 09:40 PM
  2. Language and location issues in Google play store on my PC
    By briancook451 in forum Google Play Store
    Replies: 3
    Last Post: 06-15-2014, 11:08 AM
  3. Samsung Galaxy S4 Wifi problems
    By thefreak75 in forum AT&T Samsung Galaxy S4
    Replies: 5
    Last Post: 04-14-2014, 03:34 AM
  4. only have wifi and my phone please help root all info in body.
    By Lj Lj in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 04-07-2014, 02:02 AM
  5. Anyone connect their Samsung Mega to an Apple keyboard?
    By robotmac in forum Samsung Galaxy Mega 6.3
    Replies: 0
    Last Post: 04-06-2014, 09:34 PM
LINK TO POST COPIED TO CLIPBOARD