09-22-2015 08:06 AM
60 123
tools
  1. Daverk's Avatar
    The more report to htc the better

    Sent from my tablet or smartphone using Tapatalk
    kct1975 likes this.
    12-08-2014 10:33 AM
  2. kct1975's Avatar
    Hi every one, I've been using HTC M8 for a while. I'am happy with the phone except the WiFi issue I'am facing in my Office.
    The WiFi over here is a WPA-Personal with TKIP Encryption with 10 character password.
    After saving this connection when I select it,it shows Signal strength: Excellent and security: WPA PSK.
    When I try clicking Connect it shows: saved, secured with WPA. After some time it disconnects automatically.
    I have tried everything I've seen in the blog .

    Every one else in my office is getting the WiFi connection except me. And I'am able to connect my WiFi at home where there is WPA2-Personnal With AES encryption and 10 Character password.

    Can any one help please?
    Just thought I'd mention it...If your HTC M8 is a Sprint device, I would highly recommend that you completely disable the Sprint Connections Optimizer.

    When I first got my M8, that stupid app was what was screwing up my WiFi connectivity.
    12-21-2014 10:17 AM
  3. anhanh's Avatar
    I having the same problem as you guys too. i tried to do everything you guys mentioned but the wifi still cannot connect to the phone. My phone is AT&T HTC One M8 not Sprint
    01-04-2015 11:43 AM
  4. nawb84's Avatar
    I having the same problem as you guys too. i tried to do everything you guys mentioned but the wifi still cannot connect to the phone. My phone is AT&T HTC One M8 not Sprint
    This is the only issue I have had with the device. My HTC one is unlocked and non branded running : android 4.4.4
    The only fix that worked for me was disabling the "do not disturb" feature and setting the following :

    Under wifi setting - advanced - keep wifi on during sleep - set to never
    Under power saving setting - uncheck data connection
    Under power setting - sleep mode set to off

    With this configuration my wifi connection still goes to sleep during screen off however I do not get the issue of wifi failing to reconnect after sleep.

    Previously the only thing I could do was restart the device. Something in the data connection power settings are surely conflicting which htc should remedy immediately!
    01-29-2015 04:18 PM
  5. Vladimir Sitnik's Avatar
    hello everyone, if you recently reassambly your phone in my case is HTC One M7 and after you have a very low signal. You need to switch inside your phone 2 short connectors blue and black (don't intersect position) from mainboard to smallest one on top of the phone. After this procedure i keep my signal again.
    02-01-2015 12:34 AM
  6. BBwhat's Avatar
    That fixed it! Turned bluetooth off and wifi connected instantly. Thank you, and I will follow up with a call to HTC.
    03-05-2015 09:47 AM
  7. AshleyLee Gaming's Avatar
    Had same wifi problems, change wifi router pw to an 8 char one, it was 11, and its worked fine since.
    kct1975 and bobbyhung1 like this.
    06-26-2015 07:28 PM
  8. Tomatic123's Avatar
    I see this is quite an old thread, but still high on searches.
    I had this problem too and did a couple of things which seem to have sorted it out (so could be either of them):
    1. Freed some space (my phone's internal memory was low).
    2. Disabled "Ok Google" command availability from any screen: Launch the Google app => Click the menu bars (top left) => Click Settings and go to "Voice" => "Ok Google detection" => Switch off the "From any screen" option.
    Sorted!
    bobbyhung1 likes this.
    07-17-2015 04:50 AM
  9. bobbyhung1's Avatar
    Thank you so much! Disabling "from any screen" did the trick for my T-mobile m8.
    I was going crazy trying to figure out why it was at half speed on WiFi. Much appreciated, thanks again.
    07-18-2015 09:18 PM
  10. Troy Richey's Avatar
    I fixed mine by disabling my Bluetooth radio like Johnny had mentioned. Finally, got mine to work after a month of messing with it and getting a replacement phone! Guess I will just have to toggle my Bluetooth radio.... HTC / all the carriers need to resolve this ASAP! Its quite ridiculous their tech support can't figure it out!

    Posted via the Android Central App
    09-22-2015 08:06 AM
60 123

Similar Threads

  1. Replies: 17
    Last Post: 04-01-2017, 09:40 PM
  2. Language and location issues in Google play store on my PC
    By briancook451 in forum Google Play Store
    Replies: 3
    Last Post: 06-15-2014, 11:08 AM
  3. Samsung Galaxy S4 Wifi problems
    By thefreak75 in forum AT&T Samsung Galaxy S4
    Replies: 5
    Last Post: 04-14-2014, 03:34 AM
  4. only have wifi and my phone please help root all info in body.
    By Lj Lj in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 04-07-2014, 02:02 AM
  5. Anyone connect their Samsung Mega to an Apple keyboard?
    By robotmac in forum Samsung Galaxy Mega 6.3
    Replies: 0
    Last Post: 04-06-2014, 09:34 PM
LINK TO POST COPIED TO CLIPBOARD