1. nav525's Avatar
    So I've had my M8 since it came out on Verizon and recently for the past month or so I've had trouble with texts. What happens is that it will take a really long time for the text to actually send. The icon indicating that it's sending will sometimes be there for a few minutes before it sends. Sometimes it won't send at all and I'll get a popup saying "general sms error". I've found that factory resetting the phone fixes the problem, but after about a week or so the problem returns. I've reset it twice now and both times texts were going out instantly for about a week. Then randomly I would have the problem again. It doesn't seem to be any particular app that is causing the problem. I went into Verizon once and they didn't seem to know what was going on. Any ideas guys? I don't want to have to reset my phone all of the time.
    09-03-2014 03:10 PM
  2. CountryDevil's Avatar
    Someone correct me if I am wrong here...

    On Sprint there is a MSID number in the configuration that when I new phone is provisioned and the old phone you had is still technically still not full un-provisioned it can cause problems like this. The fix, with a tech/CSR on the line knowing what they are doing, is to factory hard reset the phone so it clears all provisioning data. right before you turn it back on the CSR will re-provision the phone on the back end giving your phone a new MSID number. Once you phone is provisioned and back on the network, text messages will work as expected. I know this because I had the exact same issue a few times when I have got a new phone. With Verizon, I am sure that the fix is similar since they are both CDMA based techs.
    09-03-2014 04:37 PM
  3. Jeff Harris's Avatar
    my Verizon one m8 does this as well. I just hold the power button and reset,seems to work
    09-05-2014 09:16 AM
  4. nav525's Avatar
    Bump. So I found that booting the phone into safe mode usually fixes the problem temporarily. so that's what I've been doing every time the issue resurfaces. However, today the safe mode trick isn't working. I would like to find a permanent solution because this has become really frustrating as you guys can probably imagine. Anyone else have an idea of what could be going on?
    09-30-2014 12:59 PM
  5. salm04's Avatar
    Are you using any 3rd party apps for sending your txts?
    10-02-2014 07:43 PM
  6. sitlet's Avatar
    10-03-2014 10:07 PM

Similar Threads

  1. WIFI Problems
    By AC Question in forum Ask a Question
    Replies: 6
    Last Post: 07-19-2015, 05:00 PM
  2. Compatibility with 128gb microSD (via adapter)?
    By Jeremy8000 in forum Nexus 5 Accessories
    Replies: 1
    Last Post: 09-09-2014, 09:02 AM
  3. Htc one mini 2 speaker problem
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-03-2014, 05:53 PM
  4. WIFI Problem with S5 Slowing Down DSL
    By Mwettig in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 09-03-2014, 04:46 PM
  5. $50 off on HTC One M8 with upgrade from EVO 4G LTE
    By jwbekens in forum HTC EVO 4G LTE
    Replies: 0
    Last Post: 09-03-2014, 02:33 PM
LINK TO POST COPIED TO CLIPBOARD