1. tomwall43's Avatar
    I have recently purchased myself and another of my colleagues an HTC One M8. We also have another colleague who has had an M8 for some time.

    The two new devices I setup as ExchangeActiveSync accounts on the stock mail client. The other user has set his up as IMAP/SMTP. As a company we use office365 for our email solution.

    Here is an example of the issues I am having:

    This morning I received 11 emails, they all came into the inbox fine, I then received a 12th email. At this point the previous 11 emails were removed from the inbox. However all these email still remained on the server. It doesn't seem to have any pattern, it could be the first or the 20th email I receive and it doesn't always remove all the previous emails. It could just be the last 4 or 5. The Sync period was set to 30 days.

    The other user who has the IMAP setting says he experiences the same issue and always has done.

    I am rather puzzled, I have spoken to people from Vodafone, HTC and Microsoft, but nobody seems to have a clue. I have tried other mail clients on the phone and they seemed to work, I also have the same account on a Google Nexus which works without issue.

    Any ideas?!
    10-15-2014 12:44 PM
  2. oneeyecarpenter's Avatar
    It seems this is a very active issue over many years,I googled it and lots of pages with your issue. Here is a possible answer from a post 2007, answer 2011.

    up vote
    1
    down vote
    I know this is an older post, but I have had this issue before.

    When the phone syncs with the server it sees the email, but outlook is naturally slower to sync than phones (I have no idea why, they just do). When the outlook client sees a new email come in it puts that email in the default folder group (Personal folders, Mailbox, Archive, etc). This can be changed in outlook (2003) by selecting tools> email accounts> view/change accounts> then there is a drop down labeled "deliver email to the following location:" This will have all the folder groups listed.

    Make sure to set the default to the "Mailbox - User" folder group. This is the server mailbox, any other option will remove the emails from the server and move them to the computer locally, thus rendering all of Exchange recovery tools useless on that mailbox.

    What happens now:

    email is received at server.

    phone syncs with server.

    outlook syncs with server.

    outlook moves email from server to default folder (probably set to a "Personal Folder" group)

    Phone syncs back with server which has lost the email due to it being moved to the computer running outlook client.
    10-15-2014 09:36 PM
  3. oneeyecarpenter's Avatar
    I think your answer is here,in manual configuration. Screenshots are included in his article. Hope I have enough post to add this link.

    https://www.google.com/url?sa=t&sour...ouvCPw3EpKszVg
    10-15-2014 09:55 PM
  4. tomwall43's Avatar
    Thanks for the reply, but I am afraid this is not the solution. I am using Exchange on Outlook which syncs with the server and never deletes or moves an email unless I manually do so.

    My problem is that the phone is almost randomly hiding or masking items on the phone that are still on the server. As per my example, I receive email onto my phone fine for a random period of time, could be minutes could be hours. Then an email will come in and x amount of the most recent emails before it, will no longer be on the phones inbox. But will still be on Outlook.

    I will check the compatibility for active exchange as per your link.
    10-16-2014 02:39 AM
  5. tomwall43's Avatar
    Interestingly I changed the Mail Size Limit settings back to 5kb from the maximum setting - I've gone over 12 hours without an issues which is the longest so far. I will keep you posted.
    10-16-2014 02:41 AM
  6. tomwall43's Avatar
    The issues occurred again just now... Interestingly it wasn't when receiving a message. Just a normal sync.

    This only happens on the HTC mail client. All other clients I have used work without issue
    10-16-2014 08:42 AM
  7. johnmcc0710's Avatar
    You might try another mail app. I am using Touchdown and it works great.
    10-16-2014 09:01 AM
  8. Benjamin_NYC's Avatar
    Nine is the best email app for MS Exchange Active Sync. Every single one of the others is garbage that doesn't do MS Exchange properly. Do not listen to any other advice, and get only the Nine email app. You will waste your time with any other.

    Posted via the Android Central App
    Crashdamage likes this.
    10-16-2014 09:35 AM
  9. tomwall43's Avatar
    Thanks for the advice all, I am now using Nine and I do agree with Benjamin that it is the best for exchange active syc. Especially if you're use to Gmail, as the interface is very similar. In regards to the HTC client, HTC Europe were able to reproduce the issue with a test account I setup on our domain. They have now passed it up the line, hopefully they will fix this for anyone else with the same issue.
    10-22-2014 01:15 PM
  10. Keith Byrne's Avatar
    for me it was an outlook setting, go the the email account settings, choose more settings (i am on outlook 2007), click the advanced tab, then increase the number of days an email is left on the server. 20 would probably do it. Now it is not deleted from the server (and therefore your phone) when the message is read in outlook.
    02-10-2016 08:37 AM

Similar Threads

  1. Howdy from Texas
    By planobrett in forum New to the Forums? Introduce Yourself Here!
    Replies: 10
    Last Post: 10-19-2014, 11:37 AM
  2. Replies: 2
    Last Post: 10-15-2014, 03:19 PM
  3. Google just announces HTC-made Nexus 9 tablet,
    By Shilohcane in forum Google Nexus 9
    Replies: 2
    Last Post: 10-15-2014, 01:22 PM
  4. Why have I stopped getting my incoming emails?
    By vivian4him in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 10-15-2014, 01:13 PM
LINK TO POST COPIED TO CLIPBOARD