1. Benjamin_NYC's Avatar
    Used the new Moto Turbo Charger (Quick Charge 2.0) charger with success on my M8 when it was Sense.

    Now I've converted it to a GPE edition, and 2 of the 3 times I've used the charger since, the battery meter becomes stuck during/after the charge. Once at 64%, once at 80%. Restarting the phone gets it working again.

    So I'm thinking the battery has become uncalibrated? Would draining it to 0%, then charging it non stop to 100% be away to fix this?

    One site said wipe the cache partition and Dalvik cache. Another suggested something with both volume keys that wipes the battery memory.

    Other suggestions?

    Posted via the Android Central App
    10-27-2014 05:34 PM
  2. Benjamin_NYC's Avatar
    I think QC 2.0 just doesn't work for me after the GPE conversion. I show -2600mA for about a minute then it drops to -200mA and the meter gets stuck.

    Posted via the Android Central App
    10-27-2014 08:23 PM
  3. Benjamin_NYC's Avatar
    Wiped cache partition and charger works for a few minutes and then jams up the battery meter. Normal 2A charger doesn't jam it up.

    Maybe something wrong in my GPE conversion.

    Posted via the Android Central App
    10-27-2014 08:34 PM
  4. Mooncatt's Avatar
    I've been trying to think of some explanation, but I'm not coming up with anything. I don't know about flashing new ROMs and such, though it certainly sounds related to the conversion.

    Just for clarification, are you saying the battery actually stops charging at 80%, or the meter stops there but the orange charging light remains lit longer and the battery is going to a full charge? Once the meter gets stuck, does it stay there a long time after unplugging before starting to deplete? Basically I'm just trying to narrow it down to either a a software/calibration issue or if the battery itself isn't accepting the charge.
    10-27-2014 10:23 PM
  5. Benjamin_NYC's Avatar
    I've been trying to think of some explanation, but I'm not coming up with anything. I don't know about flashing new ROMs and such, though it certainly sounds related to the conversion.

    Just for clarification, are you saying the battery actually stops charging at 80%, or the meter stops there but the orange charging light remains lit longer and the battery is going to a full charge? Once the meter gets stuck, does it stay there a long time after unplugging before starting to deplete? Basically I'm just trying to narrow it down to either a a software/calibration issue or if the battery itself isn't accepting the charge.
    Thanks for your response.

    The battery actually keeps charging. It's just the meter that gets stuck.

    So yesterday I left it charging for an hour and unpluged it. Meter said 80%. Then I noticed after an hour of solid use, the meter still said 80%. So I did a restart. Then the meter said 84%, and was working. So it had obviously charged up to 90%+, but while on the Turbo charger, the meter had gotten stuck at 80%.

    Does that make sense? Very strange.

    Posted via the Android Central App
    10-28-2014 06:38 AM
  6. Benjamin_NYC's Avatar
    So it's some software issue for sure.

    Posted via the Android Central App
    10-28-2014 07:23 AM
  7. Benjamin_NYC's Avatar
    Maybe this version of the GPE software isn't ready for QC2.0?

    Posted via the Android Central App
    10-28-2014 07:23 AM

Similar Threads

  1. Do you use s voice?
    By thegame161 in forum Samsung Galaxy Note 4
    Replies: 19
    Last Post: 11-12-2014, 05:26 PM
  2. Does phone overheatting cause battery damage?
    By Kerihawk in forum Sony Xperia ZL
    Replies: 2
    Last Post: 11-11-2014, 05:10 AM
  3. Replies: 3
    Last Post: 10-28-2014, 08:41 AM
  4. Replies: 1
    Last Post: 10-27-2014, 11:14 PM
  5. Replies: 6
    Last Post: 10-27-2014, 04:10 PM
LINK TO POST COPIED TO CLIPBOARD